Question about Fuji FinePix A303 Digital Camera

1 Answer

Slow camera Thank you for the suggestions. I got the camera about 6 years ago and it worked fine. The problem started recently, over the last few months. It cannot be related to the card, or the processor. They were the same when it worked well. It is charging up very slowly. I think it is either a capacitor or a rechargable battery that lost performance over time. Do you know anything about the inside battery?

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

  • Expert
  • 52 Answers

Unfortunately, the externals you use are AA's so I'm sure you've tried new ones there.   The internal battery (or capacitor) is not worth attempting to replace for a camera of that age. You may end up spending more to replace the battery then you would to upgrade to a new, higher resolution camera.  Good Luck,  NGK

Posted on Sep 05, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Hi. i have sony w120. its not new, i bought it cca 3 years ago. I didnt use is for a quite a while (but my family did), so few days ago, i realized when i take pictures, pictures are somehow blurry,...


Please go to Setup menu and select Initialize option to reset camera to default settings that might solve blurry picture problem, if that does not help then its technician job to adjust focus of camera.
Thanks.

Aug 02, 2011 | Sony Cyber-shot DSC-W120 Digital Camera

Tip

I have the same problem with a Canon Powershot s20. Bought approx 5 years ago...


Many digital cameras (eg Samsung D53, Nikon 2100) have extremely poor battery life with alkaline batteries (under 20 shots!). Sometimes they won't even take a single picture.

Try using rechargeable batteries or "oxyride" disposable batteries. They perform infinately better.

on Jan 28, 2008 | Samsung Digimax D53 Digital Camera

1 Answer

I am using this camera from last 3 years. It was working fine. Suddenly, a problem occurred. Now whenever I select the Auto mode, it is set to video option instead of still image. I have formatted...


I'm have the exact same problem. Purchased the camera 3.5 years ago. Recently needed to shoot a video, when finished I set the camera back to Auto and it stayed in video. Portrait mode shows manual, all other modes work as assigned. I've noticed at least TWO other posters having the same problem within the last couple of months. It's as though this camera (mfg. 2007) has a Trojan program from the factory to make us buy newer models.

Other than resetting, is there a way to flush and reload the firmware?

May 06, 2011 | Canon PowerShot A570 IS Digital Camera

1 Answer

My bravettii slow cooker would not cook baked beans they cooked for 18 hrs total 6 hrs was on high and 12 hrs was on low and the beans are still not fully cooked it never came to a boil is there...


Hello,
I can't solve your problem but I can sure relate. I am having the same problem with my Bravetti Pro (it's far from Pro - it should be called Bravetti Amateur) I tried cooking a small ham with cut up potatoes recently, and after 11 hours cooking at the medium setting, the potatoes were not cooked. I got this thing as a gift about a year ago, and although I've only used it a few times, it never seems to cook properly. Mine was purchased at Canadian Tire and although I don't have a receipt, I think I'll try to take it back. Good luck with yours!
Tom

Feb 08, 2011 | Bravetti PC107HA Slow Cooker

1 Answer

When I recently turned on my camera (D-630 Zoom) to take a picture, I got the message titled Card Setup, with two options "Power off" and "Format". I turned the camera off, took out the...


If this exact card has worked in the camera before, chances are it has gone bad. Typically, if the camera says to format the card it is because it does not recognize the card. The only reason this would happen is if the card is unreadable from malfunction, or it is too new of a technology for the camera to recognize.

Dec 17, 2010 | Olympus D-630 Zoom Digital Camera

1 Answer

Easyshare C713 LCD view is flushed out.


you push on the little 'i' button thats right under the delete button.
(:

May 14, 2009 | Kodak EasyShare C713 Digital Camera

1 Answer

Slow rotation of the ceiling fan


Who do you think is 'you'? Electronics technician indeed. Take it down hot from running and find out what's sucking up all the juice; bearings, windings, controls, etc.

Don't take a year at servicing things if you can help it....

Aug 12, 2008 | Dryers

2 Answers

Quantary 100-300mm telephoto lense


I have been researching this problem and found there's nothing you can do. Appararently, the quantaray, being an older lens, wasn't made to work with this latest era of cameras. Though it might work perfectly with your older camera, its technology is outdated as it relates to digital cameras and can't mesh with the latest and greatest. By the way, most of my questions were answered on the Digital Camera Resource page (www.dcresource.com)

Jul 25, 2007 | Quantaray 100-300mm F4.5-6.7 Zoom lens for...

1 Answer

Losing power rapidly...


The only thing I can suggest is that the metal connections on your camera have corroded due to the long life of your camera. I had a similar problem where any batteries I used would not work, regardless of what kind of battery it was. Turns out I had a nice greenish layer of corrosion on my connections which I sand-papered off. This might be a little tricky if your connectors are way inside of a battery holder, but it can be done nonetheless. Try taping some sandpaper to the flat end of a pencil and clean it out that way. Hope it works.

Jun 25, 2007 | Canon PowerShot S1 IS Digital Camera

Not finding what you are looking for?
Fuji FinePix A303 Digital Camera Logo

Related Topics:

42 people viewed this question

Ask a Question

Usually answered in minutes!

Top Fuji Cameras Experts

kakima

Level 3 Expert

101642 Answers

Steven Wander
Steven Wander

Level 3 Expert

579 Answers

Tony

Level 3 Expert

2598 Answers

Are you a Fuji Camera Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...