Tip & How-To about Jl Audio 1000/1 Car Audio Amplifier

Jl 1000/1 amp problem

I tried switching my lanzar amp to my jl 1000/1 amp myself last night and as i plugged in the ground.. some smoke came up from where the ground and 12v cords meet the sub.. it wasnt much smoke, just a little. so i plugged my lanzar back in and today at lunch went to get it installed and it seemed to be hittin when i left the car audio place.. but its not hitting like it should. the lanzar hits harder. what went wrong? what does that smoke mean? how do i fix it? thanks. i am worried sick. those amps arent cheap.

Posted by on

Jl Audio 1000/1 Car Audio Amplifier Logo

Related Topics:

Related Questions:

1 Answer

I have a JL 1000/1 and the low ohm light switch on and off.. The terminal connector is slightly loose.. with a jiggle of the ground wire the amp switch back to GREEN and plays normal..


Check the ground wire to the car make sure that you have bare metal and that the contact between the car and the wire is good. Ensure that the ground wire is in all the way. What size ground wire are you using. I would say don't use smaller than 4ga for a 1000 watt amps.
Also has the amp been screwed or velcroed to the box? Sometimes amp connections become loose from the vibrations of the bass. So it's possible it might be an internal issue or that the wire isn't in all the way.
I would suggest also taking the amp completely out of the car and inspecting the terminals to make sure they aren't loose or corroded.

Mar 06, 2011 | Jl Audio 1000/1 Car Audio Amplifier

1 Answer

amp smokes but still works transitor looking thing is melted?????


954-443-1100 is the service department, sounds to me like your amp is slowly but surely frying itself. i am not sure putting a new transistor in it will help anything but you can try. There only around 15 dollars

Aug 23, 2009 | Jl Audio 1000/1 Car Audio Amplifier

1 Answer

jl audio 1000/1 low voltage -keeps shutting off at high volume


You should definitely upgrade the power wire to the sub amp to 4 gauge -absolutely your choking your amp its starving for current-poor thing is starving !!!!!!!

Apr 16, 2009 | Jl Audio 1000/1 Car Audio Amplifier

2 Answers

jl 1000/1 amp not working w7 like it should


If you see smoke, it's virtually always the power supply transistors. There are several things that can cause it but sometimes, they simply fail. I will generally work with people who want to repair their own amplifiers but the this JL amplifier is complex and not always an easy amplifier to repair.

If you can't find a local repair shop to repair it, you'll have to go through an authorized JL retailer to have it repaired by JL.

Let me know if you have any other questions.

Jul 26, 2008 | Jl Audio 1000/1 Car Audio Amplifier

Not finding what you are looking for?

877 people viewed this tip

Ask a Question

Usually answered in minutes!

Top Jl Audio Car Audio & Video Experts

Mark Skinner

Level 2 Expert

77 Answers

Tygh Duval
Tygh Duval

Level 2 Expert

300 Answers

hoyzee1

Level 2 Expert

150 Answers

Are you a Jl Audio Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Loading...