Tip & How-To about Computers & Internet

How do you configure Multilink PPP on Cisco Routers

How do you configure Multilink PPP?

Given that the two sites that are connecting via Multilink PPP communicate with each other and coordinate the configuration, configuring Multilink PPP is easy. Here is a sample configuration of 3E1 circuits being bonded to form a single 6Mb Internet circuit:

controller E1 4/0
framing NO-CRC4
channel-group 1 timeslots 1-31
description Connect to OtherSite#1
!
controller E1 4/1
framing NO-CRC4
channel-group 1 timeslots 1-31
description Connect to OtherSite#2
!
controller E1 4/2
framing NO-CRC4
channel-group 1 timeslots 1-31
description Connect to OtherSite#3
!
interface Multilink1
ip address 1.1.1.1 255.255.255.252
no cdp enable
ppp multilink
ppp multilink group 1
!
interface Serial4/0:1
no ip address
encapsulation ppp
no fair-queue
ppp multilink
ppp multilink group 1
!
interface Serial4/1:1
no ip address
encapsulation ppp
no fair-queue
ppp multilink
ppp multilink group 1
!
interface Serial4/2:1
no ip address
encapsulation ppp
no fair-queue
ppp multilink
ppp multilink group 1
!

This configuration is from a Cisco 7200 router that has Qty 1 Controllers E1 interfaces (plugged into module 4). These E1 controllers create the Serial4/0:1, Serial4/1:1, Serial4/2:1 interfaces that are bound to the multilink group #1, and other serial interfaces (Serial4/3:1, Serial4/4:1 and so on...)

It is the multilink1 interface that is actually the single combined interface that really has the “6Mb” of bandwidth, and that is where you would apply all of your “normal interface configuration” for this 6Mb connection that connects to the Internet. You can see how the multilink 1 interface has an interface number that matches the ppp multilink group. On that multilink 1 interface, you have the IP address for this link, an ACL on the interface, firewall, NAT, or other router interface commands.

By using the multilink interface, you are able to bond all three of these E1 interfaces into a single router interface — very cool!

To verify that your multilink interfaces are up and running, you can use the show ppp multilink command, like this:

Router# show ppp multilink
Multilink1, bundle name is OtherSite
Bundle up for 3w4d, 89/255 load
Receive buffer limit 85344 bytes, frag timeout 1000 ms
10518/6985 fragments/bytes in reassembly list
21651 lost fragments, 3287247349 reordered
17098/8879018 discarded fragments/bytes, 18 lost received
0xA990C7 received sequence, 0x7F6AA8 sent sequence
Member links: 3 active, 0 inactive (max not set, min not set)
Se4/0:1, since 3w4d
Se4/1:1, since 3w4d
Se4/2:1, since 3w4d
Router#

The key to configuring Multilink PPP is the multilink interface, the ppp multilink protocol on each router, and the ppp multilink group x command on each interface. Multilink PPP isn’t a difficult router configuration to set up, and it is extremely valuable when you need multiple circuits bonded into a single circuit from a single provider.

And for sure, you can just add multilink interface to be routed using OSPF, PBR or any other routing protocol.

Posted by on

Computers & Internet Logo

Related Topics:

Related Questions:

1 Answer

Has anybody configured Reliance Datacard - USB on ubuntu 9.04? Kindly give me step by step procedure for configuration? Regards, Moiz


Hi,

First use the following command to see if your card is being detected by kernel.

cat /proc/bus/usb/devices

Then you can use the following script for the installation, you can check if this is for your version of Ubuntu.

#!/bin/bash

#This program automates task of setting up connection for Reliance USB Card on Ubuntu Hardy Heron. This program does not come with any warranty whatsoever. Please use it at your own risk.

# Detect Modem
echo "Modem Detected: $(lsusb | grep -i huawei | cut -d" " -f7-)"

# Get Connection Number from User
echo "Enter Your Reliance Data Card Connection Number : "
read connection
echo "Setting up connection with $connection"

#Install Gnome PPP Package
echo "Installing Required Packages.."
sudo apt-get install -y -q gnome-ppp wvdial

#Add entries to /etc/ppp/ppp-secrets and /etc/ppp/chap-secrets
echo "I:Modifying necessary system files to allow dialing with Gnome PPP..."
sudo chmod 666 /etc/ppp/pap-secrets /etc/ppp/chap-secrets
echo "$connection * $connection" >> /etc/ppp/pap-secrets
echo "$connection * $connection" >> /etc/ppp/chap-secrets
sudo chmod 600 /etc/ppp/pap-secrets/etc/ppp/chap-secrets

#Start Gnome PPP
echo "We are all set.... "
echo "Starting Dialer..."
gnome-ppp &
exit 0

Dec 10, 2009 | Computers & Internet

1 Answer

cannot install java on samsung i640


Im very sorry Dude

  • It is NOT officially possible to install java MIDlets on samsung handsets (excluding smartphones) via bluetooth, IrDa, USB cable or serial cable. MIDlets can only be downloaded by Over-The-Air (OTA) via a download server
  • There is currently no method for installing MIDlets on other platforms other than by OTA/GPRS via a download server.
BUT THERE ARE SOME UNOFFICIAL METHOD PLEASE TRY THIS BUT RISK IS WITH U.

Install JAVA games on your Samsung via a USB cable, BT or even an IR port
The method here is rather straightforward. It has been tested on my two D500 phones without a single problem biggrin.gif

1. Download and install Softick PPP from here. The software is designed for Palm users, so if you receive any error messages such as unable to locate USBPORT.dll, just ignore them.

2. Active your IR connection or hook your USB cable into the phone.
For IR users, you need to active the IR connection on both of your laptop and D500, and approach the laptop with your D500 to let it find the phone prior to any transferring.
For USB connection, the one I tested is from fonefunshop

3. Start Softick PPP, and check if it has your connection in its 'Settings->Bluetooth/Serial'. Active it if done.

4. Run 'Uploader.exe' program and add a jad file.

5. Enable Serial Java download - #*536963#.

6. Enter Serial Java menu #*5737425#, and choose USB from "1 PPP UP'. Please bear in mind, just do it once for each switch on/off!
Select second option - "2.Serial Download"

7. Let upload and softick PPP access the net if you installed a firewall.





-More details--------------------------------------------------------

If you are using a USB cable, please take the following steps:

1. deactive Softick PPP, and exit it.
2. connect the cable,
3. run Samsung's PIM & File Manager to make sure that you get connected. If not, please switch off and on your mobile and try it again.
4. run Softick PPP
5. go to it's 'Settings->Bluetooth/Serial' to check if it has a connection such as COM7 Devicess_mdm0. If so, select it, otherwise exit the Softick PPP and go back to the first step. (you may find the proper COM setting from the windows device manager->modems->Samsung Mobile USB modem)
6. active Softick PPP.
7. run Uploader.exe
8. ......

For IR users,

1. deactive Softick PPP, and exit it.
2. active your IR connection。
3. approach your phone to the laptop, and make sure there displays an icon in your tray area and it gives a message 'there is a device around....'
4. run Samsung's PIM & File Manager to make sure that you get connected via IR. If not, please switch off and on your mobile and try it again.
5. run Softick PPP.
6. enable IRDA interface support in 'Settings->Options'
7. go to it's 'Settings->Bluetooth/Serial' to check if it includes a connection such as 'COM4 Device

Jun 26, 2009 | Samsung SGH-i640 Cellular Phone

Not finding what you are looking for?

1,572 people viewed this tip

Ask a Question

Usually answered in minutes!

Top Computers & Internet Experts

Doctor PC
Doctor PC

Level 3 Expert

7733 Answers

kakima

Level 3 Expert

102366 Answers

David Payne
David Payne

Level 3 Expert

14161 Answers

Are you a Computer and Internet Expert? Answer questions, earn points and help others

Answer questions

Loading...