Tip & How-To about Marantz PM7200 2-Channel Amplifier

Fixed amp won't turn on and click noise.

The amplifier would sometimes not turn on, when it did there was a loud click from one channel of the amplifier.

Reason.

Inside the amplifier there is a protection board that plugs into the amplifier, the design uses 3 x 25V 47uF capacitors charged up by 22K and 220K resistors.
As the amplifier ages with time, a parasitic resistance across each capacitor gets less and less, this means that the capacitor can not charge fully up and reach thresholds, in the **** design of a delay circuit. The parasitic capacitance is affected by the room temperature making the fault intermittent.

The pop sound is caused by DC offset, it was 25mV, this was nulled using a trimmer on the amp pcb to stop the click-pop sound, this offset could of damaged a loudspeaker.


Posted by on

Marantz PM7200 2-Channel Amplifier Logo

Related Topics:

Related Questions:

1 Answer

my teac MA-7 amplifier makes a very loud bang (rather a very loud clicking noise) a few seconds after I turn it on, and then every 5 minutes or so. Even with volume all the way down, even with no inputs plugged in. The protection turns itself on but it's always too late for the poor speakers. It does thing on both channels simultaneously always. Recently one channel got fried after one of these loud pops. Please help?


All I can tell you is that if the noise is on both channels the cause of it has to be something that is both channels running to it or is something to do with the power supply. If the main amp channels are outputted by one device I would blame it on that. But if they are separate you will need to look elsewhere.

Jul 30, 2013 | Teac Audio Players & Recorders

1 Answer

legacy 1000w 2 channel amp worked awesmoe then just stopped working after a few songs. Didn't turn up too loud. Didn't have the settings too high. still getting power (amp light on, led lights around subs blinks still) ????


Open your speaker box up most likely the jumper from the inside of the box to the subwoofer itsself is broken free, Usally when they have lights around the sub woofers there seperate leads, bet 10-1 you have loose wires inside the speaker box

Mar 25, 2013 | Legacy Audio ICON LA2770BK 1000W 2-Channel...

1 Answer

Amp quit putting out sound


It is probably in the "protect" mode. When this happens, the amp will have power going to it and seem to be turned on, but no sound. Many amplifiers have a LED that is normally red and it lights up when in the protect mode. Check all the LED's on the amp and see if one of them is for the protect mode.

When an amplifier goes into protect there are usually only 2 reasons for it.

1. A bad speaker

2. A channel blown inside the amp.

Disconnect the speakers to the amplifier and see if it makes the amp come out of protect mode. If the amp has an LED to indicate when it is in the protect mode, this LED will shut off, and sometimes they have a relay inside the amp that you will hear click. If you hear the click sound form inside the amp after you disconnect the speakers, you probably have a bad speaker. Take yours to a service center and ask them to check them for you, many shops will do this for free, I know that my shop will do it for free, so I assume that many others will also.

If the amplifier has a blown channel, you need it serviced. There is no quick fix for a blown channel. If you have a multimeter I can tell you how to check some of the components inside to verify if it has a blown channel. Let me know if you are able to do this and I will give you instructions on how to properly test the components. If you do not have a multimeter, there is really no way to figure out what components are bad. Your only choice would be to take it to a service center for repair. They can give you an estimate of what it may cost before you are committed to paying for a repair. Most car amplifiers will cost about $100 to $150 to repair a blown channel. It just depends on how much damage there is, and the rates of the service center.

I hope this is helpful, and if so a good rating would be appreciated. If you need to communicate more with me to determain what the problem is, please wait to give a rating until we are finished. That way I will not get an undeserved bad rating. By the way, the only rating that is good (meaning that it doesn't lower my over-all rating) is a FixYa! rating. The "Helpful" and lower just bring my rating down. After all, the only reason for offering this free help, is to get a good rating.

Dave

Nov 18, 2008 | Jl Audio 500/5 Car Audio Amplifier

1 Answer

xm 1002 hx


1. What type of head unit are you using
2. does the head unit have a Loud feature?
- Sometimes you have to press the loud button on certain head units to engage the amplifier.


Try disconnecting your remote wire from the amplifier, grabbing a piece of small 12 or 16 gauge wire and bridging the remote wire with the (+) on the amplifier. if your light does not turn green, then check your fuse and the ground for the amplifier itself and the subwoofers.

When you connect the remote wire to the (+) it should automatically turn the amplifier on even if the cd player isnt on. The reason I want you to try to connect the remote and power is because sometimes the remote wire for the cd player is bad. If it does end up being a bad remote wire from the head unit, then your best fix would be to connect the red wire (ignition 12v) on your head unit to an on/off switch to the remote on your amplifier. You can then turn your amplifier on and off by flipping the switch. If you go to autozone or advanced auto parts you can pick up a toggle switch for about $3.00.

Feb 20, 2008 | Sony Xplod XM-1652Z Car Audio Amplifier

3 Answers

4200


are you using a right load for the amplifier. what the rated output power of your amplifier. and know the output of your speakers.

well sometimes it protects you from being deaf.. for maybe its too loud so it goes to protection mode. dont know if -23 could make a person deaf.

well I hope I helped you with my solutions.. ^.^ please dont hesitate to respond us..

Jan 20, 2008 | Yamaha P4500 Power Amplifier 2-Channel

Not finding what you are looking for?

516 people viewed this tip

Ask a Question

Usually answered in minutes!

Top Marantz Audio Players & Recorders Experts

The Knight
The Knight

Level 3 Expert

73635 Answers

 Grubhead
Grubhead

Level 3 Expert

5017 Answers

Electro Med Services...
Electro Med Services...

Level 3 Expert

6694 Answers

Are you a Marantz Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Loading...