20 Most Recent Kenwood KAC-8103D Car Audio Amplifier Questions & Answers


Check your fuse. Also make sure all your wiring and terminals are correct and not loose.

Kenwood... | Answered on Dec 12, 2011


Does the unit have power? Check the RCAs from the stereo; are they connected. Check the speaker wires; are they connected?

Kenwood... | Answered on Sep 16, 2010


I would put a 40 amp fuse back in because it could be restricting flow

Kenwood... | Answered on Dec 07, 2009


yeahhh but you would have to send it in and hope its under warrenty. best bet do waht all the other jackasses do. sell that **** on craigslist

Kenwood... | Answered on Jun 26, 2009


When That Happens It Means Something Is Usually Hooked Up Wrong

Kenwood... | Answered on Jun 14, 2009


probably popped a diode in the amplifier circuit. The thumping sound is most likely power feeding back through the circuit, so it will have to be replaced professionally unless you have acess to the proper soldering equipment for IC boards. Hope this helps, even though it is bad news

Kenwood... | Answered on May 29, 2009


bad ground possibly wherever its grounded take it off and remove all paint in the contact area trim the wire back to fresh copper and retry

Kenwood... | Answered on May 19, 2009


Check your ground and make sure it is grounded to metal in your car with no paint. Also, make sure you are running 4 gauge power wire. Another possible cause could be that the ohm load is too low on the amp. Also, if your car battery drops below 10v it will send the amp into protection.

Kenwood... | Answered on May 13, 2009


The speaker may have shorted and caused the output transistors in the amp to fail. This is fairly common. It can be repaired.

Kenwood... | Answered on May 09, 2009


if you see that happen you might need to your i c sound chip or your trasistor change then and check

Kenwood... | Answered on May 06, 2009


Set your HPF and LPF on the headunit to match the crossover on the kenwood amp.

I have the same amp, it's really not difficult to figure out. Try these settings, For the AMP: Bass Boost: 0 Crossover: 150 Level: 1

Now just go into the menu for your head unit and make sure you set the crossovers to 150 or whatever option you have, just make sure they match.

Simple.

Kenwood... | Answered on Feb 21, 2009


I just brought mine to the shop for the same reason. I thought it was something big but it was just a bad fuse. It wasn't blown so when i checked it, I didn't think anything of. If you're using an AGU fuse, try and remove the fuse and touch the two ends of your power wire together and if it's the fuse it should cut on

Kenwood... | Answered on Jan 14, 2009


sounds very similar to something that has happend to mine. if you check the fuses in the amp and they are fine, i recomend replacing the fuse in the power wire. if you are using the glass tube type fuses, sometimes the soldering at the endcaps melts, but the filament doesnt pop. the fuse appears to be fine, but isnt. that happend to me a few times. i had to upgrade to ANL type fuses

Kenwood... | Answered on Jan 13, 2009


If it's only 2 months old, it should be under warranty. Have you tried to get it repaired under warranty?

Any car audio repair shop should be able to repair it.

If you want to repair it yourself, it's possible but you'd need basic test equipment and soldering/desoldering tools.

The following page shows you the basics for amp repair. Your amp is somewhat different than the one shown but the troubleshooting/repair procedure would be similar.

Basic Amp Repair Primer

Kenwood... | Answered on May 17, 2008


Yes, always a good idea to use a wire wheel and drill to get a super clean place for your ground. That was going to be the first thing I suggest. I would use a meter and see how many ohms the subs are at right now. It may be two low and there is too much current demanded form the amp at once. for a good sub wiring guide, go to
http://www.crutchfield.com/learningcenter/car/subwoofers_wiring.html
Don't forget to leave feedback.

Kenwood... | Answered on Jan 24, 2008

Not finding what you are looking for?
Kenwood KAC-8103D Car Audio Amplifier Logo

Popular Tags

26 questions posted

Ask a Question

Usually answered in minutes!

Top Kenwood Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

5013 Answers

Marvin
Marvin

Level 3 Expert

85161 Answers

Mike Duncan
Mike Duncan

Level 2 Expert

219 Answers

Are you a Kenwood Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

View Most Popular

Kenwood Car Audio & Video

  • Kenwood Car Audio & Video

Most Popular Question

kenwood amp red light flashes

  • Car Audio & Video
Loading...