20 Most Recent Miele CVA615 Espresso Machine Questions & Answers


There is a third solution. The brewunit drive motor has three contact switches that indicate home, preset (loading grounds, I assume) and make espresso. The problem is the three contact switches are all on one circuit, so the microprocessor knows a limit switch has been reached, but it doesn't know which one. The programming obviously assumes the limit switches are reached in the correct sequence. In my case, the microprocessor thought the brew unit was in home position when it was in the make espresso position. Miele technical support recognized this immediately, so it is a common problem. The solution is to remove the top panel of the unit, unplug the unit, unplug JP34 on the microprocessor board (four wires, red/yellow/brown/black, in the middle back edge of the microprocessor board). Plug in the unit, put it in maintenance mode, and press and hold the medium coffee button for several seconds. This will move the drive motor past the current limit switch. Plug JP34 back in, plug in the machine, and put it in maintenance mode. Press and hold the large coffee button for a second or two, maximum. Open the machine, and look at the brew unit drive male gear in the main machine as compared to the brew unit female gear. It will take several tries to get the male/female gears to match so you can plug in the brew unit. Once this is done, and the brew unit snaps in place correctly, place the machine in maintenance mode one more time and press and hold the Medium Coffee button to reset the microprocessor with the limit switches. You should be back in business!

Miele CVA615... | Answered on Feb 09, 2019


If the Hot water and the steam function work fine - then I would say the water system and heaters are good. Are the grounds being dumped in the waste dry? I would guess so. The brew unit drive sounds to be the issue - it has a valve on it that dumps the water to waste if the pressure is to great - the waste valve sometimes gets stuck, but in your scenario it sounds as if the brew unit is not being driven to full compression (the clicking sound) and if that is the case the operation is cancelled. One thing you may try - set the grind to coarse and try a small cup - this is easier on the drive and may work - showing the Valve is good and the brew unit drive is starting to weaken.
Hope that helps

Miele CVA615... | Answered on Jan 02, 2018


YOu must turn the machine off...hold both the small coffee and hot water button...tunr the machine on to light...let go of the buttons..then hold in the large coffee button for a few secinds andletgo ..if that doesn't work hold in the medium coffee button for a few seconds and letgo..that shouldreset the brew unit.
good luck

Miele CVA615... | Answered on Apr 21, 2017


Expel air is a common problem, but if the manual's method doesn't work, it can mean only one thing, the pump is not working. You should hear the pulsing of the pump while in expel air mode. If not the pump or its circuit is suspect. The parts are SAECO and available without paying Miele's ridiculous markups.

Miele CVA615... | Answered on Apr 21, 2017


The black thing floating in the water tank is a plastic shell with a magnet inside. If you clean it...make sure you reinstall it with the tapered (smaller) side down. There is a slight size difference BUT it will make ALL the difference in the world.

I had no idea there was a magnet in that black/greyish case. The direction of the casing is important.
I had the same problem and that solved it!

Miele CVA615... | Answered on Aug 16, 2016


Brew a pot with vinegar and no coffee grounds. Then rinse well with water and run a pot or two with water alone.

Miele CVA615... | Answered on Mar 08, 2015


The Brew unit present switch is located on the brew unit drive. On the 615 model not an easy feat - the top and back have to be removed as well as the electronics - the micro switch has an extension arm on it the can fall off if the brew unit hits it the wrong way - I am guessing that is what may of happened here

Miele CVA615... | Answered on Aug 23, 2014


When the alert came up- Brew unit blocked- this is before you started taking things apart, A, were you able to remove brew unit, Yes or No?
B, after turning power on and then off, Did the machine try to reset brew unit to home position Yes or no?
If Yes were you able to remove brew unit?

Miele CVA615... | Answered on Aug 19, 2014

Not finding what you are looking for?
Miele CVA615 Espresso Machine Logo

240 questions posted

Ask a Question

Usually answered in minutes!

Top Miele Coffee Makers & Espresso Machines Experts

Pierre Laplante

Level 3 Expert

2042 Answers

Vincent G
Vincent G

Level 3 Expert

2361 Answers

Jerry Greenberg
Jerry Greenberg

Level 3 Expert

1691 Answers

Are you a Miele Coffee Maker and Espresso Machine Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

View Most Popular

Miele Coffee Makers & Espresso...

  • Miele Coffee Makers & Espresso...

Most Popular Question

coffee tastes bad

  • Coffee Makers & Espresso Machines
Loading...