20 Most Recent Hoover F5891-900 Steam Cleaner Questions & Answers


Probably not, the coils in the motor might be bad.

Hoover F5891-900... | Answered on Apr 14, 2017


belt probably broken. unplug from power and remove the plate from the bottom of cleaner.belt should be visible on one side or other.

Hoover F5891-900... | Answered on Feb 02, 2013


Try Googling (domotec)(dvu 00001)(manual) without parens.

Hoover Vacuums | Answered on May 10, 2017


Sounds like a missing or damaged seal/gasket/oring. Check carefully at source of leak.. maybe a seal or rubber gasket has shifted out of place.

Hoover Vacuums | Answered on May 03, 2017


Check the hose for carpet fiber, it may be starting to plug.

Hoover Vacuums | Answered on May 03, 2017


Check YouTube for something similar.

Hoover Vacuums | Answered on Apr 30, 2017


The water and the soap are supposed to mix as they are dispensed. Check for a leak or crack anywhere in the water line. Any crack would make the vacuum-operated delivery of water quit working!

Hoover Vacuums | Answered on Apr 23, 2017

Not finding what you are looking for?
Hoover F5891-900 Steam Cleaner Logo

2 questions posted

Ask a Question

Usually answered in minutes!

Top Hoover Vacuums Experts

Les Dickinson
Les Dickinson

Level 3 Expert

18381 Answers

Roger Potts

Level 3 Expert

694 Answers

Mike Cairns
Mike Cairns

Level 3 Expert

3053 Answers

Are you a Hoover Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

View Most Popular

Hoover Vacuums

  • Hoover Vacuums

Most Popular Question

hoover f5891 900 cleaner burning smell

  • Vacuums
Loading...