20 Most Recent Kenwood KVT-817DVD DVD/CD/MP3/WMA 7" Motorized In-dash Monitor With 5.1ch DSP Car Video Player Questions & Answers


First and easiest is to check the starter relay in your fuse box under the dash and there could be a fuse box in the engine bay find the ignition one and change with another relay (best use the wipers relay)
I know you are saying you did not cut any wires but you may have knocked one causing it to come undone or cut a wire or pulled one out by accident.
If this all fails try disconnect the DVD player to check if car starts.
Let me know if this helps.
Regards Craig

Kenwood... | Answered on Feb 09, 2018


on tho screen you have settings, open it and then, clock adjustment.

Kenwood... | Answered on Sep 28, 2012


Not much you can do my friend , I tried locating and using my resources to find you a Brain and it looks like its discontinued, Im sorry to say but this guy played you, he sold you the head unit without the brain, its really messed when people take advantage of honest people like yourself. Try ebay here and there if not your just going to have to upgrade my friend, sorry.

Good luck,

Lex..

Kenwood... | Answered on Apr 13, 2012


Hi darnell224,

The USB device/iPod is selected as a source although no USB device/iPod is connected. What you can do if you're getting the "disconnected message" when iPod is connected is: Change the source to any source other than USB/iPod. Connect a USB device/iPod, and change the source to USB/iPod again.

The iPods can be controlled by your unit are:

iPod nano with software version 1.2, iPod nano 2nd gen with 1.1.1 software and iPod with video software 1.2. You must update your iPod software if its version is less than the mentioned versions.

Hope this helps.

Thank you for using FixYa.

Kenwood... | Answered on May 21, 2011


CHECK YOUR CONNECTIONS FROM HEAD UNIT TO BRAIN THERE IS A SMALL GREEN PLUG MAKE SURE IS CONNECTED

Kenwood... | Answered on Apr 06, 2011


Countries around the world have their own REGIONS. If your DVD unit is for the American market then it will only read and play discs that are REGION 1 or REGION FREE. Anything else it will not. REGION 1 : United States, U.S. territories REGION 2 : Europe, Middle East, Egypt, Japan, South Africa, Swaziland, Lesotho, Greenland REGION 3 : Southeast Asia, REGION 4 : Mexico, Central America, South America, Australia, New Zealand, Oceania REGION 5 : India, Afghanistan, Ukraine, Belarus, Russia REGION 6 : People's Republic of China, Hong Kong
I believe you get the idea.
dreamsystems

Kenwood... | Answered on Feb 13, 2011


KVT-817dvd MANUAL LINK

Yes - there is a separate receiver unit.

CLICK HERE to see all the available parts to the unit.

Look at the installation part of the manual to determine which harnesses you will need.

Thanks!!

Kenwood... | Answered on Feb 07, 2011


yes there is a safety feature but it is very easy to overide with a toggle switch you can purchase from just about any where. if you arent to tech savy you could take it to a "hole in wall" stereo shop and they can do it, but they will charge. if not look up the manual for your reciever on kenwoods website and it will tell you how and what those other wires are for.

Kenwood... | Answered on Sep 24, 2010


need to update ipod with latest software, may need new school ipod

Kenwood... | Answered on May 12, 2010


First off how long have you owned the unit? Did you buy it new? Did it ever work playing cd's? it sounds like either a setting problem or a hardware problem with the unit. Once I have more information I can assist you further in trying to isolate the problem.
Thank you,
Lee

Kenwood... | Answered on Apr 29, 2010


Same thing happened to me on 1 that I installed. There is a long molex cable on back of the head unit that goes to a tunr/amplifiwe usually mounted under the seat. This is the ontroll brain. It is either non existant, or you need to plug it back in behind the stereo. Mine was the same way,mounted in a Ford Escape, it somehow vibrated out! Go figure. Hopefully this silves it. Let me know.

Larry T
Winona Lake IN
http://www.cybersoundsaudio.com/cybersounds/vehiclepics.html

Kenwood... | Answered on Mar 19, 2010


sounds like you have it hooked to an amp and have the blue power antenna wire instead of the blue and white amp remote turn on connected the the amp remote turn on terminal.

Kenwood... | Answered on Mar 04, 2010


Hello johnnychi925,

The unit appears to have been installed on the 12vdc connection that is on the same circuit as the the vehicle's ignition switch. This means that when the ignition is turned there is a rapid drop in voltage which cause the problem with your device. You need to connect the device to a 12vdc circuit that comes straight from the battery and does not connect to the ignition circuit. Now for another possible cause if the 12vdc you are connected to is from the battery and not the ignition connection. The battery could be dropping below 12vdc during the starting of your vehicle. This could be the sign of a malfunctioning battery, or a problem with the car's electrical system.

To test out if the battery ids dropping below 12vdc I would suggest connecting a voltmeter to the - and + of the battery and starting the car. The voltage should drop but not below 12vdc.

I hope this helps,

Thank you,

Shuttle83

http://www.electron-age-technologies-llc.com

Kenwood... | Answered on Jul 12, 2009


i take it when u put cd in it says error try a couple of different disks then if it still does what i do is take top off cd player clean laser with rubbing alcohol and a q tip

Kenwood... | Answered on Jul 07, 2009


NO IT HAS BEEN FORMATED TO READ USA REGION 1

Kenwood... | Answered on May 22, 2009


I removed my brain from beneath my seat and exposed all wires and connections. I have found that on mine (kvt-815) there were two pinched wires- 1 for a speaker and the other the remote wire. I respliced these sections and tested my radio again. It appears to be working now and stays on again. I'm guessing one of the wires must have been touching something metal under the seat (seat frame) and grounding out. If the unit doesn't power on at all, check the fuse first. Otherwise, I would  inspect every wire like I did and maybe you'll find a pinched (grounded) wire. Maybe I just got lucky... but at least it's working again and I don't have to replace the brain! Hope this helps.

Kenwood... | Answered on Mar 30, 2009

Not finding what you are looking for?
Kenwood KVT-817DVD DVD/CD/MP3/WMA 7" Motorized In-dash Monitor With 5.1ch DSP Car Video Player Logo

Popular Tags

35 questions posted

Ask a Question

Usually answered in minutes!

Top Kenwood Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

5013 Answers

Marvin
Marvin

Level 3 Expert

85161 Answers

Mike Duncan
Mike Duncan

Level 2 Expert

219 Answers

Are you a Kenwood Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

View Most Popular

Kenwood Car Audio & Video

  • Kenwood Car Audio & Video

Most Popular Question

everything works fine when

  • Car Audio & Video
Loading...