20 Most Recent Hoover FH50010 Vacuum Questions & Answers


Perhaps if you were to add some detailed photographs it would clarify the problem better than a description!

Hoover Vacuums | Answered 5 hours ago


Either the charger or battery is defective.

Hoover Vacuums | Answered on Oct 10, 2017


Why do you feel that a forum dealing with Cameras can help you with this equipment ? Posting this query in a more relevant forum may obtain better results.

Hoover Vacuums | Answered on Oct 08, 2017


You may have a clog or restriction somewhere or something not assembled properly.

Hoover Vacuums | Answered on Oct 08, 2017


output holes plug up .

Hoover Vacuums | Answered on Oct 06, 2017


You likely have a hole in the hose causing a loss of suction/vacuum in the system. Mine cracked right around the bottom nozzle. There are no electrical wires in it, so I just taped it up with black electrical tape and it worked like new for many more years.

Hoover Vacuums | Answered on Sep 28, 2017

Not finding what you are looking for?
Hoover FH50010 Vacuum Logo

6 questions posted

Ask a Question

Usually answered in minutes!

Top Hoover Vacuums Experts

Les Dickinson
Les Dickinson

Level 3 Expert

18394 Answers

Gerry Harvey
Gerry Harvey

Level 3 Expert

1461 Answers

Brad Brown

Level 3 Expert

15618 Answers

Are you a Hoover Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

View Most Popular

Hoover Vacuums

  • Hoover Vacuums

Most Popular Question

am having difficulty

  • Vacuums
Loading...