Question about 2002 Buell X1 lightning

1 Answer

I have a 2002 White Lightening, bought it new. The engine light comes on and the bike runs rough. the code says issues with the heat sensor. The sensor has been replaced, but the bike still does the same. The dealer basically can't figure out the problem. Could it be that the ECU going bad? Could it be that I need to use different plugs? When it acts up, if I open the throttle, it seems to do fine, but generally there is either a power source or fuel source issue. The bike does not run properly. Very annoying!!!!

Posted by on

  • kjanda466 May 24, 2011

    I am going to relay this to the mechanic. Hopefully, this will guide him in the right direction (although, he is a dealer and should know all of this).

    Thanks, again!!!

×

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Master
  • 5,370 Answers

Try spraying carb cleaner on throttle body then check.If its running smooth then its fuel pump related issue.The fuel filter is either clogged or fuel pump is the cause of problem.Running rough actually indicates towards fuel pump issue.But still get it checked by spraying carb cleaner on throttle body.------ also recheck the heat sensor connections are they getting burnt or loose.If all getting checked ok, then it can be ECU related issue.But first check the fuel pump, filter, heat sensor connections.Also re check if the error code is changed.As you mentioned the buell runs fine with throttle open, it can be tps related error.Tps means throttle position sensor. ----------- If all checked ok, then yes it can be ECU.---------- This should help.Thanks.Helpmech.

Posted on May 22, 2011

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Ranger problems


run fault codes and check for O2 sensor problem and MAP/MAF sensor problems. If it is misfiring then codes for injectors and plugs may also appear

Jul 18, 2014 | 2002 Ford Ranger Regular Cab

2 Answers

P0154 code and p01153


both codes point to the oxygen sensor on bank 2 sensor 1 ..
that would explain the rough running also .. the engine will default to a rich condition ...

p0154 indicates no activity on bank 2 sensor 1 oxygen sensor
p01153 is showing "low switching" for bank 2 sensor 1 oxygen sensor ...

there may be a wiring pigtail coming from the sensor. that plugs into another connector a few inches away .. check that connector for damage or corrosion .. if its ok then you likely need a new oxygen sensor ..

its not a good idea to continue driving with this condition since it will eventually damage the catilytic converter. that is probably getting very hot now with the extra load of fuel ..

Jul 05, 2010 | 2002 Chevrolet Avalanche

3 Answers

2002 malibu runs hot.


Sounds like you have a faulty head gasket or maybe a cracked head.This can cause overheating and the check engine light to come on.The code for the o2 sensor is probably caused by coolant getting into the exhaust system and coating the sensor.The coolant fan may work but it cannot remove enough heat from the rad to make the engine cool off.Try some engine coolant stop leak to see if it will help.This maybe only a temperary fix.Let me know if you need more.MOE

Jun 22, 2010 | 2002 Chevrolet Malibu

1 Answer

I have a 2002 TrailBlazer with the straight 6,diognostic check said #3 cylinder was dead or misfiring, also map sensor showed up. #3 cylinder was misfiring, so to test the coil pack I swapped #3 coil pack...


did you replace only one spark plug? that can cause issues because of differences in resistances between cylinders. also, did the map code stay off after replacing
?

Feb 28, 2010 | 2002 Chevrolet TrailBlazer

3 Answers

Truck was running fine coming back from vacation


I would suggest going to Autozone and have them check for code or codes that might have occured,they will do it for free and diagnose what the problem might be. But anytime the check engine light comes on it has to do with your emission,possibly an oxygen sensor may have went bad,have them pull the codes and see what the prob is.

Jul 11, 2009 | 1998 Ford F150 Regular Cab

2 Answers

2002 chevy trailblazer has rough idle


it could be an o2 sensor. it could also just need a tune up

Mar 15, 2009 | 2002 Chevrolet TrailBlazer

1 Answer

2003 yukon xl 5.3l flexfuel all plugs lean on passenger side


P0131 - Heated Oxygen Sensor (HO2S) Circuit Low Voltage

P1133 - Heated Oxygen Sensor (HO2S) Insufficient Switching Bank 1 Sensor 1


Bank 1 Sensor 1
P0300 - Engine Misfire Detected

I would check for vacuum leaks, maybe intake or brake booster

Dec 16, 2008 | 2003 GMC Yukon XL

Not finding what you are looking for?

Open Questions:

See all 2002 Buell X1 lightning Questions

2002 Buell X1 lightning Logo

Related Topics:

90 people viewed this question

Ask a Question

Usually answered in minutes!

Top Buell Experts

yadayada
yadayada

Level 3 Expert

75817 Answers

jmcpoyle

Level 1 Expert

8 Answers

Arnie Burke
Arnie Burke

Level 3 Expert

4514 Answers

Are you a Buell Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...