Question about 2002 Suzuki VL 800 Volusia

1 Answer

My 2002 suzuki vl800 speedometer quit working, all the lights on the gauge work and the turn signal indacator works neutral light work fuel gauge works bright dim works. only the speedometer and the trip read out do not worki. any suggestgions?

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 84 Answers

If its a cable operated speedo then the cable is probably busted it would be a cable coming out of the back of the speedo and going to the front hub assembly.

Posted on Apr 11, 2011

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Every thing works no gauges working


None of my gauges will work, but my turn signal indicators ...

www.americanautowire.com/.../none-of-my-gauges-will-work-but-my-tu...
None of my gauges will work, but my turn signal indicators, high beam ... As we've discussed previously, anything electrical needs a 12 volt feed and ground to work. ... 09/28/2015 There are a number of new products coming in Nov/Dec this ...

my gauges quit working - CarGurus

www.cargurus.com > Questions > Ford > F-250 Super Duty

CarGurusSep 21, 2013 - my gauges quit working - My odometer, speedometer, fuel, tach, trip, and ... I tried fixing the wire and had the same problem....so I replaced the shift lever and everything is back to ... no gauges will work in dashboard 1 answer.

No dash gauges, but dash lights - Car Forums and Automotive Chat ...

www.automotiveforums.com > ... > Dodge > Caravan ' Voyager
Feb 6, 2010 - The dash lights work fine, so does everything else. The dash gaugesjust don't work. This is something that has been an intermittent problem ...

Dec 05, 2015 | Cars & Trucks

1 Answer

Break lights, turn signals, dash light, speedometer all quit. Head light and tail light still work. 2002 FXDWG. MAYBA TSSM OR SOMETHING ELSE ???


Check your fuses. The headlight and tail lights are usually on separate and isolated fuses. The other systems may be on the same fuse.

Aug 05, 2013 | 2002 Harley Davidson FXDWG Dyna Wide Glide

1 Answer

Turn signals on 2001 Chrysler Town & Country cause dash lights to come on and speedometer & odometer quit working


I would say its probably a short or a ground problem at the turn switch or a wire in that area. you need a test light and probably a multi meater and some nohow a ground or wireing problem can even drive a master teck crasy.

Apr 18, 2013 | 2001 Chrysler Town & Country

1 Answer

Pontiac sunfire Gauges not working after Battery change


Just pull out the 10amp cluster fuse and put it back in. The cluster will pop right back up. My 2004 does it every time the battery goes dead.

Apr 23, 2012 | Cars & Trucks

1 Answer

2000 yamaha roadstar 1600. electronic speedo and fuel gauge works as it pleases. when working turn signals make it quit. or anything including horn makes it stop. thinking ground. any ideas


Hi tcjones65 !

Did you find any solution? I have the same problem on my XV1600. I've changed the speedometer assembly, but it still the same, fuel gauge and speedometer doesn't work...

May 19, 2011 | 2000 Yamaha XV 1600 Wild Star

1 Answer

2003 Suzuki VL 800 speedo cluster, signals, brake light won't work. Worked on the way to work this A.M. Checked the two fuses under seat. ?


Did you also check the system fuses? The fuse box is located behind the left side crankcase cover above the coolant reservior.

The 15 amp Signal fuse protects the coolant temperature light, the turn signal indicator light, the neutral indicator light, the oil pressure light, horn, brake/taillight, postition light and turn signal light. Basically, if this fuse is blown, your cluster will be inop.

Please let me know if this is helpful.

Jul 21, 2010 | 2002 Suzuki VL 800 Volusia

1 Answer

I have a 2002 Suzuki VL800, vibration problems


you may want to join (it's free) www.volusiariders.com its an internet forum for VL800 owners.

Apr 07, 2009 | 2002 Suzuki VL 800 Volusia

2 Answers

Reset service warning light


Try this. I can't promise this will work though. Make sure the trip meter on the speedometer is set to the odometer. Turn the key off. Push and hold the trip reset button on the speedometer and turn the key on. Hold the button until the light goes out. This works with a lot of cars so maybe it will work on yours. Let me know something.

Jan 03, 2009 | 2002 Volkswagen Passat

Not finding what you are looking for?
2002 Suzuki VL 800 Volusia Logo

668 people viewed this question

Ask a Question

Usually answered in minutes!

Top Suzuki Experts

yadayada
yadayada

Level 3 Expert

75822 Answers

Arnie Burke
Arnie Burke

Level 3 Expert

4514 Answers

Ed Nelson
Ed Nelson

Level 2 Expert

149 Answers

Are you a Suzuki Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...