Question about Triumph Daytona 955i Motorcycles

1 Answer

Took the bike for a run last weekend. Ran fine at first.After a few miles it started running rough, backfirirg, not reving properly and cutting out when throttle closed. Would restart but the problem persisted. Any ideas?

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    MVP:

    An expert that gotĀ 5 achievements.

    Master:

    An expert who has achieved Level 3.

    Sergeant:

    An expert that hasĀ over 500 points.

  • Triumph Master
  • 500 Answers

Id change plugs ....check for intake leaks....beteween intake & cycs. w/ wd40 if rpms rise theres a leak replace seals..good luck this is a start..

Posted on Apr 09, 2011

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Motor fires up fine runs slightly rough for about 10 seconds then smooths out for about 5 seconds and cuts off. Will start right back up after about 5 seconds and does the same thing. I have drained the...


Previous owner had way overfilled crankcase oil. Oil had gotten into carb and clogged air filter. Drained oil to correct level. Ran engine but kept cutting off-see above. Took off carb cover cleaned housing and ran without air filter-ran fine. Unsuccessfully tried to clean air filter with gas-did not work. Apparently, the engine could run just long enough to exhaust the air in the old filter and cut off which is why it would start back up after a few seconds. Bought new air filter-whole thing-about $15 at Carquest. Put in some carb cleaner and installed the new filter and it runs perfectly.

Jun 10, 2014 | Homelite Pressure Washer. 2700 psi 2.3 GPM...

1 Answer

2009 Honda Shadow Aero ran fine yesterday, stopped for about 3 hours would not start last night. Turned over would not start, help?


sounds like a CDI issue!
could also be an ignition switch or run/stop switch issue.
is the bike lacking any power when running?
Maybe stator pick-up coil as well.
Have electrical components checked at the dealer.

May 24, 2014 | 2004 Honda VT 750 Shadow Aero

1 Answer

Washed '07 streetglide last night and blew her off like I usually do.This morning,started her up,let her warm a little and took off.Bike seemed to run fine for first mile or so,(city streets)then at a...


change your plug wires, if that doesnt take care of it a coil would be next. if you have a crack it would obviously be a problem with water and then forcing it in with air. An old trick is to spray the coil with wd40 to disperse water-the wires too. But i dont know if you want to do that to a chrome road locomotive. If did you would know what it is for sure though.

Sep 02, 2011 | Harley Davidson FLHX Street Glide...

2 Answers

1998 1200 Custom - We bought this bike in 2000 and it had hardly ever been ridden. We rode it for a couple of years, then parked it in the garage when we bought a bigger bike. A year ago we took it out...


I had exactly the same problem. It turned out to be the ignition module. The first time that mine failed it was exactly as you described.
What happens when the ignition module goes is the bike will run fine then when the motor gets hot it will shut down. Then it won't start again until the motor has completely cooled down. Then it will start, run rough, get hot and shut down again.
You will find the ignition module behind the round cover where the points are on older bikes.
There is an LED light on it that will tell you if it is working properly or not. But replacing one probably isn't a project that you want to take on yourself.
Unless you are completely confident with working on vital electrical components of your bike then I would suggest taking it to an experienced mechanic whom you trust.

Jun 18, 2011 | 2000 Harley Davidson XL 1200 C Sportster...

2 Answers

2001 nomad, has power commander, vance and hinse exhaust and hyper charger. Bike starts but miss fires. Bike seems to run better uphill then down hill. It started on day on a ride when the bike just died...


DRAIN CARBS FROM PETCOCK AT BOTTOM OF EACH CARB MAKE SURE FUEL DRAINS COMPLETELY THEN TURN FUEL BACK ON, IF THIS IS AN INJECTED MODEL DRAIN TANK AND FLUSH THEN RUN IT HARD FOR 20 MILES OR SO, MAKE SURE YOUR OIL LEVEL IS OK

Oct 04, 2009 | 2001 kawasaki VN 1500 Vulcan Classic...

1 Answer

2002 VT1100C2 Intermittent Fuel Starvation


No the fuel pump will not fail more than once. When a fuel pump goes out it just goes. Will not work after that what so ever. Sounds like bad gas lines. I had this problem. I replaced my old gas line after the old one cracked when I did this I cut the new on to long. When I put my tank back on the old one pinched. It would run fine for a few min then sputter and die as the gas in the line ran out. I let it sit for a min and more gas filled the line and would start the process over. Try replacing the fuel lines and make sure they are cut to the right length and do not kink when the tank is on. It could also be a dirty petcock. I had let my bike sit for 6 months while in another state and the gat tank got dirty somehow. I got it running and same problem putters and dies. Neighbor took out the petcock and used an air hose to clean it out and it worked like new.

Jul 08, 2009 | 2001 Honda VT 1100 C2 Shadow Sabre

1 Answer

Cylinder issue


Well I figured it out. The carbs were rejetted at some point by a previous owner and the bike was running richer than normal. I recently did a tune up on the bike and put in new OEM spark plugs. The oem plugs were getting fouled. I put the old plugs back in which are a step hotter than oem and the bike ran again. Im just relieved it wasnt anything major. Thanks for the advice.

Nov 20, 2008 | 2004 BMW R 850 RT

1 Answer

Wont start


FIRST thing to check is spark plug ,make sure it is sparking ,if it is and is wet change the plug .If plug is dry it could be the carb needs cleaning out if it has beesn stood for a while

Nov 15, 2008 | 2004 Yamaha DT 125 R

Not finding what you are looking for?
Motorcycles Logo

Related Topics:

250 people viewed this question

Ask a Question

Usually answered in minutes!

Top Triumph Experts

Arnie Burke
Arnie Burke

Level 3 Expert

4514 Answers

yadayada
yadayada

Level 3 Expert

75797 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22114 Answers

Are you a Triumph Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...