Question about 2006 Triumph Daytona 675

Open Question

2006 Daytona won't start. Checked battery, cranked engine seems fine and smells fuel at tail pipe. Still won't fire up. Any idea?

Posted by on

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

  • 375 Answers

SOURCE: am trying to jump start

If you haven#t got enough batter, you wont have enough power to run the FI - you will need to jump it with another charged battery - pushing will never do it.

Posted on Jun 30, 2009

ollie reece
  • 1167 Answers

SOURCE: Yamaha virago 1985, gas and oil coming out of tail pipe

run the bike on 40:1 oil and petrol and then on the carb find the screw thats the furthest in and screw it in a 1/4 of turns at a time this will decrease the amount of fuel going into engine also replace plug and check piston rings by getting a compression tester and put it in the spark plug hole and kick it a few times the pressure wil go up and if it goes over 100 psi or 7 bar then thats ok if below say by to piston rings

Posted on Aug 20, 2009

DoubleClutch
  • 376 Answers

SOURCE: My 2006 Triumph America has a problem starting.

I have a friend that has a 2006 Triumph America and the same thing happened to him. Started running on one cylinder and then just refused to start. I did a check on everything and found that the CDI went bad. This is mounted under the fuel tank along the back bone and is about 3 inch square box.
They mounted them with a type of plastic rivet and would vibrated on the mount and cause something inside to break. When you replace it mount it solid and use a piece of rubber between the mounting plate and the CDI.

Posted on Oct 28, 2009

  • 1 Answer

SOURCE: Hi, Daytona 955i fuel pump not functioning when connected to bike

im having the same problem need help also

Posted on Feb 07, 2010

nedkelly900
  • 345 Answers

SOURCE: Triumph Daytona 1200 petrol leak from airbox

something with the carburettas, only solution would be to remove them, and take them apart, sounds like your float levels could be stuck

Posted on May 20, 2010

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

When I put the gas petal to the floor first before cranking then cranks up smoke it coming out tail pipe and smelling gas


Hi there,

The starting technique you're referring to is not used on late model vehicles because of the fuel injection systems used. If you have a carburetor, when you press the accelerator pedal down, you're adding a lot (more than needed) of fuel mix to the engine. When it does fire up, what you're smelling is unburned fuel. Vehicle fuel is too rich at that point.


25545134-pf4xvcmvqar2tvmmrf0a3mol-1-0.png

Mar 10, 2015 | Cars & Trucks

1 Answer

Fuel smell coming from tail pipe 2006 expedition turned off truck now it will not start.


The most common reason for the smell is excessive fuel in the intake.
You might try disabling the fuel system or fuel pump and crank the engine to see if you can dry the cylinders out.
One of the fuel injectors may have stuck open, or you could have a problem with the fuel pressure regulator.

Feb 16, 2013 | 2006 Ford Expedition Eddie Bauer

1 Answer

98 Pontiac Grand Prix GT 3.8 won't after engine warms up


crank pos. sensor or maf sensor ck. the fuel press reg. also

Jun 06, 2012 | 1998 Pontiac Grand Prix

1 Answer

Won't start


remove the fuel inlet pipe suction till fuel comes. than crank the engine .once the fuel comes out ,connect the pipe. next remove the out-let pipe and crank the engine till fuel comes out.and also check the fitting at suction for any leakage,breakages etc...

Feb 29, 2012 | 1995 Ford Explorer

1 Answer

Vehicle will crank but wont fire


The problem is probably either a bad fuel pump or a bad coil/distributor. To test this, try to turn over the engine for 10 seconds then go back to the tail pipe and smell around it. If you smell gas it is probably a coil/distributor problem. If you do not smell gas it is most likely your fuel pump.

Oct 05, 2010 | 1985 Ford F350

1 Answer

2004 silverado cranks but won't start


try the spark plugs do you smell fuel you may want to try starter spray make sure battery is fully charged.write back well try something else good luck thanks

Nov 29, 2009 | 2004 Chevrolet Silverado

1 Answer

1998 350 Silverado will not start


I believe that you have throttle body injection (TBI) Take off the air cleaner and have someone crank the engine look at the injectors and see if fuel is seen..Do you or have you smelled fuel when you were recently attempting to start truck???? if so this sounds like you are not getting spark....if you havent smelled fuel try priming TBI with gas and see if the truck fires...If so you know that problem lies in fuel delivery... On TBI systems it is very important that a conicle spray pattern is delivered by injectors for proper ignition if injector drips fuel into TBI this could cause a no start condition...To see if spray pattern is correct you can use a timing light if available...Hook it up as normal (red positive post and black negative post and pick-up on #1 spark plug wire) point light at injector and have assistant crank engine light allows visibility to spray pattern.....also check the fuel pressure regulator and vacuum lines....Hope this helped you..let me know if I can help anyfurther....Good Luck!!!!

Jan 01, 2009 | 1999 Chevrolet Silverado 1500

1 Answer

Cannot get topaz to turn over


make sure the exaust is actually cumin out the tail pipe while your cranking the engine sounds like the catilac converter is cloged which keeps too much pressure in the engine

Aug 30, 2008 | 1990 Mercury Topaz

Not finding what you are looking for?
2006 Triumph Daytona 675 Logo

Related Topics:

56 people viewed this question

Ask a Question

Usually answered in minutes!

Top Triumph Experts

Arnie Burke
Arnie Burke

Level 3 Expert

4514 Answers

yadayada
yadayada

Level 3 Expert

75051 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

Are you a Triumph Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...