Question about 2004 Yamaha YZ 250

1 Answer

It back fires when i let off the gas and will run for about ten mins then just quite and it will start i thought it mite be that i have bad gas or the spark plug faled or my valves need adjusted do you now what is going on its a 2007 yzf 250

Posted by on

Ad

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 8 Answers

The back firing is normal on a fourstroke and try cleaning your carb the carbs on those bike are a regular maintenance item if they set for any period of time they need to be cleaned

Posted on Mar 30, 2011

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Why wont 97 Pontic sun fire run it trys to start just for a min bucks for a sec then quits


No fuel pressure , test the fuel system with a fuel pressure gauge . Hook up a scanner an check engine sensor data parameters to the PCM . 048 Engine Hard to Start or No Start Scan Data for Starting Problems If you don't know this you mite want to take it to a qualified repair shop.

Mar 05, 2018 | 1997 Pontiac Sunfire

1 Answer

Husqvarna ride on will quit after running for about 10 to 15 mins.


check for spark as the coil might have gone bad

Aug 15, 2012 | Garden

1 Answer

My car starts up then runs for ten mins then dies. it will start up after that but wont stay running. then i come back an hour later then she starts right up and drives for ten mins then back to the same...


sounds like a bad cam sensor. have scanned if light on dash is on. if no scanner any auto parts store will scan for free. a bad or failing crank sensor will make vehicle stall out after a few seconds or minutes. if it is bad enough it will not start. because it controls timing.

Aug 19, 2010 | 1990 Mercury Topaz

1 Answer

94 camry v 6 run good for 30 min or a hour. motor stop running and want start back. you can wait a hour and it start right up and run good i replace the fuel pump


could be any number of problems. next time it does it check to see if it is getting fire to the plugs if not the igntion module could be heating up and quitting or the coil could be heating up and quitting

Jul 12, 2009 | Air Tools & Compressors

3 Answers

Spit and sputter/2004 PT Cruiser


Check for fire to the coil pack. These have a tendency to go bad on these cars. Could be a cam or crank sensor, these also go bad. If you haven't changed the plugs in 30K, this is due also, wires every 60K. May need to actually get it hooked to a machine to find out for sure.

Jun 02, 2009 | 2004 Chrysler PT Cruiser

1 Answer

Heat runs ten minutes than heat shuts off continues to run


I'm thinking the thermostat has failed, it get's too hot and the emergency over temp sensor kills the flame before a fire is started.

Apr 07, 2009 | Kenmore 63942 Dryer

1 Answer

GENERATOR WILL RUN ABOUT TEN MINS WITH LOAD THEN QUITS


You may have a 'TEST" mode on your Generator. Ten Minutes is usually the duration of the 'Exercise' function of most units, so I'd like to determine what mode you are starting your generator in. Please comment.

Mar 18, 2009 | Electronics - Others

1 Answer

Flooding/shutting off/black smoke/harder on gas


Sounds to me like you have a bad coolant temperature sensor. Or a bad o2 sensor. Leaning towards the coolant temp. sensor. I hope that I helped. Best wishes.

Jan 20, 2009 | 2002 Chevrolet Silverado

1 Answer

Chainsaw floods out after about 10 mins


sounds to me that the needle in the carburator is bad.you need to rebuild the carb. and check the settings when your done

Jan 01, 2009 | Poulan Wild Thing 2375 18" Gas Chain Saw...

Not finding what you are looking for?
2004 Yamaha YZ 250 Logo

Related Topics:

143 people viewed this question

Ask a Question

Usually answered in minutes!

Top Yamaha Experts

Tom

Level 2 Expert

314 Answers

vince

Level 3 Expert

1216 Answers

Steve Sweetleaf
Steve Sweetleaf

Level 3 Expert

1165 Answers

Are you a Yamaha Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...