Question about 2008 Triumph America

1 Answer

My 2008 carbi America cut out in heavy rain I removed the tank and spraid heaps of wd40 not on cdi and it would not start till the next day. Is there any part I need to waterproof

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Sergeant:

    An expert that has over 500 points.

  • Expert
  • 296 Answers

Take some petroleum jelly and run it on all the wire connectors. That will waterproof them for a LONG time at low cost.

Posted on Mar 22, 2011

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

ML 320 CDI 2008 Model. Car cuts out while driving, fault code: fuel rail pressure low.


it needs a cat converter to enable the ECM to function properly next low fuel pressure can be from EVAP system not venting the tank properly, failing fuel pump or faulty pressure regulator unloading too much fuel and dropping the pressure
at this point I would be looking at the EVAP system , then the pressure regulator

Nov 06, 2016 | Cars & Trucks

1 Answer

2007 bonnevelle america..runs for 15 minutes ignition cuts out wont start then 2 hours later starts.Changed coils and wires.Same problem .Where to look next?


Hi, Randy sounds like shades of Lucas Electrics the undisputed Prince of Darkness I would remove the tank again and meticulously scan all electrical connections and pay particular attention to signs of corrosion loose pins inside connectors etc. otherwise the usual suspects are:
1. Severely discharged or a damaged battery, should have 12.5 volts or better and be able to pass a load test if necessary.
2. Failed alternator/generator and or voltage regulator.
3. Loose or corroded battery terminals and or cables especially the "NEGATIVE" cable, look for loose, corroded, or broken connectors inside the cable harness at "BOTH" ends.
4. Failed main circuit breaker or ignition switch, check for loose connections and continuity.
5. Failed system and or ignition relay, check for continuity.
6. Failed ignition coil, ignition/electronic module.
7. Failed CKP, CPS, CMP, MAP, TPS, or BAS sensor, corroded, loose or broken wire connector pins/sockets.
8. Throttle cables and or idle speed improperly adjusted hot idle speed should be 950 RPM to 1000 RPM.
9. Air/fuel mixture screw improperly adjusted.
10. Accelerator pump damaged or not working.
11. Water or dirt in the fuel system, carburetor or filter.
12. Restricted, blocked or kinked fuel line.
13. Fuel tank empty.
14. The gas cap is not venting properly or fuel tank venting system blocked.
15. A failed fuel pump, pressure regulator and or fuel injectors.
16. Vacuum line from intake manifold to petcock broken, cracked, or not attached, carburetor vent line plugged.
17. Needle and seat stuck closed in the float bowl.
For more information about your issue and valuable "FREE" downloads that you need please click on the links below. Good luck and have a nice day.
Triumph Bonneville Ignition Control Unit CDI Limiter Failure
2005 bonneville t100 wont start no spark dies
Triumph Quit Ignoring Your Ignition Problems
Triumph America Handbook

Sep 22, 2016 | 2003 Triumph Bonneville America

1 Answer

Gilare runner st 200 my 2008 runner 200 st won't start after heavy rain.


The ignition components are getting wet and the Ignition charge is being discharged down the side of the wires and not through the spark plugs are required. The next time it does not start in the wet, try spraying all the spark plug wires with wd40 and if it fires up, replace the ignition wires.

Nov 18, 2013 | Motorcycles

1 Answer

I am facing problem to startbike and low performance all electricalparts are ok. bike dosenot run smoothly and suffocate


start with the basic.
is there fuel air and spark
remove spark plugs check if there wet it means you tied to start for too long.
rest sparkplug on metal part of bike and turn over spark ok next is fuel remove carbs and clean ensure all passage ways are clean and moving parts are free to move.
check tank has been drained of fuel check for rust if rust present use rust remover or kream takes 3 days.
clean fuel filter.
clean air filters.
check that youre bike has no low oil pressure cut out if so clean oil filter and replace oil, check oil pressure is maintaining.
if in doubt lubricate wd40 and duck tape can solve 88% of problems.

Sep 26, 2013 | 2008 Yamaha Gladiator SS

1 Answer

My wife and I were headed on vacation and got caught in a rain storm for a good part of the day. The next day was better, but we got caught in rain again. We thought luck was on our side when we finally...


Hi, Paul some bikes can handle moisture better than others depending on age and 99% of the ones that don't start after getting wet just need a little time to dry out then they are good to go. WD40 works wonders when sprayed in critical electronic areas, ie. coils, spark plugs, safety switches etc.
For more information about your question and valuable "FREE" downloads that you will need please click on the blue links below. Good luck and have a wonderful day.
Bike won start after transporting in rain GL1500 Information Questions...
Bike won start after the rain ninjette org
Honda Magna VF750C Service Manual
http://www.partsfish.com/page/oem-parts-for-honda
Honda VF750C Owner Manual

May 22, 2017 | 1995 Honda VF 750 C Magna

1 Answer

Won't start after a heavy rain. Ok next day after drying out.


change the distributor cap by friend did the same thing and i wouldent start untill we took the distributor cap off and we seen croshin and we replaced it and it started up like a champ

Jul 14, 2012 | 2000 Chevrolet Blazer

1 Answer

Engine cuts out during heavy rains. This started


I HAD THE SAME PROBLEM BUT WITH AN ASTRO VAN. THE PROBLEM WAS WATER WAS GETTING INTO THE FUEL PUMP CONNECTOR UNDERNEATH THE VAN, NEXT TO THE FUEL TANK.THIS WAS CAUSING A SHORT, NOT BAD ENOUGH TO BLOW THE FUSE, BUT ENOUGH TO CAUSE THE PUMP TO SHUT DOWN. BEST WAY TO DUPLICATE THE PROBLEM IS TO FIND THE CONNECTOR AND SPRAY IT WITH WATER WHILE THE VAN IS RUNNING. ALSO DO A WIGGLE TEST, THIS IS DONE BY GRABBING THE HARNESS TO THE PUMP AND MOVING IT AROUND, IF YOU HAVE A LOOSE CONNECTOR OR A BAD WIRE THE VAN SHOULD SHUT OFF.

Jun 07, 2010 | 2000 Ford Econoline

2 Answers

Yamaha Neos 50cc water in carb


water from an air filter will not get into the carby bowl to block the jets
water in a carby comes from the fuel tank
if you are using e-mix fuel change to straight petrol as the ethanol in the fuel attracts water out of the atmosphere or the pump where you get the fuel has a water problem in the storage tank
next add methylated spirits ( around 20mm to a gallon) to the fuel tank to break down any water so that t it can go through the carby and be burnt in the combustion process best fix is to remove the tank and have it properly cleaned out, clean the fuel filter , have the carby properly overhauled and get the fuel from a different servo

Apr 07, 2017 | 2010 Yamaha Neos

2 Answers

My 2006 Triumph America has a problem starting up. The engine starts but cuts out after approx 6-7 secs and will not then re-start for an hour or so. I have checked the battery and fuel flow and found no...


I have a friend that has a 2006 Triumph America and the same thing happened to him. Started running on one cylinder and then just refused to start. I did a check on everything and found that the CDI went bad. This is mounted under the fuel tank along the back bone and is about 3 inch square box.
They mounted them with a type of plastic rivet and would vibrated on the mount and cause something inside to break. When you replace it mount it solid and use a piece of rubber between the mounting plate and the CDI.

Oct 28, 2009 | 2006 Triumph America

1 Answer

Only if very humid or after heavy rain gmc 97


sounds like moisture is getting into your wiring or even the ecu

Jun 28, 2009 | 1997 GMC Jimmy

Not finding what you are looking for?
2008 Triumph America Logo

Related Topics:

193 people viewed this question

Ask a Question

Usually answered in minutes!

Top Triumph Experts

Arnie Burke
Arnie Burke

Level 3 Expert

4514 Answers

yadayada
yadayada

Level 3 Expert

75797 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22114 Answers

Are you a Triumph Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...