Question about 1990 kawasaki ZXR 750

2 Answers

Zxr750h1 starts and runs for 30minutes then stops try too start it again but won' t fire up. wait for engine to cool ie 2hours then it starts again, ive changed the cdi, plugs ,clean petrol & checked the coils, do you think it could be the side stand switch or suspect fuel pump/relay, local mechanic didnt really want to take on the job too time consuming. thanks.

Posted by on

Ad

2 Answers

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

My bike was doing the same now wont even start unless choke is on and then sounds like its not runnning very well

Posted on Nov 13, 2012

Ad
  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 6 Answers

In addition to the cdi you should have a set of pickup coils that help with ignition timing, they are on the right side of the engine behind the side plate, they should ohm at 5k or so. If you check them and one or both shows infinite resistance that may be the problem.

Posted on Mar 21, 2011

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

2002 malibu 3100 v-6 won't start, getting fuel and fire to all cylinders


if the security light is flashing than the anti theft is active. The anti theft shuts down the injectors and will not let the vehicle start.

You'll need a battery charger to do this. Hook up the battery charger to the battery.

Place the key in the igniton and attempt to start. Let the key return to the run postion and leave it there untill the light stops flashing. Turn the key off

Turn the key on (do not try to start) and wait for the light to stop flashing again.

turn the key off and then try to start the vehicle.

You can google search "resetting gm security" and find this info as well.

Feb 03, 2012 | 2002 Chevrolet Malibu

1 Answer

Engine stopped running after 2 hours of consistent start and stop driving with air on for the 1st time at full blast. It turns but won't fire. I checked fuel pump and it's working. Replaced...


have you cheeked the ignition (coil ) ?? probably it is
because we learnt it (the coil) comes down after engine high temperatures
yes i know if car cools down and turn on again it is surely bad coil
but some times the coil is just dead not only bad

Jun 06, 2011 | 2001 Nissan Sentra

3 Answers

2000 Mercedes CLK..I think it is a vapor lock problem..car starts as usual but 5-7 minutes later it just shuts down..happened in traffic..so I dont dare to drive it..Afterwards it doesnt start unril...


Sounds like the crankshaft position sensor needs to be replaced. They are a common problem with the Mercedes. That sensor is the one that the engine control module looks at to see if the engine is running. When they get hot and stop producing a signal the engine control module thinks the engine is not running and shuts of the fuel. After waiting awhile they cool down and the vehicle will start up again. I've changed many of them when I worked at the dealer. Tricky part is when there working and the car is running there will be no check engine light on or code stored. Usually will only have the code when the car won't start. Let me know what you end up finding out on it but that would be the first place to look and probably the cheapest.

Apr 20, 2011 | 2000 Mercedes-Benz CLK

1 Answer

Morning or when engine cools down I have to run it for about 15min then it stop dead. wait for 5-10 mins, turn it on and runs again for 2-5 mins than stop again. wait for few more mins and on again, It...


dear sir
this can be problem cause of o2 sensor(lamda sensor) . in cold condition if we start the car some quantity of water can also came out through silencer and can stay at point of 02 sensor it is paced at silencer, ECU(Engine Control Unit) receive data from 02 sensor for Engine Firing . so replace it and let me know. thanks.

Sep 13, 2010 | 1997 Jeep Grand Cherokee

1 Answer

Stypejag2002 will not start for quite some time


it apears to have been a faulty fuel pump ie no pressure at test point tapped fuel tank with small mallet fired up straight away.new fuel pump on its way. thanks

Nov 26, 2008 | 2002 Jaguar S-Type

1 Answer

1991 f150 when i first start it runs fine when i shut it off and


have the electronic module checked and maybe replaced to correct this problem

Nov 26, 2008 | 1989 Ford F 150

Not finding what you are looking for?
1990 kawasaki ZXR 750 Logo

367 people viewed this question

Ask a Question

Usually answered in minutes!

Top kawasaki Experts

Arnie Burke
Arnie Burke

Level 3 Expert

4536 Answers

yadayada
yadayada

Level 3 Expert

76846 Answers

bazzz7071
bazzz7071

Level 2 Expert

342 Answers

Are you a kawasaki Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...