Question about Yamaha MT-03 Motorcycles

1 Answer

2009 Yamaha MT 03 blew the main 10amp fuse it stopped & all instrument lights went out. I changed the fuse it was ok. I rode apr 4 miles stopped for a few minuets then started it again rode it for about 25yards and it blew the fuse again. I changed the fuse again this time the fuse blew when I attempted to start the bike.

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    MVP:

    An expert that gotĀ 5 achievements.

    Champion:

    An expert who has answered 200 questions.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

  • Contributor
  • 299 Answers

I had to run a inline fuse on my bike with a 15 amp fuse, but there is a short somewhere. check all connections at solenoid make sure nothing is touching

Posted on Mar 18, 2011

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Where is fuse located at for instrument panel on 2003 Chevy Blazer LS


Fuse Block - I/P- instrument panel
At the left side of the I/P, near the left door jamb switch. there are four fuse's that supply power to the I/P fuse #3 cruise 10amp - fuse #4 Gauges 10amp - fuse #11 CLSTR 10amp - fuse #19 RDOBATT 15amp ! Hi Dave hope this helps , but I have to ask what trouble are you having ? Gauges not working ? GM had problems with instrument clusters 03 to 06 , had bad stepper motors that controlled the gauges !
There are f
How to repair GM Instrument Cluster Speedometer Gauge Stepper

Mar 30, 2015 | Chevrolet 2003 Chevrolet Blazer LS

1 Answer

Why did two fuses blow making check engine light came back on


Scan for codes there a reason the fuses blew, just replacing them isn't always the answer. If they blow again you've got a wiring issue.

Jun 27, 2014 | 2001 Pontiac Grand Prix

1 Answer

How do i change the speedo from kmh to mph on my yam mt 03


Push the SELECT and RESET buttons together and turn the key ON,when the digits start flashing on the display push the SELECT button to choose kilometres or miles .

May 07, 2011 | 2007 Yamaha MT-03

1 Answer

My yamaha mt03 will not start unless i charge battery it runs fine after i push start it but will not start after i stop and turn off i checked the altantor its fine makes a buzzing sound when i try to...


Hi, Jagojohn before testing any electrical component in the Starting System it is "IMPERATIVE" that you have a fully charged battery of 12.5 volts or more and be able to pass a proper "LOAD" test if necessary, you may have a preliminary reading of 12.5 volts or more but little or zero amperage, the battery is faulty and must be replaced. AGM type batteries fall into this scenario more so than lead acid batteries.
1. Ignition Switch not in the "ON" position.
2. Engine Run Switch in the "OFF" position.
3. Check the battery terminals for damage or corrosion check the battery cables at "BOTH" ends for loose, corroded, or broken connectors, "INSIDE" and outside the cable harness, perform connector wiggle test and check cables with an ohmmeter.
4. Bank angle sensor needs a reset or is faulty.
5. FOB battery low or dead.
6. Faulty ignition switch.
7. Faulty starter button.
8. Faulty kickstand, clutch, neutral safety switch.
9. Security alarm needs a reset.
10. Starter relay, solenoid, starter have failed or circuit wiring faulty.
11. Starter armature or field coils have failed.
12. Main fuse or circuit breaker may be blown or faulty.
13. The electric starter is working but starter clutch has failed.
14. Check for engine trouble codes.
For more information about your issue and valuable "FREE" downloads that you will need please click on the blue links below. Good luck and have a wonderful day.
Yamaha MT Owners Club
http://meiguohosting.com/How-to-fix-start-problem-for-your-2006-Yamaha-MT-03
Yamaha MT 03 Service Manual
OEM parts for Yamaha
YAMAHA MT 03 Owner Manual

Nov 12, 2010 | 2006 Yamaha MT-03

1 Answer

2006 MT-03. The Parking light fuse has blown


Hi, Jus_sie before diagnosing your blown fuse issue check the bottom of your seat if its metal and comes in close proximity to the positive battery post you need to take the necessary steps to ensure there is no contact (electrical tape, thick rubber insulation, hammer a dent in the seat bottom etc.) You are going to need a wiring diagram from your service manual, a test light, an ohmmeter and plenty of extra fuses.
If you turn on your ignition switch and immediately blow a fuse you have a hard/dead short and is usually easy to find. With a test light connected to the hot side of the blown fuse holder start stabbing the wire/s that leads away from the fuse holder and towards the ignition switch, you test light will illuminate validating the short. When the test light fails to illuminate you have passed the short and need to back up until the test light illuminates, then look in the immediate area for the short.
If you driving down the road for 30 minutes or 15 miles and blow a fuse you have soft/flying short and may take some time and patience to find.
If the main fuse/circuit breaker constantly blows/trips while riding you probably have a faulty battery terminal connection. Check battery terminals for damage or corrosion, check battery cables at "BOTH" ends for loose, corroded, or broken connectors, "INSIDE" and outside the cable harness, perform connector wiggle test and check cables with an ohmmeter if necessary. Any other fuses that constantly keep blowing while riding are usually caused by a loose or corroded ground wire in the circuit, which means you have to check, inspect, test each and everyone with and ohm meter set on a low ohm scale 100 ohms or less . Simply touch one lead to the ground source and the other lead to the battery negative terminal, a reading of zero indicates a clean solid ground. Any number reading or infinity indicates a poor ground and needs to be repaired. Poor or weak grounds require excessive additional amperage to complete the circuit which in turn blows the small amperage fuse.
For more information about your issue and valuable "FREE" downloads that you will need please click on the blue links below. Good luck and have a wonderful day.
http://www.mt-owners-club.org/forum/viewtopic.php?t=1012
Re headlight fuse blown no lights Road Star Forum Yamaha Road Star
Yamaha MT 03 Service Manual
OEM parts for Yamaha
YAMAHA MT 03 Owner Manual

Nov 25, 2009 | 2006 Yamaha MT-03

5 Answers

2002 jeep liberty interior fuse diagram


1-20amp-pwr outlet frt. 2-10amp-rear fog lights(export only)
3-15 amp-horn 4-10amp-hedlt low beam rt
5-10amp-hedlt low beam lft 6-20amp-bodycontrolmodule/pwr dr locks 7-spare 8-spare 9-10amp- rt pk lt /rt tail lt/trailer tow lt/cluster
10-spare 11-15 amp-flasher 12-15 amp-stop lts
13-10amp-bodycontrolmodule/cmtc/cluster 14-spare
15-10amp-pdc fuel pmp & auto shutdownrelays/skis
16-20amp-pwr outlet rear 17-15amp-rear wiper 18-20amp-radio choke relay 19-20amp-frt fog lts/trailer tow stop and turn lts
20-20amp-sunroof 21-spare 22-10amp-wiperswitch/frt and rear washer 23-10amp-lft park lt/lft tail lt 24-10amp-pdc blower motor relay 25-10amp-heatseatswitch/hvac controlhead/trailor tow battery charge 26-10amp-hedlt highbeam rt 27-10amp-hedlt highbeam lft
28-spare 29-15amp-heated seat module 30-10amp-heated mirrors/rearwindowdefrosterindicator 31-20amp-cigarlighter
32-10amp-radio/frtdoorlockswitches/bodycontrolmodule
33-10amp-skis/diagnostic connector 34-15amp-cluster/courtesy lts/radio/bodycontrolmodule/maplights/cmtc/underhood lt/vanity lts
35-spare 36-10amp-ignition run/start-orc/lft and rt siacm
37-10amp-ignition run only-orc 38-10amp-abs module/brake shift interlock solenoid 39-10amp-rear window defroster relay/flasher/backup lts

Jul 03, 2009 | 2002 Jeep Liberty

2 Answers

Mt-03 km/h not mph


Place the key in the ignition switched off. Press and HOLD both the select and reset buttons before turning the key to the on position. Now let go of both buttons and the on screen digits should start flashing. Now press select to toggle between kilometres and miles per hour.

Mar 23, 2009 | 2006 Yamaha MT-03

1 Answer

2006 mt-03 the instrument cluster has stopped working. the only bit of life is the imobliser lamp.Thanks


Hi, Adrian if some or all of your instrument cluster goes dark/blank immediately upon startup or a few minutes later riding down the road the usual suspects are:
1. Blown instrument fuse.
2. A bad ground in the instrument circuit.
3. Faulty wiring before or after the fuse.
4. Faulty wiring or connector between the fuse and the instrument cluster.
For more information about your issue and valuable "FREE" downloads that you will need please click on the blue links below. Good luck and have a wonderful day.
Main instrument cluster NOT working
Yamaha mt 03 electrical problem
Yamaha MT 03 Service Manual
OEM parts for Yamaha
YAMAHA MT 03 Owner Manual

Feb 21, 2009 | 2006 Yamaha MT-03

Not finding what you are looking for?
Motorcycles Logo

Related Topics:

205 people viewed this question

Ask a Question

Usually answered in minutes!

Top Yamaha Experts

dhnguyen

Level 2 Expert

281 Answers

Steve Sweetleaf
Steve Sweetleaf

Level 3 Expert

1144 Answers

Tony

Level 3 Expert

2600 Answers

Are you a Yamaha Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...