Question about 2005 Suzuki Boulevard C50

1 Answer

Speedometer and odometer not working , harness is ok and checked fuses and seem to be ok

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Sergeant:

    An expert that hasĀ over 500 points.

    Champion:

    An expert who has answered 200 questions.

  • Expert
  • 213 Answers

The Speedometer has been known to go bad. But if you check the SIGNAL fuse in the fuse block behind the left rear engine cover you may find it open. Replacing the 10 amp fuse should get it working again. Don't just measure the fuse's voltage test points, pull it and look at the fuse itself.

Posted on Sep 12, 2012

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

Speedometer and odometer have stopped working. I have replaced the VSS and they still do not work


suspect you may have some sort of power issue. Check all fuses. May be a hairline crack in a fuse that powers the speedometer. If you can get a 12v light prove place negative of probe on car body and then put the probe pointy end on each side of each fuse to test each fuse .
google 12v probe.
http://www.supercheapauto.com.au/online-store/products/Toledo-Circuit-Tester-Heavy-Duty-6V-12V-24V.aspx?pid=305190#Recommendations

Jul 09, 2016 | Cars & Trucks

1 Answer

Speedometer, turn signals and horn quit working, speedometer light doesn't work


Hi, Brian I do not know what type of bike you have but this is what I tell all my Harley friends with electronic speedometers the vast majority of speedometer issues is caused by the speed sensor and or the wiring, a faulty speedometer sensor and or connection will automatically interrupt proper turn signal and flasher operation. On Sportsters the sensor is located on top of the engine case behind the rear cylinder, on big twins, it's located on the right side of the transmission case between the starter end cap and the transmission top cover. Remove the bolt/***** that secures the sensor and lift the sensor out of the case. Inspect it for damage and contamination, if there appears to be no damage wipe the end of the sensor clean and reinstall, you can go for a short quick test ride to see if the speedo is working. If the issue still exists grab your test light and unplug the harness connector from the sensor, check for power (red wire) and ground (black wire) continuity coming from the speedo, there is also the connector that plugs into the speedometer, also, look for corroded, broken or loose pin/sockets. If everything checks out OK then replace the speed sensor. Good luck and have a nice day

Mar 28, 2016 | Motorcycles

1 Answer

2003 ford taurus installed aftermarket cd player in my car and accidentally grounded the poet wire out and now I have no power windows, no wiper blades, no radio, no speedometer, odometer, or hazzard...


dont b a **** fool and cut wires under your dash for some boom booms in your car buy the connecting harness they sell theres one for every make and model out there solves guessing and saves headaches... dont be a ******* buy the right parts

Jul 14, 2012 | 2000 Ford Taurus

1 Answer

Broke speedometer and odometer reader


you may need a car electrician as these things need troubleshooting.the only thing you can do is by checking all fuses however if other gauges and indicator lights are working then the fuse for the inst. cluster is ok.the speedometer has a sensor installed on the transmission while the odometer gets signal from the ECU so these two problems need separate solution

Jan 30, 2010 | 1997 Ford Escort

2 Answers

Speedo, odometer and fuel gauge don't work


You probably have a sporadic fuse failure - go in and replace the fuses linked to these functions with NEW fuses and make sure there is no corrosion on the fuse box connections - this should solve.

Dec 31, 2008 | 2002 Toyota ECHO

1 Answer

1991 Dodge Daytona Speedometer and Odometer not working.


I had the same problem with my 90 daytona. The tach and the speedometer would work intermitantly. I took the whole gauge cluster out, and heated all the soldering with a solder gun to reflow the connections. It seems that this is a common problem with the connections cracking. You may not be able to see the cracks in the solder.

Oct 03, 2008 | 1991 Dodge Daytona

1 Answer

Speedometer/ Fuel Gauge & Tachometer not working


check for loose connection at the instrument cluster.

Jun 28, 2008 | 2001 Volkswagen Beetle

Not finding what you are looking for?
2005 Suzuki Boulevard C50 Logo

289 people viewed this question

Ask a Question

Usually answered in minutes!

Top Suzuki Experts

yadayada
yadayada

Level 3 Expert

75077 Answers

Arnie Burke
Arnie Burke

Level 3 Expert

4514 Answers

Ed Nelson
Ed Nelson

Level 2 Expert

149 Answers

Are you a Suzuki Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...