Question about 2005 Suzuki Boulevard S83

1 Answer

80 cc 4 wheller starts but no power changed plug and air filter, any other ideas?

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 130 Answers

Sounds like the exhaust may be clogged,remove silencer and you can usually dismantle this and clean it out.

Posted on Jan 01, 2011

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
New users get to try the service completely Free afterwhich it costs $6 per call and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Hi my McCulloch mac 70 keeps loosing power,I have changed the fuel filter,spark plug and air filter the mixture is right but still won't run right,any ideas?many thanks Barrie.


Check the muffler for any type of obstruction first. Then I would check the diaphragm in the carburetor to make sure it isn't starting to stiffen up. If that doesn't help it may be that it is just old and tired

Jan 16, 2013 | Garden

2 Answers

I have a 2006 vento 150 cc scooter 48 miles on it and hasn't been started in 3 years Q - DOES IT A SPARK PLUG TO CHANGE Q- SHOULD I DRAIN THE FUEL OUT AND IS IT USEABLE IN THE MOWER OR WEED EATER


hi.
if it has not been started in 3 years then a new spark plug would probably be a good idea, but not essential if the old one is cleaned.
3 year old fuel should be drained and is pretty much no use for anything. you may be able to start a bonfire with it, but i would not even try to run a machine on it after 3 years.
it would also be a good idea to change the oil and clean the air filter. the battery will almost certainly need changing as well.
there should not be any major problems though.
hope this helps

Jul 17, 2011 | Vento Agility City 50 Motorcycles

1 Answer

I get an error code e1 and have cleaned and replaced the filter. Runs for a couple minutes then shuts of with same message. Any ideas?


THIS SHOULD RESET IT
1 DISCONECT THE POWER PLUG FROM POWER SUPPLY 2 CLEAN FILTER 3 HOLD DOWN THE POWER ON/OF BUTON ON THE UNIT AND PLUG THE UNIT KEEP PRESSING UNTILL IT EMITS A BEEP SOUND FOR APROX 5 SECONDS 4 DISCONECT POWER AND PLUG AGAIN
IF THAT DOES NOT WORK 1 DISCONECT UNIT 2 HOLD DOWN THE MODE KEY ON THE PAD OF THE UNIT AND PLUG THE UNIT KEEP PRESSING UNTIL IT EMITS A BEEP SOUND APROX 3 SECONDS THE UNIT WILL START. 3 STOP THE UNITS OPERATION BY PRESING ON/OF 4 RESTART UNIT.
raypena_0.gif
BEST OF LUCK

May 31, 2011 | Sharp AF-R120FX 12,000 BTU Comfort Touch...

1 Answer

My 2001 jetta is bogging out. you step on the gas, it starts until the RPM,s get up and then looses power. You can get to about 3000 rpm and go throught the gears but will only hit 80 km/h depending on...


Possibilities could include clogged fuel injectors, worn spark plugs, bad coil pack, bad plug wires, clogged catalytic converter, bad or dirty maf sensor.

Mar 30, 2011 | 2001 Volkswagen Jetta TDI

1 Answer

I have a 1990 yamaha 100 cc 4 wheeler and we replaced the spark plug and cleaned out the carb and its turning over but wont start. I know the spark is fine but it just wont turn over, any ideas? maybe...


If the spark is fine, then it is not wiring. It is going to more than likely be fuel. Try spraying a little starting fluid in the air filter. If it starts, then you will know that it is fuel. Make sure that the carb is getting fuel from the tank. A lot of times the filter in the tank will get plugged up. If the bike doesn't start with starting fluid, then the problem is not fuel and will have to be either the timing is off or not enough spark. The spark should be blueish purple.
If this helps you please rate by checking the 4 thumbs up! Thanks for using Fixya.com

Jan 12, 2011 | Yamaha G5 Motorcycles

1 Answer

Have a 2000 Plymouth neon (4 cyl, 2.0) with loss of power and backfire , car has just been tuned up (plugs, wires, throttle body cleaned, air filter, oil change). Just changed the ignition coil today power...


Did this backfiring start after the tune-up? If yes, check firing order of plug wires. Also , if you paid someone to do this, have you consulted with them regarding the way the vehicle is running?

Apr 22, 2010 | 2000 Plymouth Neon

1 Answer

87 Fiero 4 cylinder. Starts and idles fine but no ability to accelerate, no power. Have drained old fuel and replaced with fresh. New fuel filter, new air filter, new plugs am going to change out the...


Possibilities:Timing is retarded,TPS (throttle position sensor) is malfunctioning.Make sure there isnt a vacuum leak(check vacuum lines and intake for whistling or air sucking)

Nov 18, 2009 | 1985 Pontiac Fiero

1 Answer

Starts ok when cold. acts like it's out of fuel when hot.


Clean or change the sparkplug. Also make sure you have fresh gas and the proper fuel mix.

Jul 23, 2009 | Poulan Pro 42CC 2 Cycle Chainsaw, 18"

1 Answer

1990 camry will not start


this is just a shot in the dark, but wiggle the wires on the top of the air filter canister...i had this same problem (though i never got in to check if the engine plugs) after I changed the air filter.

I had started to take that sensor off bove the air filter because i thought i had to, turns out i didn't need to do that. I put the air filter in, and my car wouldn't start...I unscrewed and screwed back in the tiny screws that hold that plug into the top of the airbox sensor thing (no idea what it's called)...and wiggled it around and it started fine again.

I will not change my air filter again!!

Feb 02, 2009 | 1990 Toyota Camry

Not finding what you are looking for?
2005 Suzuki Boulevard S83 Logo

Related Topics:

53 people viewed this question

Ask a Question

Usually answered in minutes!

Top Suzuki Experts

yadayada
yadayada

Level 3 Expert

76630 Answers

Arnie Burke
Arnie Burke

Level 3 Expert

4535 Answers

Richard
Richard

Level 2 Expert

83 Answers

Are you a Suzuki Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...