Question about 2000 Harley Davidson FLHTCUI Electra Glide Ultra Classic

1 Answer

Have 1999 ultra classic and cannot keep a horn working. Installed new one and it worked then started to ride and it just squeeks any help appreciated

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Brigadier General:

    An expert that has over 10,000 points.

  • Master
  • 4,565 Answers

To be perfectly honest, Harley Davidson has never had a horn that was worth the effort it takes to put one on your bike. The problem is vibration. A horn has an adjuster on it that adjusts a set of contact points. This adjustment is very touchy to get it where the diaphragm in the horn just vibrates. You can try adjusting the horn but if that doesn't work, I'd go to an aftermarket type air horn.

Good Luck
Steve

Posted on Dec 29, 2010

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

2008 ultra classic cvo cb says module not installed check with dealer


Hi Anonymous, call, take a ride or trailer your bike over to your local dealers service/parts department, I'm sure they will be happy to take your Harley Davidson for a test ride if necessary/possible and offer professional advice and assistance concerning your issue. Good luck have a nice day.

Mar 17, 2013 | 2008 Harley Davidson FLHTCU Ultra Classic...

1 Answer

I have a 02 electral glide ultra classic that keeps blowing the accessories fuse. as soon as i put a new 15 amp fuse in it blows. turn signals, brake lights and the spped odometer stop working.


In this case, you're going to need a wiring schematic to trouble shoot the problem. You'll have to disconnect the power lead to each device that the fuse provides power to. Then, replace the fuse and start reconnecting the devices one at the time. When you connect a device and the fuse blows, you have found the problem. I do not have schematics for bikes newer than 1999, I'm sorry.

Good Luck
Steve

May 28, 2011 | 2002 Harley Davidson FLHTCUI Electra Glide...

1 Answer

On my 2002 ultra classic my headset or intercom does not work. Cant talk to passenger


sorry i do not know,, but i have got great help at harleytalking.com .. good luck ..I ride a flhtcu...

Apr 27, 2011 | 2002 Harley Davidson FLHTCUI Electra Glide...

1 Answer

1999 Honda Shadow 1100/ turn signals went out and horn.


im having the same problem! I am on a cross country loop and would appreciate any help. if anyone has figured this out please contact me so i can make it towards a so called home. thanks!
kpsprocuts@gmail.com

Aug 02, 2010 | 2002 Honda VT 1100 C3 Shadow Aero

1 Answer

Brake lights,turn signal and horn not working...


Check the wiring within the headlight shell--look for connectors that may be corroded or pulled loose. A little WD-40 will favor connection integrity when sprayed into the connectors, then coupling and uncoupling them several times. Hope this helps!

May 24, 2010 | 2000 Harley Davidson FLHTCUI Electra Glide...

1 Answer

Horn wont work 1996 flhtcui electra glide classic


Its possible that just a wire came loose...but if thats not the case take off one of the wires and read for voltage while pushing the horn button..if you get voltage its a bad horn..if not you'll need to check the horn button it may be bad.
hope this helps...when my horn went bad i had voltage..i replaced the horn and it worked fine...also just insure that the wires are on solid and arent corroded or damage before you try all this other stuff first. Hope this helps .

Apr 05, 2010 | 2000 Harley Davidson FLHTCUI Electra Glide...

1 Answer

Accessory fuse keeps blowing, headlight not working


I know this sounds aomewhat general, however please give the following some thought:
Check your relays, if you have an aftermarket horn you may have a different relay. To troubleshoot unplug your headlight, unplug your horn, etc.. Turn your ignition switch to accessory only. See if the fuse pops. If it does unplug whatever added accessories you may have still have plugged in. Once you can get the fuse to stop popping, turn the ignition switch to on. Then one at a time plug you accessory, headlight, etc. back in. When you find what pops the fuse, unplug that item, start plugging in the other items, if the fuse has not popped you have potentially isolated the circuit causing the issue. Now check the wiring for loose connections, bad ground, and CHECK the relay if that item has one. Hope this helps,

JP

Aug 17, 2009 | 2000 Harley Davidson FLSTC Heritage...

Not finding what you are looking for?
2000 Harley Davidson FLHTCUI Electra Glide Ultra Classic Logo

246 people viewed this question

Ask a Question

Usually answered in minutes!

Top Harley Davidson Experts

Arnie Burke
Arnie Burke

Level 3 Expert

4514 Answers

Gills Lango

Level 2 Expert

195 Answers

Mike

Level 3 Expert

4336 Answers

Are you a Harley Davidson Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...