Question about 2006 kawasaki ZX-14

1 Answer

At 3500 rpm my throttle shuts off because the speed sensor engauges. So, replaced it but still has same problem. When I dissconnected the speedsensor bike runs like its suppose to but have F1 error code flashing and no speedometer. Tach works and engine heat read correct but fuel gauge doesn't. Please help

Posted by on

  • PawnShopZX14 Nov 11, 2010

    the bike runs the way its suppose to now but the speedo doesnt read at all and fuel fuel guage read incorrectlly. all the guages work if i plug the wire on my speed sensor in but then the speed sensor shuts the throttle off at thirtyfive hundred rpm. but ill try that connection you were talking about where can i find it?

×

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Master
  • 2,299 Answers

There is a electrical connection on the secondaries of the fuel system. Try unplugging this connector. And see if the bike runs normal then.

Posted on Nov 11, 2010

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

RPM's rev high and low


"Could this be a throttle positioning sensor problem?" - probably not. The Throttle Position Sensor (TPS) tells the computer how hard you are stepping on the gas. It does not really control idle speed.

Your problem is more likely the Idle Air Control (IAC) valve. This is a small electric valve that the computer can open and close in small steps to set the idle RPM at the desired point (a little higher when cold, then down to normal speed when warm). The IAC valve is notorious for getting all crudded up inside. Then it sticks open too much (really fast idle speed) or sticks shut (really low speed).

You can try taking it off the engine, cleaning it with carb cleaner spray, and putting it back on. That is easy and cheap.

If cleaning does not fix it, you need to buy a replacement valve and put it on. Pretty easy to do but costs more $$$.

Apr 29, 2013 | 2000 Honda Odyssey

1 Answer

My 1998 buick regal gs shuts off when i stop and i notice that the rpm moves back and forth


Usually when the engine is "hunting" for the idle speed, the throttle position sensor or idle air control valve is faulty, or there is gunk in the throttle body, or a vac leak somewhere.
The computer controls the idle speed by using that control valve.
Is the check engine light on when the engine is running ?

Jul 25, 2012 | Buick Regal Cars & Trucks

1 Answer

Rpm shoots up to 3500 dwn to 1500 up again down again .


scan it check tps sensor.also check for sticking throttle linkage.also check idle speed control.

Jul 17, 2009 | 1995 Honda Accord

1 Answer

Stalls at about 3400 RPM - Everytime!


u could have just replace the main relay and save a lot of money.

Jul 01, 2009 | 1996 Honda Accord

1 Answer

Looses power at 3500 rpm


Blocked gas filter is most noticeable at HIGH SPEEDS.

If it looses power at only 3500 or so rpm's, most likely culprit is the throttle position sensor also known as TPS.

Does ur engine burn oil? Could be low compression, but unlikely.
Could alsobe, but unlikely, the coil giving a weak spark.

Whats ur mileage and is it an automatic tranny or manual? Give more details please as to what ur car does, IE sputters, jerks, weird noises, engine revs high but car doesn't go faster, etc.

Sep 08, 2008 | 1994 Subaru Legacy Outdoor

1 Answer

RPM Oscillating


have you had the vehicle speed control reprogrammed if not that could be your problem

Jun 26, 2008 | 2005 Dodge Ram 3500

2 Answers

Run hard at 2500 rpm 96 nissan pickup 2.4 5 speed


I had a similar problem mine would hit a rev limiter at 3500 rpms. it would blow black sut out of the tail pipe. Ended up being mass air flow sensor/valorem sensor. almost 500.00 from nissan. fixed it though.

May 31, 2008 | 1996 Nissan Pickup

Not finding what you are looking for?
2006 kawasaki ZX-14 Logo

Related Topics:

121 people viewed this question

Ask a Question

Usually answered in minutes!

Top kawasaki Experts

Arnie Burke
Arnie Burke

Level 3 Expert

4514 Answers

yadayada
yadayada

Level 3 Expert

75117 Answers

Gino Cussen
Gino Cussen

Level 2 Expert

216 Answers

Are you a kawasaki Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...