Question about 2005 Suzuki Boulevard C90

1 Answer

Went to start bike it clicked then went dead no lights nothing. Is there a main fuse that could have blown? Battery fully charged with good connections.

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 7 Answers

It sounds like bad connection. Check the terminals are securely connected either to the battery or engine. Simply trace the cable hope this help

Posted on Jul 28, 2014

4 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

  • 3 Answers

SOURCE: bike starter just clicks when trying to start

possible poor ground

Posted on Mar 23, 2009

  • 86 Answers

SOURCE: TL1000R bike won't start

Start checking fuses

Posted on Mar 30, 2010

  • 1 Answer

SOURCE: Honda 1985 1200 Gold Wing

put a new starter on ,now it seems to be very noisy in where the gears are since i put the new one on

Posted on Aug 12, 2011

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

1999 honda shadow 750cc wont start.key off ...tried hooking up led lights.. ran 2 grey wires from led lights together to headlight fuse turned key on ran 2 black wires from led lights to ground


Hi, Arleen before testing any electrical component in the Starting System it is "IMPERATIVE" that you have a fully charged battery of 12.5 volts or more and be able to pass a proper "LOAD" test if necessary, you may have a preliminary reading of 12.5 volts or more but little or zero amperage, the battery is faulty and must be replaced. AGM type batteries fall into this scenario more so than lead acid batteries.
1. Ignition Switch not in the "ON" position.
2. Engine Run Switch in the "OFF" position.
3. Check the battery terminals for damage or corrosion check the battery cables at "BOTH" ends for loose, corroded, or broken connectors, "INSIDE" and outside the cable harness, perform connector wiggle test and check cables with an ohmmeter.
4. Bank angle sensor needs a reset or is faulty.
5. FOB battery low or dead.
6. Faulty ignition switch.
7. Faulty starter button.
8. Faulty kickstand or clutch pull in switch/sensor.
9. Security alarm needs a reset.
10. Starter relay, solenoid, starter have failed or circuit wiring faulty.
11. Starter armature or field coils have failed.
12. Main fuse or circuit breaker may be blown or faulty.
13. The electric starter is working but starter clutch has failed.
14. Check for engine trouble codes.
For more information about your issue and valuable "FREE" downloads that you will need please click on the blue links below. Good luck and have a wonderful day.
Won crank over ACE Help Needed
cant start my 750 shadow
Honda 1998 VT750C Service Manual
http://www.partsfish.com/page/oem-parts-for-honda
Honda VT750C Owner Manual

May 22, 2017 | 1999 Honda VT 750 C2 Shadow

1 Answer

No power to 2001 yamaha 1600 road star. battery good, fuses good, starter relay good.


Hi, David and the usual suspects are:
1. Ignition Switch not in the "ON" position.
2. Engine Run Switch in the "OFF" position.
3. Discharged battery, needs to be 12.5 volts or better and be able to pass a load test if necessary, check battery terminals for damage or corrosion, check the battery cables at "BOTH" ends for loose, corroded, or broken connectors, "INSIDE" and outside the cable harness, perform connector wiggle test and check cables with an ohmmeter if necessary.
4. Bank angle sensor tripped and ignition/light key switch not cycled to the "OFF" position and then back to the "ON" position.
5. Faulty ignition switch.
6. Faulty starter button.
7. Faulty kickstand or clutch pull in switch/sensor.
8. Security alarm needs a reset.
9. Starter control circuit, relay, or solenoid faulty.
10. Main fuse or circuit breaker may be blown or faulty.
11. Electric starter shaft pinion gear is not engaging or over-running starter clutch slipping.
For more information about your issue and valuable "FREE" downloads that you will need please click on the links below. Good luck and have nice a day.
Re Electrical Starting System Failure Road Star Forum Yamaha Road Star
ROADSTAR FUEL PUMP INTERMITTENT FAULT
http://www.electrosport.com/media/pdf/fault-finding-diagram.pdf
http://www.vsoc-eastanglia.org.uk/xv1600.pdf
http://www.starmotorcycles.com/assets/service/manuals/2006/LIT-11626-19-45_Road_Star_1266.pdf

Jun 18, 2016 | Yamaha Motorcycles

1 Answer

Attempted to start the bike, there was one click from the battery area. Then everything went dead. No lights anywhere. I checked the battery. It is fully charged. Is there a fuse that could cause this?


If I'm not mistaken, I think the fuses are under the seat on these bikes... Not 100% sure but, on the older Shadows and Magnas and those type of bikes, the fuse panel slides into the side of a plastic cover. This would be right on top of the rear fender, under the seat if this the type of bike I'm thinking of. Good Luck!

Oct 29, 2013 | Honda VT 750 DC Shadow Spirit Motorcycles

1 Answer

Nissan Altama Starter Relay electrical problems or a fuse?


Double check the battery positive connection wiring carefully as it commonly has connection problems when the battery is changed.

Apr 08, 2017 | 2004 Nissan Altima

1 Answer

Went to start it, lights came on hit starter then all went off and nothing now


How good is battery, is it fully charged, else battery charger to charge it overnight first before trying again to start the bike. Cheers

Dec 19, 2010 | Yamaha Royal Star Venture Motorcycles

1 Answer

I own a 98 yzf. the battery was dead so i tried jumping it with a car i hooked the cables up with the car off. the lights on the bike went on so i tried to start it when i hit the ignition & the lights...


Yes it sounds like one. OK, find your abttery terminals, one is marked in black cable and the other has a red sleeve near the terminal. Follow the red cabel to a box that contain a 30A fuse, see if this is blwon, which most likely. Replace fuse and now use a trickle charger as car batteries has toooo much amperage to jump start a bike. If you have another bike battery it is fine to jump start, never try using a car battery as many damages can happen. Once battery is fully charged ( normally in 8 hours) try again for your bike to start. Cheers. If good give a return comment please.

Nov 07, 2010 | Yamaha SZR 660 Motorcycles

1 Answer

Nothing happens when key is turned and clutch is down, no clicking, no lights, battery is fully charged and terminals are tight. 1994 eagle talon fwd 5 speed 1.8L


Sounds to me like the ignition module went out. I would test the ignition module, then I would test the clutch safety switch. If these test out fine I would test the starter and replace it if it is suspected to be bad.

No lights really seems like the battery might be dead, or a fuse is blown. Check the main and alt. fuses.

Dec 26, 2009 | 1994 Eagle Talon

Not finding what you are looking for?
2005 Suzuki Boulevard C90 Logo

116 people viewed this question

Ask a Question

Usually answered in minutes!

Top Suzuki Experts

yadayada
yadayada

Level 3 Expert

75117 Answers

Arnie Burke
Arnie Burke

Level 3 Expert

4514 Answers

Ed Nelson
Ed Nelson

Level 2 Expert

149 Answers

Are you a Suzuki Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...