Question about 2002 Suzuki VL 800 Volusia

1 Answer

Speedometer quit working, the rest of the cluster is still working.

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Expert
  • 121 Answers

It may be that the speed sensor failed. This is a common item to go bad on this bike. If you look at the right side of the front tire where the axle is, you should see a black "donut" looking device snugged up to the hub; That is the speed sensor. It operates magnetically, so there is not a cable, just a wire. In order to change the sensor you will need to remove the front tire assembly.

Since the brake pads will come loose when you remove the tire, check those for wear and replace them if necessary.

God bless and good luck.

Posted on Oct 09, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
New users get to try the service completely Free afterwhich it costs $6 per call and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

The speedometer on my 2004 Pontiac Montana quit working. Is there a fuse for that?


Nope. The speedometer needs a signal from the vehicle speed sensor to operate. Is the check engine light on? If so, scan for any codes that may indicate a VSS problem. If no codes, possible internal cluster issue with the speedometer head

Jan 27, 2016 | Pontiac Cars & Trucks

1 Answer

Speedometer quit working


Hi, this is a pretty common problem on these Silverado instrument clusters. We can repair it for you or provide you with the parts to do it yourself. Click here to learn more about these silverado instrument cluster problems: Dr Speedometer Instrument Cluster Repair Speedometer Repair Guage...

Feb 27, 2014 | 2003 Chevrolet Silverado 1500

1 Answer

All my gauges quit on my 2003 silverado the dash lights still work but none of the gauges move


Hi, this is a pretty common problem on these Silverado instrument clusters. We can definitely help you out with that. Click here to learn more about these Silverado instrument cluster problems: Dr Speedometer Instrument Cluster Repair Speedometer Repair Guage...

Jan 09, 2014 | Chevrolet Silverado 1500 Cars & Trucks

1 Answer

1994 Nissan pu speedometer quit working


SPEEDOMETER TROUBLESHOOTING


Can be loose speedo wiring connectors under instrument panel or its issue with speed sensor on transmission.


I suggest you to go through help links mentioned below with appropriate solutions to confirm the problem :------


How to trouble shoot speedometer?

http://schematicsdiagram.blogspot.com/2011/06/speedometer-not-working.html

-----------

1996 fiat bravo speedometer not working?

http://technoanswers.blogspot.com/2012/01/1996-fiat-bravo-speedometer-not-working.html
------------

Speedometer works but odometer not working?

http://technoanswers.blogspot.in/2012/01/speedometer-works-but-odometer-not.html

-----------

Speedometer runs backward?

http://technoanswers.blogspot.com/2012/01/speedometer-runs-backward.html

-------------

Warning lights on and speedometer died?

http://howtobyme.blogspot.com/2011/08/warning-lights-on-and-speedometer-died.ht

-------------

Speedometer not working on 1993 Ford F350?


http://repairhelpcenter.blogspot.in/2012/02/speedometer-not-working-on-1993-ford.html

----------

ABS & Brake lights warning indicator steady on dash and speedometer not working for Dodge Ram?

http://howtobyme.blogspot.com/2011/11/abs-brake-lights-warning-indicator.html

-----------

Vehicles Cluster panel Not reading Miles?

http://schematicsdiagram.blogspot.com/2011/12/vehicles-cluster-panel-not-reading.html

-------------

Odometer works properly but speedometer works intermittently?

http://technoanswers.blogspot.com/2012/01/odometer-works-properly-but-speedometer.html

-------------

These will help.

Thanks.

Feb 04, 2013 | Nissan Cars & Trucks

1 Answer

Speedometer quit working on 1999 Chev Cavalier. Tthin it is the output sensor. Where is this sensor located ??


It on the back of the instrument cluster circuit board but, these clusters are faulty sooner or later all of the gauges will quit working replace the cluster

May 01, 2011 | 1999 Chevrolet Cavalier

2 Answers

I HAVE A 1994 GEO PRISM 1.6L THE SPEEDOMETER DOESNT WORK , I REPLACED THE CLUSTER AND THE SENSOR THE SPEEDOMETER REACHES 35MPH AND THATS IT ANY SUGGESTIONS.


I've had a similar problem with my '94 prizm. I had to replace the instrument cluster about seven or eight years ago because the speedometer quit working. After replacing with a used instrument cluster it's been working fine till now. However, the problem is back again....so I'm looking for another used one. There is definately a weakness in this speedometer design when the mileage on the car gets high. Your problem is different since you replaced both the sensor and the speedometer and it still doesn't work. Chances are, you got a speedometer that didn't work to begin with. I would try another used one.

Apr 11, 2010 | 1994 Geo Prizm

2 Answers

Dash lights for speedometer and tach don't work. All fuses are good. 95 Jetta


You have a bad electrical cluster. Replace the cluster and your dash lights speedometer and tach should work just fine.

Jan 25, 2010 | 1995 Volkswagen Jetta

1 Answer

Speedometer Quit working, odometer also. Don't


Hello.
What sounds like happened is that the instrument cluster fuse sounds like its burnt out. Otherwise the wires on the back of them both may have been knocked out. Very simple fix if its the fuse, if not, pull the cluster out and check the wiring. Hope this helps!
-Steve

Dec 06, 2009 | 2006 Kia Spectra

Not finding what you are looking for?
2002 Suzuki VL 800 Volusia Logo

197 people viewed this question

Ask a Question

Usually answered in minutes!

Top Suzuki Experts

yadayada
yadayada

Level 3 Expert

76630 Answers

Arnie Burke
Arnie Burke

Level 3 Expert

4533 Answers

Richard
Richard

Level 2 Expert

83 Answers

Are you a Suzuki Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...