Question about 1997 Yamaha YZF 600 R thunder cat

1 Answer

I have a 2004 yzf 600r My speedo cable was mangled at the end connecting to the front wheel. I replaced it with a new cable and was sure to get everything out of the connect points . When I put the new cable on I maybe went 10 ft and realized It still wasnt working. I removed it at the wheel and the same thing happened again...it was managled up. Am I doing something wrong or is there a problem I dont know of.

Posted by on

  • anderson_art Sep 17, 2010

    Thanks, I will try what you said and hopefully it wont be anything major

×

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Master
  • 2,427 Answers

Hmm I dont think yopur doing anything wrong,, but there isnt any reason the cable should strip unless its meeting an opposite force holding it back.. change the cable again but this time disconnect it from the Speed-o-Meter,, leave it only on the front wheel.. drive ,, ok cable is good right ??? If so reconnect it tom the speed o meter ,, Hopefully it remains good and works ,, if not then change the speed-o-meter..

If its didnt remain good on the fron wheen you will need to change the port the cable connects to,, chances are the grears are shot and stripping your cable..

Posted on Sep 17, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

YZF R125 Engine Management light on, but engine runs ok.


I had this exact problem with my r125. My speedo just read 0 and warning light came on. This is caused by a faulty speedo cable. You need to unclip it from under the clocks (the white connector running to the side of the front wheel) and take the front wheel off. Then replace the speedo sensor with a "new" one (quite fiddly to put all back together). Got mine off eBay for just a few pounds. When it's all back together, the warning light will still be on, but when you ride off and the speedo reads something other than 0, the light will go off, and problem solved! When your wheel is off, take the time to re lube the axle, makes putting the axle back in so much easier and your front wheel will turn so smoothly and freely. Make sure you keep note of how the spacer goes in, and I'd get a friend to help support the wheel as you put it back in, makes it so much easier as it's quite fiddly by yourself.

Mar 24, 2013 | 2008 Yamaha YZF-R125

1 Answer

I have a yamaha thunderace 1000 & my spedo has stoped working.Its not my cable.can anyone tell me what it could be? Many Thanks carlo


Go for a ride and take note of the trip counter/odo. Does it tick over? If it does then the problem is in the speedo unit itself and you're looking at a costly replacement. Internal speedo parts are not sold seperately. You replace the unit as a whole. In this case e-bay is your friend. ;-)
If that doesnt solve it, remove the cable from the speedo end, leave connected at the wheel. Inside the cable is the inner drive which looks like a tightly wound spring. You should be able to remove it from the cable in one piece. (Might as well oil it while it is out. Motor oil will do) It should come out in 1 piece. Have a look at the ends. They should have a part of it squared off where it fits in the speedo and the at the other end where it fits in the wheel drive gear. Now put the inner back into the cable and reconnect to the wheel only. On the speedo side(which should still be hanging loose) grip the inner by hand and try to turn it. You should be able to get about half a turn and when you release it, it should return to its original position. If this does not happen the problem is in the wheel. The inner is not seated properly in the drive gear or the gear is faulty. The same can also be true of the speedo end.

Jul 06, 2010 | 1997 Yamaha YZF Thunder ace 1000 R

1 Answer

2002 yzf600r speedo cable fell off


If you but a new cable it will have an inner to it, which is a flexible drive that spins with the wheel, the fluid is a just some lubrication left after the inner has fallen out on the road.
The cable connects to the speedo with a similar fitting to the one at the bottom, you will likely need to remove some fairing parts to get your hand or pliers in there

Jun 19, 2010 | 2000 Yamaha YZF-R6

1 Answer

The speedo on my 1992 xr250r doesnt work, cable and speedo r fine, how do i remove and check the part of the speedo that is mounted on the front wheel


First, remove the lower end of the speedo cable from the speedo gear box on the front axle. Then, lift the front wheel off the ground and remove the wheel. To remove the speedo-drive gear box, unscrew the axle nut that holds it in place. With the speedo-drive removed, inspect the two flanges that fit into the slots on the wheel hub, making sure they haven't gotten bent - or sheared off. When you turn flange on the speedo-drive, it should turn freely and you should be able to see the speedo cable drive-blade spinning. If not, then you will need to replace the whole unit because the worm gear inside has become excessively worn.

Nov 04, 2009 | 1992 Honda XR 250 R

1 Answer

How to fit a speed sensor on a yamaha r6 1999


Speed sprocket is on leftside of front wheel. Disconnect speedo cable from under speedometer itself and turn front wheel to see if cable turns. If not dis connect at front wheel and try turning cable, it's a squared pieces of cable inside black casing. If you can pull both ends out then it is definetly broken. This is much more likely than breaking the speedo sprocket on front wheel. If it is speedo sprocket, get a new one and remove front wheel , change sprocket and reassemble. If Speedo sprocket is being stubborn coming out use something relatively soft and tap it out. Good Luck.

Oct 10, 2009 | 1999 Yamaha YZF-R6

1 Answer

How to replace the speedo cable on a yamaha yzf 600 r


Thread new cable into place alongside old cable. As you remove tiedowns or clamps holding old cable place new cable in as you go. Undo bottom of cable at front wheel, replace with new cable. Do the same underneath speedometer and you are done.

Oct 05, 2009 | 2005 Yamaha YZF 600 R thunder cat

1 Answer

Aprilia RS 125 (2004) - speedo not working


it may have snapped in the middle of the cable or check the drive in the front wheel

Aug 04, 2009 | 2004 Aprilia RS 125

1 Answer

98 yzf 600R..Right fork leaking. Problem and fix?


it sounds like your fork seal has failed,it wont affect your brakes but will make your front suspension feel a wee bit "soggy"and will affect your handling,i would suggest getting the seal replaced as evetually the oil from the faulty seal will contaminate your brake pads that will affect your braking performance,replacing the seal,sooner rather than later ,would be a wise move..hope this helps...cheers

Jul 29, 2009 | 2004 Yamaha YZF 600 R thunder cat

3 Answers

Speedometer not working


Check your speedometer gear box, it probably got bumped during removal/installation. The cable may have got pulled out. You can see the gearbox here: http://fiche.ronayers.com/Index.cfm/Module/Main/TypeID/26/Type/Motorcycle/MakeID/2/Make/Suzuki/YearID/45/Year/2004/ModelID/6619/Model/VL800Z_INTRUDER_VOLUSIA/GroupID/279409/Group/FRONT_WHEEL

Jun 15, 2009 | 2004 Suzuki VL 800 Volusia

3 Answers

SPEEDO IS NOT WORKING


the connection on your front wheel where the speedo cable connects the link between the cable and gear more than likely broke you will need new speedo cable it happened to my cruiser

Feb 18, 2009 | 2007 Yamaha XT 125 X

Not finding what you are looking for?
1997 Yamaha YZF 600 R thunder cat Logo

Related Topics:

35 people viewed this question

Ask a Question

Usually answered in minutes!

Top Yamaha Experts

dhnguyen

Level 2 Expert

281 Answers

Steve Sweetleaf
Steve Sweetleaf

Level 3 Expert

1144 Answers

Tony

Level 3 Expert

2600 Answers

Are you a Yamaha Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...