Question about 2003 kawasaki KX 125

1 Answer

My 03 KX125 just had a new crank kit and top end installed. Bike ran great first few times out. Now it's misfiring under a load. It revs great in neutral and is very responsive, but when accelerating under load, the bike misfires pretty bad. I cleaned the carb, installed new plug, and the reed valves look ok. Any idea??

Posted by on

Ad

1 Answer

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 2 Answers

Muffler bearings definately

Posted on Sep 09, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My GSXR 750 J runs extreemly rough between 7000 and 9000 rpm. Its a mildly tuned engine with after market cams, a dynojet kit and I recently installed some inline fuel filters. The bike runs perfectly...


I would check and adjust the static ignition timing as if too far retarded it will tend to misfire at mid range revs. and suffer from lack of power at the top end.

Mar 01, 2011 | 1988 Suzuki GSX-R 750 J

1 Answer

My kx125 i put a piston in it not to long ago got least 6 times to ride it hard know the top end sound like its pinging and when i rev the bike it boggs and sound like a 4 stroke and sound like a car...


i had the same problem. sorry to say but its your piston again. have you been letting it warm up before riding. checked oil before and after every ride. if yes then when the new piston was fitted something wasnt done properly

Aug 20, 2010 | 2004 kawasaki KX 125

1 Answer

Engine misfires around 5000 revs and sometimes


Give your bike a tune up, Plugs , Air filter, clean the carbs. Do these jobs one at a time till the problem goes away, Dirty fuel from leaving the bike unused can also give grief.
Happy hunting

Jun 06, 2010 | 2005 Yamaha FZS 1000 Fazer

1 Answer

Have put a new piston kit in my 1993 kx125 dont have a kickstart and it wont bump start 4 some reason,theres fuel going through and there is a spark but a weak one will just a new plug get it going?


how long was your bike sitting for when you did the new piston? change the old fuel out the tank if the bike has been stood for along period of time the fuel may have gone off. have you installed the piston the correct way round?

Apr 23, 2010 | kawasaki Full Suspension Mountain Bike Men

2 Answers

2002 kx125 no spark


its prob your magnito with out a good connection to magnito it wont spark at all,could also be spark plug wire



My bike,
Kx125

Dec 21, 2009 | 2003 kawasaki KX 125

1 Answer

My jeep CRD 2.7 started to misfire at low revs in the mornings but seemed ok when warm. the injector on cylinder 1 then started to leak and it went into limp mode, this was repaired.A few weeks later it as...


Austrian assembled Cherokee's have a 5 cylinder 2.7 Mercedes motor. These are a serious piece of kit and put the US product to shame. Sadly they still suffer from the usual reliability issues . The worst of which is the habit of blowing the injector seals . As the engine is a tight fit and removing the rear two injectors require dropping the motor, this can be a very expensive problem and can happen as early as 40000kms. Still a great machine!!

Oct 11, 2009 | 2003 Jeep Grand Cherokee

1 Answer

99 yz 125, just put a new crank and new gaskets, ran great, readjusted the timing after initial break in, still ran great, a few weeks later its missing at top end, and sounds like it jumps immidiatly to...


sounds like you may have a base gasket orseal leaking. you should do a leakdown test on motor. buy a manual and it will save you tons of money. a service overhaul manual

Jul 11, 2009 | 2003 Yamaha YZ 125

Not finding what you are looking for?
2003 kawasaki KX 125 Logo

297 people viewed this question

Ask a Question

Usually answered in minutes!

Top kawasaki Experts

Arnie Burke
Arnie Burke

Level 3 Expert

4536 Answers

yadayada
yadayada

Level 3 Expert

76649 Answers

bazzz7071
bazzz7071

Level 2 Expert

342 Answers

Are you a kawasaki Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...