Question about 2003 Harley Davidson FLSTFI Fat Boy

1 Answer

I just replaced speed sensor 5 weeks ago. It stopped working again on September 3rd. My bike also has died twice when I came to a stop sign. the little red light that comes on when I turn ignition on , I wait till it goes out then start bike, the light comes back on after bike starts then goes out again in about 5 or 6 seconds. Runs fine on top end but when I come to stop it wants to stop running. Any Ideas? (sure would appreciate any help)

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

Hi! I have exactly the same problem. Have you found a solution yet?
Morten

Posted on Feb 02, 2011

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

P0440 engine stopped


That code is an emissions cannister leak and is not related to the engine failure. IT is most likely the crank shaft sensor that is bad.

Apr 08, 2014 | 1999 Nissan Maxima

1 Answer

Yamaha '2005 Xv250 idling problem


Have the shop put in a richer pilot jet, aka "slow jet". Also, move the needle clip down one notch for better low end performance.
Can I get a “very helpful” rating on this answer?

Aug 17, 2009 | 2006 Beta RR 250

1 Answer

Rough Idle and then the veh cuts off


Have you tried cleaning the mass air flow sensor ? Use Qtip and carb cleaner to remove any gunk on the two wires that strech across the inside.

Mar 19, 2009 | 1999 Pontiac Grand Am GT

2 Answers

2002 miata ls driving @ 80 mph engine stalls dies let set for 10min restarts and runs fine gives obd2 code p0340 camshaft sensor


I have had the same problem on my 2000 Miata. Turned our it needed a new cam sensor. Had it replaced 9 months ago and now it has occurred again. They are replacing the cam sensor again.

Mar 18, 2009 | 2000 Mazda MX-5 Miata

1 Answer

1996 Jeep Grand Cherokee stalls when brakes are applied


My 2000 Grand Cherokee had the same problem, without all the sputtering, it would just die approaching a stop. We could only keep it running by slightly pushing down on the gas petal when coming to a stop. I replaced the Throttle Position Sensor, but that didn't change anything. A new mechanic I found replaced the Idle Air Control Valve, and we've had no problems in a week.

Jan 02, 2009 | 1986 Jeep Cherokee

1 Answer

2000 grand am se blower


It could be the actual switch maybe???

May 05, 2017 | 2000 Pontiac Grand Am GT

Not finding what you are looking for?
2003 Harley Davidson FLSTFI Fat Boy Logo

196 people viewed this question

Ask a Question

Usually answered in minutes!

Top Harley Davidson Experts

Arnie Burke
Arnie Burke

Level 3 Expert

4514 Answers

Gills Lango

Level 2 Expert

195 Answers

Mike

Level 3 Expert

4336 Answers

Are you a Harley Davidson Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...