Question about 2000 Harley Davidson FXST Softail Standard

1 Answer

I was riding and noticed my speedometer and turn signals quit working. Soon after that my bike lost all power, would idle but would not throttle up. my head and tail light were on but dim. Shut it off and tried to start and nothing, not even a click. Put a new battery in it, everthing seem to be working fine and road it home. Nothing seemed to be hot. Would this be the voltage regulator?

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that hasĀ over 10 points.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 6 Answers

Yes it could be or could be your charge system did the battery go down after u drove it

Posted on Sep 05, 2010

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Speedometer, turn signals and horn quit working, speedometer light doesn't work


Hi, Brian I do not know what type of bike you have but this is what I tell all my Harley friends with electronic speedometers the vast majority of speedometer issues is caused by the speed sensor and or the wiring, a faulty speedometer sensor and or connection will automatically interrupt proper turn signal and flasher operation. On Sportsters the sensor is located on top of the engine case behind the rear cylinder, on big twins, it's located on the right side of the transmission case between the starter end cap and the transmission top cover. Remove the bolt/***** that secures the sensor and lift the sensor out of the case. Inspect it for damage and contamination, if there appears to be no damage wipe the end of the sensor clean and reinstall, you can go for a short quick test ride to see if the speedo is working. If the issue still exists grab your test light and unplug the harness connector from the sensor, check for power (red wire) and ground (black wire) continuity coming from the speedo, there is also the connector that plugs into the speedometer, also, look for corroded, broken or loose pin/sockets. If everything checks out OK then replace the speed sensor. Good luck and have a nice day

Mar 28, 2016 | Motorcycles

1 Answer

The primer pump light on my 2004 ultra


I think you mean the engine management light. I do not know of a 'pump primer light' on any Harley. If this light is coming on when driving, and staying off when idling, then you have a problem which needs investigating. Golden rule, red light on - stop motor or damage iminent. Orange light on - needs looking at as soon as possible. check for historic DTC codes using speedometer and repost with these or bring bike to dealer.

May 26, 2014 | 2004 Harley Davidson FLHTCUI Electra Glide...

1 Answer

2006 v star 1100 classic w/ vance + hines slip on exhaust. I get popping at idle and decel (i'm thinking it just needs to be rejetted). The big problem, is when the bike has already warmed up (at least 5...


The popping at idle and deceleration (when the throttle is in the idle position) could be a lean mixture at idle.
A lean mixture sitting at idle for a long light would cause the engine to run hot.
Also, as the engine reaches operating temperatures, the idle will pick up.

Oct 08, 2013 | Yamaha V Star 1100 Classic Motorcycles

1 Answer

Erratic speedometer


Hi Anonymous, your going to have to check every pin connection in every wiring harness in the light circuit for corrosion, breaks, or loose fit in connector. For a free wiring diagram please to visit website below:
Harley Davidson Wiring Diagrams and Schematics
Good luck

Apr 04, 2012 | 2001 Harley Davidson FXDX Dyna Super Glide...

1 Answer

Backfiring


4000 rpm ???????

Feb 14, 2012 | 2000 kawasaki ZX-9 R Ninja

1 Answer

Speedometer stoped working and turn signals won't


Your turn signals will not shut off automatically if the speedometer is not working. As for why the speedo is not working, I'm afraid I can't help you with that as I know nothing about them but I'd check the speedometer sending unit in the transmission first. It's supposed to generate a pulse for the speedometer. I work on the older bikes that the dealers will no longer work on and some Evolution powered bikes. I do not work on the digital electronics nor fuel injected bikes. I'm sorry I can't help you more.

Good Luck
Steve

Sep 17, 2011 | 2000 Harley Davidson FLHTCUI Electra Glide...

1 Answer

I replaced my NGK CR8E spark plugs with the new NGK CR8EIX Iridiums on my 2009 Hyosung GV650...and immediately after starting up the bike, I heard an electrical buzz in the front of the bike and shortly...


Hi, Skjc01 before diagnosing any turn signal/running light/parking light issue make sure the bulb is good and the light fuse has continuity with a test light. If you have replaced your OEM lights with LED lights you are going to need a load equalizer. If no turn signals work the cause could be a faulty turn signal module or the connector going to it, look for corroded, loose, or broken pins/sockets. Contact spray cleaner is great for removing corrosion. If your speedometer does not function properly it will have to be fixed first because your turn signal module gets the data from the speedometer for normal turn signal function. If your front turn signals don't work use a test light to check for power and ground at the bulb socket, then start backtracking the wiring through every wire connector to the turn signal switch/button and check for continuity, go all the way back to the fuse if necessary to find the cause of the malfunction. If your rear turn signals don't work check your rear fender wiring harness connector first for corroded, broken, loose pins/sockets, power, and a good ground, (the harness connector is usually located under the seat on the front of the rear fender) then keep tracing the wiring look for obvious harness damage caused by the rear tire. If you still can't find the malfunction backtrack from the rear fender wiring harness connector. If one side does not work you could have a faulty turn signal switch or module check for continuity.
For more information about your issue and valuable "FREE" downloads that you will need please click on the blue links below. Good luck and have a wonderful day.
2007 Hyosung GV650 Avitar turn signal buzzer intalled
2006 Hyosung LED Turnsignals Fix
HYOSUNG Aquil GV650 Service Manual
HYOSUNG AQUILA GV650 CATALOGUE Manual
HYOSUNG GV650 User Manual

May 01, 2017 | 2011 Hyosung GV 650 SE

1 Answer

I HAVE A 2009 SUZUKI 250GZ ONLY 500 MILES ON IT WITH INTERMITTED TURN SIGNAL ISSUES. THE TURN SIGNALS WORK SOME TIMES AND SOMETIMES THEY DON'T. SOME TIMES WHEN THE BIKE IS JUST TURNED ON THEY BOTH WILL...


Hi, Jimbenesh nice novella, before diagnosing any turn signal/running light/parking light issue make sure the bulb is good and the light fuse has continuity with a test light. If you have replaced you OEM lights with LED lights you are going to need a load equalizer. If no turn signals work the cause could be a faulty turn signal module or the connector going to it, look for corroded, loose, or broken pins/sockets. Contact spray cleaner is great for removing corrosion. If your speedometer does not function properly it will have to be fixed first because your turn signal module gets the data from the speedometer for normal turn signal function. If your front turn signals don't work use a test light to check for power and ground at the bulb socket, then start backtracking the wiring through every wire connector to the turn signal switch/button and check for continuity, go all the way back to the fuse if necessary to find the cause of the malfunction. If your rear turn signals don't work check your rear fender wiring harness connector first for corroded, broken, loose pins/sockets, power, and a good ground, (the harness connector is usually located under the seat on the front of the rear fender) then keep tracing the wiring look for obvious harness damage caused by the rear tire. If you still can't find the malfunction backtrack from the rear fender wiring harness connector. If one side does not work you could have a faulty turn signal switch or module check for continuity. For more information about your issue and valuable "FREE" downloads that you will need please click on the blue links below. Good luck and have a wonderful day.
Turn Signals Don Work Sometimes
Motorcycle Turn Signals Quick Fix YouMotorcycle
Suzuki GZ250 Service Manual
OEM parts for Suzuki
Suzuki GZ250 Owner Manual

Feb 28, 2017 | Suzuki GZ 250 Motorcycles

1 Answer

I have a 99 road king 1550 fuel injected. on the way on a trip the engine lost power and shut down . cranked but no start. Took it to harley dealer where they found that the computer was fried, front...


Interesting story but other than the low idle, you never said how the bike was running. I must assume that it's running alright other than your concern that it may be running lean due to your fuel mileage. You're mileage is about nornal for an engine as large as yours. My 1340 Evo gets about 45 miles per gallon. If you had a vacuum leak on the manifold seals, you would notice it mostly at idle speeds. The idle speed would probably vary considerably while sitting still. It may even cause one cylinder to miss. As long as your bike seems to be running good, ride it and enjoy it.

Ride Safe
Steve

Aug 11, 2010 | Harley Davidson FLHR - FLHRI Road King...

1 Answer

No headlight,signal light,tail lights, or speedometer power.


id say it was a fuse or maybe cdi box take an ohm meter and check it out man see what happends

Mar 06, 2009 | 2001 Yamaha V Star 1100 Classic

Not finding what you are looking for?
2000 Harley Davidson FXST Softail Standard Logo

237 people viewed this question

Ask a Question

Usually answered in minutes!

Top Harley Davidson Experts

Arnie Burke
Arnie Burke

Level 3 Expert

4514 Answers

Gills Lango

Level 2 Expert

195 Answers

Mike

Level 3 Expert

4336 Answers

Are you a Harley Davidson Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...