Question about 2000 Harley Davidson FLHTCUI Electra Glide Ultra Classic

1 Answer

Washed my bike now it won't start. When I switch to run, no light indicator comes on. It will cycle through the start but will not crank.

Posted by on

Ad

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Mayor:

    An expert whose answer got voted for 2 times.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 5 Answers

Sounds electrical and I assume the fuses are ok. Try a blow dryer on any areas that you think might have gotten water where it shouldn't be.

Posted on Sep 05, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I washed my 2012 softail slim went to start it all the lights came on except the neutral light and the dam thing won't start and yes the bike is in neutral I push the start button and get nothing


Hi, Michael electrical components do not like water check your fuses and the usual suspects are:
1. Ignition Switch not in the "ON" position.
2. Engine Run Switch in the "OFF" position.
3. Discharged battery, needs to be 12.5 volts or better and be able to pass a load test if necessary, check battery terminals for damage or corrosion, check the battery cables at "BOTH" ends for loose, corroded, or broken connectors, "INSIDE" and outside the cable harness, perform connector wiggle test and check cables with an ohmmeter if necessary.
4. Bank angle sensor tripped and ignition/light key switch not cycled to the "OFF" position and then back to the "ON" position.
5. Faulty starter button/switch.
6. Faulty jiffy stand or clutch pull in switch/sensor.
7. Security alarm needs a reset.
8. Starter control circuit, relay, or solenoid faulty.
9. Main fuse or circuit breaker may be blown or faulty.
10. Electric starter shaft pinion gear is not engaging or over-running starter clutch slipping.
For more information about your issue and valuable "FREE" downloads that you will need please click on the links below, and for specific information or questions please feel free to contact me at xlch@mail.com Good luck and have nice a day.
Harley Davidson Manuals Mark Workshop
http://www.stcharlesharleydavidson.com/OEMpartfinder.htm
Owner Manuals Harley Davidson USA
BIke won start Acts like dead battery but it isn
Harley Davidson Softail Won Start
Instant Tech Relief A must have !!! only $6 a month "CHEAP"

Apr 17, 2016 | DAM Motorcycles

2 Answers

Turns over but indignation button won't fire


possibly you have water in the electrical, let it dry and retry.

Jun 06, 2013 | Triumph Motorcycles

1 Answer

Have a 2000 electric glide classic, no spark at the plugs after washing bike


The bike threw a code. My guess is a misfire code. I would check to make sure you didn't get water in the kill switch at the right handlebar control. Water in the run/off switch could short out the switch and cause the problem you are having.

Jun 16, 2012 | 2002 Harley Davidson FLHTCUI Electra Glide...

1 Answer

Fuel gage quit, turn signals canceler quit, fuel pump quit, won't start


With the bike turned off, remove the TSM/TSSM. This is the security module. Make the sure these connections aren't wet. And quit powerwashing your bike!

May 19, 2012 | 2002 Harley Davidson FLSTF - FLSTFI Fat...

1 Answer

Washed bike - now no power


does it crank? Or just run badly?

Apr 20, 2009 | 2007 Yamaha V Star 1100 Silverado

1 Answer

My bike wont start up, fuzes are good, oil good, new battery. Bike wont turn over to star.


Hi and welcome to FixYa,

Initially, determine if there is a clicking sound when the START button is pressed. The click is significant. If there is, this indicates that the starting relay is engaging but for some reason, the starter motor is not cranking. This could either indicate a faulty starter relay (particularly the contacts) or a faulty starter motor (specifically, the carbon brushes). To determine which:
  • with the side covers off, expose the starter relay particularly the 2 large terminals;
  • have somebody start the bike normally using the key and button start switch;
  • determine if indeed the clicking is coming from the starter relay;
  • while the start button is still pressed, jump the 2 big terminals;
  • if the engine cranks, then the internal contacts of the starter relay are corroded or burned;
  • if the engine will not crank, then the starter motor is faulty.
If there is no click, you may want to check the alarm/security/immobilizer if your bike is so equipped. others to check would be side stand switch, clutch switch and neutral light indicator.

Good luck and thank you for using FixYa.

Feb 21, 2009 | 2004 Yamaha YZF 600 R thunder cat

Not finding what you are looking for?
2000 Harley Davidson FLHTCUI Electra Glide Ultra Classic Logo

216 people viewed this question

Ask a Question

Usually answered in minutes!

Top Harley Davidson Experts

Arnie Burke
Arnie Burke

Level 3 Expert

4521 Answers

Mike

Level 3 Expert

4340 Answers

yadayada
yadayada

Level 3 Expert

76109 Answers

Are you a Harley Davidson Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...