Question about 2005 Aprilia MX 125

1 Answer

I seem to have a top end splutter on my mx125 i have changed the cdi and coil and the full loom and it is still doing it i had a new carb fitted and new reeds and a new plug can any 1 help me plz

Posted by on

Ad

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Contributor
  • 296 Answers

2-stroke engines misfire regularly under light loads — sounds more like a flutter or sputter..

My guess would be that at the high end you are running out of torque, resulting in a light-load condition, and that characteristic 2-stroke misfiring is taking place. If you are simply running out of the engine's ability to give more, you might be stuck with this behavior.

Posted on Aug 04, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Miss fire after up to temp and runfor short amount of time. I get a miss fire coming to a stop..drops to cylinders or 1. will not accelerate at all boggs with miss fire.


Joe, i'm afraid we'll need some more info; year, make and model. Have you changed anything to after market like air cleaners or exhaust? How many miles are on it?

Jan 14, 2015 | Motorcycles

1 Answer

Fault code vauxhall corsam


Have you had an oil pressure switch replaced recently ? If so the problem is probably the engine wiring loom,what happens is the oil leaks into the loom and ends up at the plugs for the ECU and the coil pack and crank sensors,meaning they all need to be replaced.

May 04, 2017 | Vauxhall Cars & Trucks

1 Answer

Starts but mis fires


I know it sounds too simple but the aircleaner element is worth checking. Even if it looks only a little grey still replace it. Are the spark plugs fouling?? If so I would do the air filter replacement.

Nov 29, 2013 | Motorcycles

1 Answer

I have a 1990 kx 250, just had the top and bottom end done. Rode it for four hours and it died! Replaced the cdi box with new one, replaced the coil and stator and I still have no spark'


chec battery-must always be at 12.6volts-any lower and bike wont function--inspect connections for corrosion--also make sure carb and fuel delivery are correct

Jan 08, 2013 | Motorcycles

2 Answers

My 1992 yamaha serow xt225 seems to not have full power if I'm riding with full throttle and pull the choke its power is a little better but once u hit sixth gear I cannot too it out ... Any...


Hey I got a serow too, in Thailand. Love the bike but lots of issues, no parts there. Runs great on cool mornings, heats up and acts likes it hits every other cycle. Thought cdi, but fires good when you make it jump to plug. New plug, no change. Carb is not original, going to start there. Think its a 92, think it only 5 gears. Original japan with strange vin. Carb and valve adjust might fix it. Any suggestion?

Nov 25, 2012 | Motorcycles

1 Answer

92 virago 750. Front cylinder runs intermittently. Coil is good. I cleaned carbs. Suspect CDI. Seems to run fine until it warms up. I recently put new Voltage Regulator in. Stator is not shorted. and...


You have to test all the electronics on the bike to figure out if you have a bad CDI box. A CDI box can test good and still be bad. Your problem sounds more like a bad spark plug cap. Unscrew the cap from the end of the wire and take an OHM reading on the cap. If it is higher or lower than 5000 OHMs replace the cap . A plug cap from NGK runs about $5. Replace them both for about $10 it should take care of the problem.

Oct 04, 2010 | Yamaha XV 535 Virago DX Motorcycles

1 Answer

Rm125 1999 no spark


what comes out of CDI box? if you have it going in it is rectified and more will come out. If not change CDI

Feb 25, 2010 | 2003 Suzuki RM 125

1 Answer

99 cr80 starts but cuts out at the top end of 4th gear. jets and carb clean air filter clean just had a new top end and new packing in exhaust


cuts off or breaks up?? if it breaks up it could be a couple of things bad reeds or electrical like stator or cdi bog ign coil check those

Jul 11, 2009 | 2002 Honda CR 125 R

1 Answer

1989Fzr6 3he bike/ 1995 4jh engine


does the bike have a fuel pump?what carbs are you running ?are the carbs in sync?

May 13, 2009 | 1995 Yamaha FZR 600

Not finding what you are looking for?
2005 Aprilia MX 125 Logo

196 people viewed this question

Ask a Question

Usually answered in minutes!

Top Aprilia Experts

yadayada
yadayada

Level 3 Expert

76109 Answers

Arnie Burke
Arnie Burke

Level 3 Expert

4521 Answers

Fabrice Wolters

Level 2 Expert

265 Answers

Are you an Aprilia Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...