Question about 2000 Harley Davidson XL 1200 C Sportster Custom

1 Answer

Bike is dead. battery ok. not even a headlight???

I just bought the bike. I put about 200 miles on it and never had a problem. The bike has 3280 miles on it. Last night I went to start it and nothing. I figured the battery was dead, so I charged the battery, put it back in, and still nothing... the headlight or nuetral light, and mileage isn't even showing up when I turn it on. Its like its dead. Please help!!! Its an 03 1200 custom sportster (anniversary) I was thinkin it could be a fuse but I have no clue where to find it. Thanl you so much if u can help, and for your time if u can't.

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Brigadier General:

    An expert that has over 10,000 points.

  • Master
  • 4,565 Answers

The fuses are probably behind the trianglular plate on the right side of the bike. It may be that the bike has a security system on it as well and something has tripped it preventing it from being started.

Posted on Jul 14, 2010

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Hi i have a 2000 fxst harley i put new starter in my bike,than i couldnt get it started so i put new coil and plug wire it run good for 6 or 7 mile,now front plug has kno spar.


Why did you change the starter? Because it had a dead battery? If your battery is not getting charged (is the headlight bright when the engine is running?) you will get kno spar pretty quickly.

Sep 26, 2014 | 2000 Harley Davidson FXST Softail Standard

1 Answer

2005 Dyna Wide Glide- alternator problem?


change battery first step. if goes flat then its the rectifier thats the problem

Mar 15, 2013 | 2005 Harley Davidson FXDWG - FXDWGI Dyna...

1 Answer

Ridding my 94 FXR Harley and all of a sudden it stopped running, leaving me stranded on the side of the road. Everything was going normal untill it died and when it died it started to sputter as if it were...


The first thing I'd suspect is the battery. I've seen batteries break battery posts, suffer from internal shorts, and all sorts of problems. You FXR, as well as the Softail bikes, is very tough on batteries. This is due to the fact that the battery is in such close proximity of the hot oil tank subjecting the battery to higher temperatures than other model bikes. Vibration is a contributing factor in the Evolution and earlier bikes as well even if they do have rubber mounted engines. I'd take the battery out and take it to an automotive parts store and ask them if they can "load test" it for you. If the battery test good, you need to check to see if the main circuit breaker is tripping indicating a short circuit somewhere.

Good Luck
Steve

Aug 29, 2011 | Harley Davidson FLHT Electra Glide...

1 Answer

I have a 97 jesse james custom,with less than 200 miles on it. Rode it to a friends house ran fine, turned it off and went in. After 2 hrs. I went to leave and the damn thing is completely dead. New...


I wished I could answer this question but I'm not familiar with any Jesse James Customs. Usually the fuses on a Harley are located under the seat or on an electrical panel depending on the year and model of the bike. The best suggestion I can give you is to look for the wiring harness. Wherever it's the largest is the center of the electrics and the most likely place for a fuse.

Good Luck
Steve

Jul 25, 2011 | Harley Davidson Boulevard C109RT...

1 Answer

Hi, Just bought a 1994 CBRR 900 last week. Battery was poor, tested it and verdict was sulphating. Therefore i replaced it, went for a 5 hour ride yesterday and had the lights on all the time, did over...


It sounds like a problem with the charging circuit. You should be able to ride with your lights on!
The first thing to do is put a multimeter set to DC Volts across the battery with the engine running. Are you seeing more than 13.5 volts? If not there is a charging problem. It could be the regulator/rectifier or the stator windings, or just loose electrical connections if you are very lucky. I have a manual for the 900 Fireblade (I used to have a 98 Blade) so let me know if you need anymore help.

Sep 12, 2010 | 1994 Honda CBR 900 RR Fireblade

2 Answers

Charging system problem


start up the bike,put volt meter on battery terminals,if voltage rises with revs ,the anternator is okay,but if no volts then the alternator or the wiring to the battery is suspect

Jul 03, 2010 | 2001 Yamaha V Star 1100 Classic

1 Answer

Headlight malfunction on suzuki V Strom


broken filament in lights. Wiring corroded or loose,, faulty light switch

Feb 25, 2010 | 2002 Suzuki DL 1000 V-Strom

1 Answer

No charge to battery headlight ok


i bought a multimeter tested the alternator ok over 14 volts then i tested the rectifier still 14 volts then i tested the regulater only 4volts solution was to replace rectifier and regulator with a boyer bransen power box

Oct 09, 2009 | 2005 Enfield Bullet 500

1 Answer

Yamaha TW 200 starts but won't run.


If the bike has sat for a long period of time without being run - the gas that is sitting in the carb(s) will shellac.. Then the carb(s) would need to be cleaned and "rebuilt"..

Sep 14, 2009 | 2001 Yamaha TW 200

2 Answers

Battery drained while riding


Sounds like you either have corroded wires going to your battery or your alternator is not properly charging the battery. Get the bike to an autozone and ask them to put their tester on it.

please mark this as a fizya! thanks

Mar 12, 2009 | 2000 Harley Davidson FLSTC Heritage...

Not finding what you are looking for?
2000 Harley Davidson XL 1200 C Sportster Custom Logo

187 people viewed this question

Ask a Question

Usually answered in minutes!

Top Harley Davidson Experts

Arnie Burke
Arnie Burke

Level 3 Expert

4514 Answers

Gills Lango

Level 2 Expert

195 Answers

Mike

Level 3 Expert

4336 Answers

Are you a Harley Davidson Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...