Question about Suzuki Boulevard M50 Motorcycles

2 Answers

Just put a new battery in my 2006 M50. All lights and horn work but gauges don't cycle through like they used to. Speedometer does not go bact to zero and odometer not showing miles. I hear a high pitch humming coming from the battery area. Bike sat for about a year. When I hit the starter button, it just grinds but won't start. Iput fresh gas in.

Posted by on

  • bobc2524 Jun 06, 2010

    The shop charged it for me but it took me 2 weeks to get it installed. Could it have drained that much since then or is it that they didn't charge it enoigh?

  • bobc2524 Jun 06, 2010

    Thank you

×

Ad

2 Answers

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Master
  • 10,865 Answers

Hello. The fact that your starter is not functioning indicates that you may have a bad ground,, or a bad starter. SInce parts are so expensive, I recommend that you get the bike to an auto electric repair shop where they have all of the diagnostic equipment needed to find the problems for you.. J.

Posted on Jun 06, 2010

Ad
  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Master
  • 2,272 Answers

Get the new battery checked.Either the new battery has low charge or it has dead cell in it.Get the voltage checked of the new battery.Also Check battery connections.
Also get the starter solenoid checked.If the solenoid is worn out it will make such noise.
thanks.

Posted on Jun 05, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

1995 4×4. Installed new battery. Why don't instruments and speedometer work?


if it is EFI then use a scan tool to reset the ECM program

Sep 12, 2015 | 1995 Dodge Ram 2500

1 Answer

Instrument cluster


Do an online search for speedometer repair places. You can get yours rebuilt for a fraction of the price of new or junkyard

Jun 18, 2017 | 1994 Oldsmobile Bravada

1 Answer

When I turn on the key to start my 1986 toyota truck, it does nothing as if it has no battery. I put new battery. LIghts work, horn works but gauges don't work and it does nothing when I trun th


You need a wiring diagram to start your testing

Guessing won't get it,waste of time

It is old enough to be a fusible link corroded

Some things work some don't,starting circuit
included if not a bad starter & separate problem

You can solve almost looking at a wiring diagram
as you know what deosn't work

Nov 20, 2012 | Cars & Trucks

1 Answer

Horns don't work when power put to them with a


If you did apply power directly to the horn and they don't repsond or just "buzz" then you need new horns.

Jan 27, 2012 | 1991 Mercedes-Benz Mercedes Benz 500 Class

1 Answer

1999 Ford escort, horn speedometer , odometer, gas


Most likely a fuse,or the ignition switch is bad.

Jun 06, 2010 | 1997 Ford Escort

1 Answer

No power to odometer no power horn


You never will know for sure UNTIL you take it apart.
  • I would start with the fuse box. If you find a bad fuse, disconnect the horn before putting in a new fuse. If a new fuse restores the power, reconnect the horn. If the fuse blows then it is a bad horn or a grounded horn wire or bad horn button switch.
  • Next, put a volt ohmmeter on the ignition switch to check for proper operation.
  • Check the wire connections inside the headlight housing to be sure the connections are clean, tight and that no wire is disconnected.
  • Next There may be a loose / dirty connection somewhere else on the bike. Remove the seat and gas tank to gain access to the wiring harness. Use a volt Ohmmeter. Start at the battery, then fuses and the wires connecting to the fuses. Inspect for burned wires, abraded wires, loose and/or dirty connections, bad plastic "box connectors" and loose wires.

Aug 15, 2009 | 2008 Suzuki Boulevard

1 Answer

Speedometer 2005 suzuki m50


It sounds like either the gears or the speedometer cable itself is worn out. I would try replacing the speedometer cable.

Jun 19, 2009 | 2005 Suzuki Boulevard M50

2 Answers

Fuse box,, relays ?


Disconnect the battery for a minute or two and reconnect it. Sometimes the BCM (body control module) locks up.

Apr 14, 2009 | 2005 Dodge Caravan

2 Answers

Chevrolet HHR horn and lights flash every few minuets.


Its not better to go to a key copying and re-set your remote entry?

Jul 03, 2008 | 2006 Chevrolet HHR

Not finding what you are looking for?
Motorcycles Logo

Related Topics:

24 people viewed this question

Ask a Question

Usually answered in minutes!

Top Suzuki Experts

yadayada
yadayada

Level 3 Expert

76109 Answers

Arnie Burke
Arnie Burke

Level 3 Expert

4521 Answers

Richard
Richard

Level 2 Expert

83 Answers

Are you a Suzuki Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...