Question about 1996 Suzuki GSX-R 750 T

1 Answer

No electrics when ignition turned on

There seems to be no electrics when ignition is turned on,ive checked the fuses and its not them,any ideas of what the problem could be,,,

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Vice President:

    An expert whose answer gotĀ voted for 100 times.

    Champion:

    An expert who has answered 200 questions.

  • Expert
  • 221 Answers

If there is no power to your ignition lights you have an open in the system circuit more than likely it is the MAIN fuse disconnect battery neg. terminal then battery pos. follow the pos. cable and you will find the MAIN fuse right before the solenoid

Posted on May 31, 2010

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Key turns ignition zwitch but nothing happens


Do the headlamps light ? Dome light come on when you open the door ? Did you check for bad fuse's that supply the ignition switch ? Check fuse's F422 - 20amp and F431 20 amp . These supply B+ voltage to ignition switch .

Jan 01, 2017 | Lincoln Cars & Trucks

1 Answer

1996 yamaha royalstar electrical?


Hi, Sonia and the usual suspects are:
1. Ignition Switch not in the "ON" position.
2. Engine Run Switch in the "OFF" position.
3. Discharged battery, needs to be 12.5 volts or better and be able to pass a load test if necessary, check battery terminals for damage or corrosion, check the battery cables at "BOTH" ends for loose, corroded, or broken connectors, "INSIDE" and outside the cable harness, perform connector wiggle test and check cables with an ohmmeter if necessary.
4. Bank angle sensor tripped and ignition/light key switch not cycled to the "OFF" position and then back to the "ON" position.
5. Faulty starter button/switch.
6. Faulty jiffy stand or clutch pull in switch/sensor.
7. Security alarm needs a reset.
8. Starter control circuit, relay, or solenoid faulty.
9. Main fuse or circuit breaker may be blown or faulty.
10. Electric starter shaft pinion gear is not engaging or over-running starter clutch slipping.
For more information about your issue and valuable "FREE" downloads that you will need please click on the links below. Good luck and have nice a day.
http://www.starbikeforums.com/forums/14-royal-star/23673-no-electrical-power-when-key-turned.html
Re No electrical power Road Star Forum Yamaha Road Star
http://www.yamahaventure.nl/pdf/servicemanualxvz13tf.pdf
OEM parts for Yamaha
http://www.starmotorcycles.com/assets/service/manuals/1998/Lit-11626-11-17_320.pdf

Mar 20, 2014 | 1996 Yamaha Royal Star XVZ 1300 A

1 Answer

Ignition fuse keep blowing in my 2003 cavalier


u have a dead short on main live wire check for overheated wires

Jul 10, 2012 | 2003 Chevrolet Cavalier

1 Answer

No power to the spark plugs


Check first the wire connections to your ignition unit. Are they properly plugged? If all wires are good, try to measure the voltage from one of the wires to the ignition unit while the ignition key is in "on" position. If there's no voltage, have someone check your ECM. If there's a good voltage reading, try replacing your ignition unit with a good one.

Jul 10, 2009 | 1994 Suzuki Sidekick

1 Answer

No start, blown ignition fuse 30 amp.


If it is the AM2 (30A) fuse that is blowing, check the ignition condenser, capacitor, within the ignition assembly. I just removed it and assembled the ignition back together. I am in the process of ordering a new one from Rock Auto for a total of $2.57. It seems to be a common issue. The condenser is actually a capacitor and the issue is that they internally short.

Jun 17, 2009 | 1993 Toyota Corolla

1 Answer

1992 pontiac grand prix le interior lights and key buzzer wont go


inside the steering column locate the ignition remove wire to reveal screw to remove ignition that wire is what controls the buzzer and light itthe wire probrally wasnt in place correctly wich caused your problem

Apr 27, 2009 | 1992 Pontiac Grand Prix

1 Answer

Main ignition fuse


Check the immobiliser.. is OFF IF you are using remote lock make sure battery is good in sender or try your spare push-button. Otherwise check fuses under dash .bones

Jun 26, 2008 | 1992 Jaguar Xj Series

Not finding what you are looking for?
1996 Suzuki GSX-R 750 T Logo

Related Topics:

174 people viewed this question

Ask a Question

Usually answered in minutes!

Top Suzuki Experts

yadayada
yadayada

Level 3 Expert

75817 Answers

Arnie Burke
Arnie Burke

Level 3 Expert

4514 Answers

Ed Nelson
Ed Nelson

Level 2 Expert

149 Answers

Are you a Suzuki Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...