Question about 1990 Suzuki GS 500 E

1 Answer

Bike was working sound, parked it up now no electrics working

Bike was working sound, parked it up now none of the electrics are working. Tried charging the battery, but still not starting - anyone got any ideas ?

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Brigadier General:

    An expert that has over 10,000 points.

  • Master
  • 6,966 Answers

Hi and welcome to the site,

Check / replace the 20A main fuse. It would be inside the starter relay. To locate the starter relay, follow the red cable from the battery's + terminal.

Good luck and thank you for asking.

Posted on May 27, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Suzuki gsx1400 want start hot until cold


You need to check the charging system and battery Condition,it sounds like the battery is draining then recovering after being parked for a while.Get the charging system checked with a multi meter across the battery terminals while it's running..I have a gsx1400 too by the way.

Sep 17, 2017 | Suzuki Motorcycles

1 Answer

Buell Blast 2000 -problem starting the bike -


That's NOT A KNOWN PROBLEM. He unloaded HIS PROBLEM ON YOU. The best I can figure is that the engine is looking for a ELECTRICAL GROUND and finding one through the cluch cable(only reason it gets hot). Check the battery terminals and cables. Make sure they are clean and TIGHT. Check the engine mount on the front of the motor near the neck of the bike and make sure NONE of the bolts are stripped or vibrated loose or missing. Check to see if there is a ground cable/strap that comes off of the frame and goes to the motor too. Look under the gastank for that one.

Jul 18, 2012 | 2000 Buell Blast

1 Answer

Bike will not start or stay running on a full charge battery/bought brand new battery, still same promblem,jump bike off,will crank ,ride bike for 30 min. park bike, leave bike running,lights start's to...


sounds like the problem is your battery is not charging when you are riding. The most common cause is a faulty regulator / rectifier. Contact a motorcycle wreckers for these parts, or your yamaha dealer.
Easy way to test is, when your bike is running, and the lights start to dim, before the bike shuts down, using a volt meter, test the voltage at the battery terminals, should be about 14V. If faulty rectifier,no charge going in to your battery, then the reading will be low, about only a few volts. If you dont have a volt meter, then any mechanic shop can do this test for you. best to have this done before buying any parts.

Aug 11, 2010 | 2000 Yamaha YZF-R1

1 Answer

Starter problem


If the starter is really spinning backwards, the battery must be in backwards. or the battery was charged incorrectly???
red cable goes to + positive,
black cable goes to -negative frame

You may need a new battery and hope none of the electrics has been damaged

May 02, 2010 | 1996 Suzuki GSX 750 F (Katana)

1 Answer

2000 yamaha YZF 600r wouldnt start


i suspect the battery is problem.Also you may have an electric fuel pump that is acting up.

Jul 28, 2009 | 2000 Yamaha YZF-R6

1 Answer

Electrical problem


Without a battery,None of the electrics will work unless the bike is running.Start the bike to test.


Please rate this fixya

Jan 28, 2009 | 2003 Yamaha WR 250 F

1 Answer

Suzuki dr350 electric problems


I had the same problem. It was a blown fuse located right in front of the battery.

Jan 06, 2009 | 1994 Suzuki DR 350 S

1 Answer

Heater/ defrost


no heat can be a t stat problem and the defroster sounds like a vacuum canister that controls the switching is not operating

Oct 20, 2008 | 1992 Buick Park Avenue

Not finding what you are looking for?
1990 Suzuki GS 500 E Logo

Related Topics:

293 people viewed this question

Ask a Question

Usually answered in minutes!

Top Suzuki Experts

yadayada
yadayada

Level 3 Expert

76846 Answers

Arnie Burke
Arnie Burke

Level 3 Expert

4536 Answers

Richard
Richard

Level 2 Expert

83 Answers

Are you a Suzuki Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...