Question about 2000 Harley Davidson FLSTC Heritage Softail Classic

1 Answer

Bike runs when boosted take cables off the bike dies

Pump the throutle when i boost it runs rougf take booster cables off stops running

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

  • Expert
  • 54 Answers

Bikes need a measurable amount of charge from the battery try getting a new battery or testing the one in the bike with a load tester or cleaning the connections on the battery.

Posted on May 27, 2010

Testimonial: "thank u so much couse i got to fix it my self thank u "

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

1987 nissan 300zx turbo 5 speed runs fine just doesnt have the power it used to


hard to diagnose whithout seen it, but; have you checked ignition timing.
cam shafts timing- looked at boost gage-if the boost indicator does not
move, check if the booster turbine are not jammed. Also would be good idea to check throttle position sensor output and catalitic converter for free flow.

Dec 03, 2012 | 1987 Nissan 300ZX

1 Answer

Battery is drained


try an old fashioned battery boost from another car or truck. leave the other car running while boosting your. run booster cable from the booster car to your truck make sure to run them the same way on each battery. positive on booster to positive side battery on the truck. run the negative from booster car to negative on your truck. allow the car to run for about 10minutes before you attempt to start your truck. this allows your battery to build up enough charge for the start up of your truck. after your truck starts take the cables off right away. let your truck run for at least 15minutes to allow time for your battery to build up before you attempt to drive it.that way if it should die,you'll have enough charge on your battery for a restart. thank you for choosing fixya.com hope this helps.

Jan 10, 2011 | 2004 Ford F250

1 Answer

2004 grand am starts wit a boost dies when cables off


Sounds like dead battery and dead alternator/regulator.

May 20, 2010 | 2004 Pontiac Grand Am

1 Answer

Loss of brakes and steering


sounds like you've got a bad power steering pump. i'm not familiar with your vehicle, but some brake boosters run off vacume from the engine and others run off the power steering pump and it's called hydro boost. if you have the hydro boost type, this is most likely your issue.

Feb 09, 2010 | 2001 Chevrolet Silverado 2500HD

1 Answer

Car cut out when putting petrol in got it towed back had new cat, battery but car still not running good keep booster on every thing ok take booster off all clocks and instrument lighs go all over and the...


Do an alternator test, boost car and with volt meter test at battery, remove jumper cable, reading at battery with car running should be about 13.5-14.5 volts, if you dont have that bad alternator

Dec 15, 2009 | 2000 Ford Focus

1 Answer

Bike hasn't been running for months. change of owner. low batt. Boosted off truck. All four cable leads conected, ''truck to bike'',truck started, main fuse blows: 1-stator coil de-magnitized ...


First of all, when boost starting a bike from a auto make sure the auto is NOT running. The auto battery has more than enough power all by itself.

The most likely is 4) None of the above. The truck's charging system put more than 30 amps into the bike's electrical system and blew the fuse.

Get a new bike battery and fully charge it. Then go from there. If you really want to see if the bike will run before buying a new battery go ahead and hook up the cables to the truck battery and try it with the truck off.

A faulty alternator/regulator/rectifier should have no effect on the bike actually starting or turning over. Only the output of the charging system would be affected, possibly causing the bike to die when the cables are removed. My '78 Honda would not run at all without battery power, not sure if the Kawasaki is the same or not.

Jul 20, 2009 | 1979 kawasaki KZ 1300 A1

1 Answer

HARD BRAE PEDAL AND NO BOOST ASSIST


you either have a bad brake booster or no vacuum to the booster.Check for vacuum while running if you have vacuum replace the brake booster :)

Jun 28, 2009 | 1996 Dodge Dakota

2 Answers

1980 ford f700 electric brake pump operates when pedal is depressed while vehicle is running and driving


check you aux hydurlic pump, ford will have one pump for the powersteering and one on the right hand side for the brake

Jul 15, 2008 | 2007 Ford F-450 Lariat

Not finding what you are looking for?
2000 Harley Davidson FLSTC Heritage Softail Classic Logo

142 people viewed this question

Ask a Question

Usually answered in minutes!

Top Harley Davidson Experts

Arnie Burke
Arnie Burke

Level 3 Expert

4514 Answers

Gills Lango

Level 2 Expert

195 Answers

Mike

Level 3 Expert

4336 Answers

Are you a Harley Davidson Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...