Question about 2006 Suzuki DL 650 V-Strom

1 Answer

I washed my V-Strom 650 yesterday and now it won't start. Lights, gauges react to key, fuses all seem fine, however, I get no response from start button. Lights dim when I push start button and that's it. I've checked the kill button too, it is in "on" position. Any advice?

Posted by on

Ad

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Contributor
  • 1 Answer

It's probably just the the clutch ignition wiring clip located directly underneath the clutch lever. It seems to come unplugged fairly easily. I had the exact same problem and this was the quick fix.

Posted on Jul 02, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My whole dash went out on my 2002 gmc envoy all the gauges arent working i checked fuses under the hood they seemed fine. Any advice for these problems?


Does it light up ? When you turn the key on do the warning lights come on ? Check engine , oil , abs , air bag etc... just gauges not working ? Does the vehicle start an run ? With vehicle running is check engine light on ? GM had a problem with the stepper motors that control the gauges . How to repair GM Instrument Cluster Speedometer Gauge Stepper

Sep 12, 2016 | 2002 GMC Envoy

1 Answer

All gauges in the dash went out yesterday, is there a fuse that controls them?


Yes there is it is in the main Fuse panel and should be marked instrument cluster or dash panel, dash lights,

Sep 21, 2014 | 1998 Jeep Cherokee

1 Answer

2003 Oldsmobile Alero won't start


Chances are you got water inside the fuse box or a wiring harness connection.
You may have to start tracing circuits to find out what is getting power and what is not.

Jan 10, 2013 | 2003 Oldsmobile Alero

1 Answer

Battery is new, engine won't turn over.


The voltmeter should only go as high as 14-15 volts when the engine is running. I would check for a poor connection between the battery and starter.

Oct 10, 2017 | Jeep Grand Cherokee Cars & Trucks

1 Answer

1994 Honda Civic not starting


you need to check all fuses one by one for loose contact.leave the igtion key to on position and try to tap the fuse box, shake wires from battery going to inside the car.A testlight is effective in diagnosting this trouble.Probing the wires on the ignition switch while turning on the key.Need somebody to observe the cluster while performing the troubleshooting.

Jan 20, 2010 | 1994 Honda Civic

1 Answer

I have an 04 suzuki DL 650 with an electrical problem.


chech the dash plug if it fet correctly and not mouving

Jul 11, 2009 | 2006 Suzuki DL 650 V-Strom

1 Answer

Although the battery is brand new my v-strom dl 1000 wont start unless I jump-starting it conected to my car, reagrdless how long I do ride it for, as soon as I stop it and turn the key off it wont start...


It seems that your bike's battery is not getting charged while running, but if your Headlights are working then the Dynamo is OK but the rectifier/battery charging has conked out. It might be just a blown fuse or it could be in the rectifier coil/circuit. It would be best if you could get it checked from their authorized service center and get the part replaced since you said that the bike is brand new & even the distributor from whom you bought it should take responsibility for a faulty piece of equipment.................sodeep

May 08, 2009 | 2002 Suzuki DL 1000 V-Strom

1 Answer

Radio, dome lights and EVIC power problem


I found a paritally blown fuse. When the fuse blew metal pieces ended up partially making contact. After replacing the fuse everything worked great.

Jan 07, 2009 | 1994 Jeep Grand Cherokee

Not finding what you are looking for?
2006 Suzuki DL 650 V-Strom Logo

383 people viewed this question

Ask a Question

Usually answered in minutes!

Top Suzuki Experts

yadayada
yadayada

Level 3 Expert

76846 Answers

Arnie Burke
Arnie Burke

Level 3 Expert

4536 Answers

Richard
Richard

Level 2 Expert

83 Answers

Are you a Suzuki Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...