Question about Suzuki GSX-R 750 Motorcycles

4 Answers

91 gsxr wont start, was running good, it was idling then it justed died tried to start again then it wouldnt idle, it just kept starting then diying... checked compression, checked spark plugs, and they were good but one looked kinda fouled so i cleaned it and checked it for spark and it had spark... the other plugs were kinda greyish so i thought it was running to lean but to me it seems to be running rich cause the prior days of riding i would have a vapory feeling in my eyes after longer rides... i need help!!!

Posted by on

  • 3 more comments 
  • bryraasch May 01, 2010

    how do i check that... i bought new coils a couple months ago...

  • bryraasch May 01, 2010

    i have brand new coils and ran great the past few days

  • bryraasch May 01, 2010

    i have brand new coils

  • bryraasch May 01, 2010

    i already cleaned the carbs out

  • bryraasch May 02, 2010

    i already put in new timing

×

Ad

4 Answers

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    President:

    An expert whose answer got voted for 500 times.

  • Expert
  • 4,070 Answers

Hi! You may have fuel flood and the spark plugs cant burn them all thats why it just dies. Check the injectors or you may just replace them for the hole may be too big causing massive fuel supply that the plugs cant burn. HOpe this helps and have a good one!

Posted on May 02, 2010

Ad
  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    President:

    An expert whose answer got voted for 500 times.

  • Suzuki Master
  • 1,619 Answers

How about the points/ignition module down by the crankshaft (under that screwed on cover) that tells the unit too fire?

Posted on May 01, 2010

  • Jason Johnson May 02, 2010

    Did you put in the ignition parts before it wouldnt start or after? If they are point are they gapped correctly? if not will not run. Did you grease the shaft as to not wear down the shaft or arm for the points?

×

Ad
  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Master
  • 10,865 Answers

Hello. I had a similar problem. I installed new plugs and new plug wires, and a new air filter and then I used a fuel additive called Seafoam which cleans out any gunk in the entire fuel system for you. Seafoam is available at most auto parts stores. It worked like a charm for me. Joe

Posted on May 01, 2010

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Master
  • 10,319 Answers

Sounds like weak coils to me. Check the ohm ratings on them
Manuals for these bikes can be downloaded for free by going into this website(s) below

http://www.carlsalter.com/motorcycle-manuals.asp

http://www.repairmanualclub.com/motomanuals/


Posted on May 01, 2010

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

2002 jeep liberty backfiring and wont idle


Sound like bad valve ckeck the compression on the engine ,next the
tempature sensor on the motor.Good Luck.

Feb 10, 2013 | 2002 Jeep Liberty

1 Answer

How do i adjust the idle on my chevy impala just replaced throttle positioning sensor


did you disconnect the negative battery terminal before changing the sensor?

Sep 04, 2012 | Chevrolet Impala Cars & Trucks

1 Answer

91 F-150 300 six starts fine, then runs rough, won't idle and dies. Restarts easily, dies again?


check idle air controll motor, Lightly tap it while vehical is running, If this helps, you will need to replace it, usaly 55.00 at the zone

Jun 09, 2010 | 1991 Ford F150

1 Answer

In park the engine dies; only will run if given gas


It sounds like there is a problem with the Idle Air Control (IAC) valve. Its job is to open and let air into the manifold when the throttle is closed at idle. If it does not open, the engine dies at idle. The IAC is mounted on the throttle body. Possibly the valve is clogged or stuck, in which case it could be ok again if it is removed and cleaned. Or it is broken, and needs to be replaced. Or, there is a problem with its electrical connection, that needs to be traced. Good luck, let me know if you have any questions.

Mar 30, 2010 | 1993 Chevrolet Lumina

2 Answers

5.8L just started will not idle, black smoke


possibly a fuel pressure regulator letting too much fuel in the engine

Oct 02, 2009 | 1991 Ford F150

1 Answer

Replaced stator and battery, bike still givin trouble


the regulater is located between tha battery and the gas tank .There are (3) white and(2)red wires .See if they are showing signs of damage from heat more than likley they are because when you "boost" or jump these bikes you burn a very weak diode witch regulates the charging time from the stator i would check ebay for the best price on a new regulater rectifier you may need one.I had the same problem with my 2000 model r6.good luck bro!

Jul 04, 2009 | 2000 Yamaha YZF-R6

1 Answer

Turns over but wont stay running or idle


Sounds ike the fuel pump died. As they get old and your car is about that age the start to overheat after being in use for a while. They stop pushing out the fuel consistantly and then stop working all together. Sometimes letting them cool back down will allow you to use it for a short while before it dies again but in your case it sounds like it just gave out. Remember fuel in the tank helps cool the pump when in use.

Tis is a good place to start, good luck.


Joe

May 21, 2009 | 1991 Saturn SL

1 Answer

1999 mazda 626 wont start


you blew the timing belt..sorry...well sorry if my crystal ball is working and i am right..... get it checked...good luck

Aug 10, 2008 | 2001 Mazda 626

Not finding what you are looking for?
Motorcycles Logo

Related Topics:

34 people viewed this question

Ask a Question

Usually answered in minutes!

Top Suzuki Experts

yadayada
yadayada

Level 3 Expert

76164 Answers

Arnie Burke
Arnie Burke

Level 3 Expert

4521 Answers

Richard
Richard

Level 2 Expert

83 Answers

Are you a Suzuki Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...