Question about 2008 Yamaha Yamaha G5

1 Answer

L50deto 2 stroke outboard stalling at high revs. Revs ok when timing advances, but as soon as throttles on the carbs open much it stalls rapidly. Carbs, filter, lines etc. all cleaned. I'm thinking fuel pump. Any ideas

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Sergeant:

    An expert that hasĀ over 500 points.

    Champion:

    An expert who has answered 200 questions.

  • Expert
  • 232 Answers

Fuel pump could be the cause but also the float in the carby could be not set at the right level and starve the motor at high revs .




Posted on Sep 29, 2009

Testimonial: "I found the solution, carbs werent clean enough. Got a compressor in there and solved it. Thanks anyway"

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

115hp 1985 yamaha outboard 6e5 AETO running at low revs as if on 3 cylinders,on low revs only when i accelerate it goes well and fast without issues,when i slow to trolling speeds it runs a bit rough...


sounds like a bad coil or trigger. Find the offending cylinder with a timing light and physically move the coil to a good firing cylinder. If the problem follows the coil, you have it, if not you need a trigger,

Nov 09, 2012 | Clymer Marine Maintenance and Repair...

1 Answer

Outboard 115 yamaha misfiring at low revs


clean carbs and check set up !

Oct 31, 2012 | Clymer Boating

1 Answer

Outboard 115 yamaha misfiring at low revs


Unscrew the 4 idle mixture screws 1/2 turn 1 at the time till sneezing stops...
Clean your carburettors

Oct 31, 2012 | Clymer Marine Maintenance and Repair...

1 Answer

Why does my dt125r 2001 stall at high revs


Drain the tank and switch to a 32 /1 mix. I take it you have disconnected the oil feed to the carb from the 2 stroke tank, if not then your mix contains too much oil. Only switch to 32 / 1 if the oil tank has been disconnected. I hope this helps.

Dec 18, 2011 | Yamaha DT 125 X Motorcycles

1 Answer

What is the correct oil to gas mixture for a 1999 25 H.P. Tracker outboard motor


Mate.All 2 stroke motors are born and bred to run at 50/1.Higher revs than 5000 you put in about 40/1.Hope this helps you

Sep 05, 2010 | Bass Pro Boating

1 Answer

2 stroke scrambler revs high on its own


there should be an idle screw on the carb, set it when the choke has come off. You'll recognise it because it will have a spring underneath it.
Dan

Sep 05, 2009 | 2001 Suzuki GSX 400 Impulse

1 Answer

3.5 mercury outboard stalls when put into forward


hi take the prop off see if there is anything /string/ between the hub and the housing check oil lvel in g/box /is gear box nice and free if all is ok try it in ware with just a small amount of choke
drain /empty fuel out replace with fresh /correct oil mix
check /change fuel filter/air filter
warm engine up check idle mixture ajustment/tick over speed
increase idle speed slightly/7/800 rpm
hope this helps merlin v 12

Aug 20, 2009 | Light Outboard Motor Boat Bass Fishing...

2 Answers

Car revs high when not in gear, but still revs


Timing has been adjusted to high, or the spark advance is out of adjustment causing the revving

Jul 09, 2009 | 1989 Oldsmobile Cutlass Ciera

1 Answer

Stalls when put into drive on starting


Sounds like their is a vacume leak some where. Try replacing any cracked or broken vacume lines. This should fix ya.

Please contact me if your problem presists.

Thanks, Charlie

Jan 31, 2009 | 1997 Ford Escort

Not finding what you are looking for?
2008 Yamaha Yamaha G5 Logo

359 people viewed this question

Ask a Question

Usually answered in minutes!

Top Yamaha Experts

dhnguyen

Level 2 Expert

281 Answers

Steve Sweetleaf
Steve Sweetleaf

Level 3 Expert

1144 Answers

Tony

Level 3 Expert

2600 Answers

Are you a Yamaha Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...