Question about Power Motorcycles

1 Answer

No power at the key or odometer Polaris 2010 500 HO

New battery, new ignition, and new odometer

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Top Expert:

    An expert who has finished #1 on the weekly Top 10 Fixya Experts Leaderboard.

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

  • Power Master
  • 12,650 Answers

Check connections and inline fuse

Posted on Dec 31, 2016

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
New users get to try the service completely Free afterwhich it costs $6 per call and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Have a 2004 Polaris 500 HO. New battery, yet no power to switch. Is there a fuse somewhere?


Some crafty devils actually hide some fuses inside the CDI unit.

Mar 30, 2017 | Polaris ATV

1 Answer

NO SPARK AT SPARK PLUG. WHAT ARE THE PROABLE CAUSES,BATTERY IS BRAND NEW AND FULLY CHARGED. ENGINE TURNS OVER BUT STILL NO SPARK.


I would check the kill switch or on/off switch as those work by grounding out the ignition system so there is no spark. After that the coil or magneto might be the issue.

Feb 08, 2016 | Polaris 2010 Sportsman 400 H.O

1 Answer

I have a code that makes no sense.Lo 010.8 Any idea what this means?


New 2012 850xp won't start - Polaris ATV Forum

www.polarisatvforums.com > ... > ATV Repair and Maintenance
Jul 29, 2012 - With only 6 miles and 2 hrs on my new 850 the battery was dead. ...Location: Mc Minnville TN ... 2012 Sportsman XP 850 H.O. .... code 10.8 on a 2012polaris 850 four atv ... Copyright ©2000 - 2015, vBulletin Solutions, Inc. Broke my first axle
Apr 20, 2015
Sportsman 570 with or witout EPF
Nov 10, 2013
BRAND NEW 850xp PROBLEMS!
Oct 16, 2010
More results from www.polarisatvforums.com

Thread: Lo 10.8 code - Polaris Ranger Club


Dec 25, 2015 | Polaris 2015 Sportsman 850 SP Base

1 Answer

When i turn key gauge pod lights up but nothing else happens


neutral try connect battery terminals charge battery,starter hanging up

Aug 28, 2014 | Polaris 2006 Sportsman 500 HO EFI

1 Answer

Had new key made on an 04 polaris 700 now it trys to start when i hook up battery in off position


it sounds like your starter solenoid is stuck. Locate the solenoid and check for continuity between the positive and negative poles right on top of it. If there is continuity between the poles in the off position, your solenoid is stuck and probably needs to be replaced.

Oct 29, 2013 | Polaris 2004 Sportsman 500 H.O

1 Answer

I have a 2006 polaris sportsman 500 ho. that will not start with the ignition/start button, the pull start gets it going first pull< i have lights and display and the battery is new {3months old} and...


starter silonoid has bad connection or has gone out completly. check connection of ignition switch
harness connection may be able to jump across silonoid post to make crank if so bad silonoid

Aug 28, 2011 | Polaris ATV

2 Answers

My 2005 Polaris 500 H.O. will not power up. The batery is good, there is just nothing when I turn the key. I don't even know where to start looking! Please help, I need my machine! Thanks. Steve


Its probably the electronic control module. Try leaving the key on for a while, if you do start to get something and it comes and goes, its the ECM. I had the same problem with my 07 EFI 500.

Aug 24, 2010 | Polaris ATV

2 Answers

1999 Polaris 500 ATV: Battery went shot. Just use pull start for quite awhile. After awhile, head light and low beam lights quit wokring. Replaced battery, all other lights work except those noted. Riding...


I had a simular problem with my 99 sportsman 500 and it turned out to be my pulse coil somehow became out of alinement. The pulse coil air gap should be between0.016 to 0.040 inch, But I would start by checking the coil it should read 0.3 to 0.5 ohms. Good luck and hope this helps

Mar 23, 2010 | Polaris ATV

1 Answer

5oo sportsman


check for power at the ignition switch on the yellow wire. Then check for power on the red and white wire at the ignition switch. Also make sure you have battery voltage at wires. If no power on yellow wire at ignition switch with switch on replace control module in front of radiator.

Jul 06, 2009 | Polaris ATV

Not finding what you are looking for?
Motorcycles Logo

Related Topics:

21 people viewed this question

Ask a Question

Usually answered in minutes!

Top Power Experts

D. E. Hev

Level 3 Expert

1173 Answers

mikeuk

Level 2 Expert

70 Answers

Lawrence Oravetz

Level 3 Expert

9742 Answers

Are you a Power Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...