Question about 2005 Harley Davidson FLHTCUI Electra Glide Ultra Classic

3 Answers

I have a 2006 Electra Glide Ultra Classic. I have lost my speedo, tach, turn signals, brake lights, odometer and trip meters. The alarm indicator stays on (red key by odometer). Bike starts and runs fine. Is there a common harness or connector block under fairing? I had to take fairing off as the trip reset button had pushed all the way thru.

Posted by on

  • 2 more comments 
  • neeker56 Jul 20, 2009

    but i still have my headlamps and all other instruments (fuel, air temp, oil pressure...)

  • neeker56 Jul 20, 2009

    I still have all my other instruments including radio.

  • neeker56 Jul 20, 2009

    Any other ideas? checked all the connectors and nothing.

  • neeker56 Jul 21, 2009

    This person did not have the exact solution but at least put me on the right track. It was a ground issue but not a bad ground. The Accessory fuse kept burning out so hard wired it and looked for "hot" wire. Worn thru wire found under seat.

×

Ad

3 Answers

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Master
  • 3,037 Answers

Sounds like a bad ground on the display board or a bad board needing replacement with what symptoms you have. The radio would have its own ground so check for the grounding wire being loose, wrecked, or disconnected from the display panel board. Let me know how this turns out for you.



Benjamin

Posted on Jul 20, 2009

Ad
  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Top Expert:

    An expert who has finished #1 on the weekly Top 10 Fixya Experts Leaderboard.

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

  • Harley Davidson Master
  • 77,499 Answers

All the connection for these devices are behind the head light, pull the head light assembly out and check the connectors, I am sure from my own past experience you will find a connector not fully locked together or actually pulled apart.

Posted on Jul 20, 2009

Ad
  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Master
  • 11,896 Answers

They should all be running through the same wire harness or connect to one single one eventually. Otherwise you circuit board or main power box may have fried.

Posted on Jul 20, 2009

  • Nate Stansfield
    Nate Stansfield Jul 20, 2009

    Check for any fusible links and any relays. Make sure the CDI box or equivelant is supply sufficient power to your main controls circuit.

×

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya Mechanic can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repair professionals here in the US.
click here to Talk to a Mechanic (only for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Speedometer not working


sounds like your speedo drive is bad on your front wheel

Jul 06, 2014 | 2005 Harley Davidson FLHTCUI Electra Glide...

1 Answer

I have a 2001 electra glide ultra classic with the left turn signal lights up when applying the front or feaf brakeS and when i turn on the left signal the brake lights blink


First you check that the left turn signal and brake switch wiring haven't been switched. I presume brakes and turn indicators use different bulbs. Then you check for shorted wires from wear or crushing where they go from headlight

Mar 12, 2014 | 2001 Harley Davidson FLHTCUI Electra Glide...

1 Answer

Check engine light


Your bike can run a self diagnostics.
to do this:
key off position
run switch in run position
press and hold trip reset button
turn ignition to on
odometer will start diagnostic
release trip meter button

To cycle through pess trip button

Feb 21, 2014 | 2000 Harley Davidson FLHTCUI Electra Glide...

1 Answer

I have a ultra classic and the speedo, tach, horn


Hi Pstika, always check your instrument fuse before performing the next procedure, try cleaning your speed sensor located on top of the transmissions right side between the top cover and the chrome starter end cap on Twin Cams and on top of the engine case between the rear cylinder and the starter motor for Sportsters. Remove the the bolt that secures the sensor and pull it out of the transmission. Inspect sensor for obvious damage and repace if necessary. If sensor has no damage then wipe clean any obvious contamination like micro fiberous material with a clean rag and reinstall, torque bolt to 8 ft lbs. Next check the connector to the speedometer for correded, broken or loose pins/sockets. If it still doesn"t fix your problem try replacing your ignition relay. Good luck and have nice day.

Jun 24, 2010 | 2005 Harley Davidson FLHTCUI Electra Glide...

1 Answer

2004 FLHTCUI ULTRA CLASSIC..TRYING TO WIRE UP FOR TRAILER..SHORTED WIRES NOW NO BRAKE LIGHTS OR TURN SIGNALS, SPEEDO OR TACH. TSM???


chk backwards to your turn signal control unit. The brake lights and rurn signals are routed in a way that would affect each other.Is this a four wire or?Chk fuses 1st. Good Luck- -Ned- A good grd is important.

Jun 01, 2010 | 2000 Harley Davidson FLHTCUI Electra Glide...

1 Answer

My speedometer and tach fuse blows when I hit a bump. the engine light that turns on when I turn on the fuel pump times out normally but then turns back on for the same duration a second time. the security...


most often these problems are solved by mending the wires going in and out of headlight or faring assembly. They can get worn or pinched during service, or bulb replacement etc.

Aug 22, 2009 | 2005 Harley Davidson FLHTCUI Electra Glide...

1 Answer

2003 Ultra Classic. Above 2000RPM, the volt meter gauge pegs past 16, the odometer blinks, the speedo jumps back and forth, the red engine light comes on and the radio cuts in and out. At idle or below...


Dont do that, your voltage regulator is faulty. It is in the alternator. Max charging voltage should be 14.2 and min 13.6v. Chk battery water level. but get an alternator 4 sure

Jul 08, 2009 | 2003 Harley Davidson FLHTCUI Electra Glide...

2 Answers

Lights bulbs in tach and speedo


The tach and speedo are their own separate unit.  There is no changeable light bulb.  You may want to check your light and instrument fuses.  If those are working, I would remove the outer fairing and check the connections to your tach and speedo.

Apr 14, 2009 | 2005 Harley Davidson FLHTCUI Electra Glide...

1 Answer

Speedometer stop working & turn signals do not cancel out already replaced speedo cable still not working


check out the speedo meter itsely something might be wrong inside
and for the turn signals check turning engine off and starting again and try the signals
if not maight be some wiring fault

Mar 08, 2009 | 2000 Harley Davidson FLHTCUI Electra Glide...

Not finding what you are looking for?
2005 Harley Davidson FLHTCUI Electra Glide Ultra Classic Logo

Related Topics:

302 people viewed this question

Ask a Question

Usually answered in minutes!

Top Harley Davidson Experts

Arnie Burke
Arnie Burke

Level 3 Expert

4536 Answers

Mike

Level 3 Expert

4345 Answers

yadayada
yadayada

Level 3 Expert

77499 Answers

Are you a Harley Davidson Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...