Question about 1981 Yamaha XJ 650

1 Answer

No Ignition I had a bad motor, found a replacement a lot cheeper than rebuilding origional motor. The original motor ran, swaped only the motor and generator stator. I have no spark at the plugs. I ohmed out the pickup coils they are in spec. Ohmed out the ing. coils they are in spec too. checked all the wiring seams to be good to. It all points to the ignitor box. Any way to check it? or any other ideals where the problem might be?

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    President:

    An expert whose answer got voted for 500 times.

  • Master
  • 1,392 Answers

There is no way to check the CDI boxes that I know of. If your pick ups are good, and everything else checks out, that would be suspect. Make sure the wiring going to all of the components have good continuity, and make sure you haven't blown a fuse. Beyond that, it sounds like your problem. You may be able to have it repaired if you have an electronics repair shop in your area.

Posted on Jul 02, 2009

  • oldxs650 Jul 29, 2011

    Try Rex's Speed Shop. They test Cdi units and are not expensive.
    www.rexs-speedshop.com

×

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

2002 impala 3.4 crank no start, no check engine light, or security light besides the one by radio that flashes


Hi Jarrek.
Since you had to pulse the injectors to start the motor its possible your camshaft position sensor/crankshaft position sensor is bad (More than likely your Camshaft Position Sensor). Another possibility is your MAF (Mass Air Flow) sensor may be bad, going bad, or just dirty. The parts store sells a cleaner for the MAF sensor. DON'T clean the sensor with anything else, it will damage it. Hope this helps. Let me know.

Jun 04, 2017 | Cars & Trucks

2 Answers

Why my s430 will run and idle but dies as soon as squeeze the trigger even if I do it slow? The primmer bulb was bad so I changed that but still does the same thing?


Carb is in need or a cleaning and rebuild. I would suspect the diaphragm is bad. You can get a rebuild kit with all the gaskets for most carbs for around $10. There are some that gaskets are not available for and you would need to replace the entire carb. Carbs run from $15 to $30.

Oct 16, 2016 | Ryobi Garden

2 Answers

My key does not turn the ignition what could be the problem


Sounds like either your ignition is wearing out or your key is wearing out. First try another key, if it does the same thing it may be your ignition wearing out. If it seems like your key is bad, go to dealer with your car ownership papers and they can cut you an original key. If your key is wearing there is no sense having another one cut from it, you must get the dealer to cut one for you. If this still does not work, I'd say it's an ignition problem.

Nov 30, 2014 | 2003 Pontiac Aztek

2 Answers

1998 ford explorer no reverse


Replaced or rebuilt it depends how good of shape the rest of the vehical is a used one is your cheeper choice rebuild is more money but will be new

Dec 11, 2013 | Cars & Trucks

1 Answer

Halo, i lost my original remote and bought ''Sony


Order a replacment of the origional online. eBay would probably have it. http://www.sony.newremotecontrol.com/catalog_item.php?catnum=147854511
Just found it after a short google search.

Steven Cumming
stevencumming@hotmail.com
Please leave positive feedback :-)

Jun 05, 2011 | Sony Televison & Video

1 Answer

Need to replace alternator in 1990 cutlass calais s 2.3 L 138 L4 F1-A


most alt rebuilders will only charge a min fee to remove and rebuild cost is usually a beter way to go
some salvae yards also have removal and install service and are far cheeper than retail parts

Jan 16, 2010 | 1990 Oldsmobile Cutlass Calais

2 Answers

If the timing belt breaks while the car is running on my 2005 galant will it hurt the motor?


Most likely not but if you are asking this question you must suspect it is worn and beginning to cause a problem. Go ahead and replace it if this is the case.

Dec 30, 2009 | 2005 Mitsubishi Galant

1 Answer

Re attach output bin error swaped known


Look for the sensor that is tripped when the output bin is attached. Trace the wiring back to origination. Either sensor is bad or wiring is bad.

Nov 24, 2009 | HP LaserJet 4345mfp All-In-One Printer

2 Answers

66' 289 4v mustang


pull number 1 up go from there see which way rotor button is pointing match wires according

Dec 05, 2008 | 1966 Ford Mustang

Not finding what you are looking for?
1981 Yamaha XJ 650 Logo

205 people viewed this question

Ask a Question

Usually answered in minutes!

Top Yamaha Experts

dhnguyen

Level 2 Expert

281 Answers

Steve Sweetleaf
Steve Sweetleaf

Level 3 Expert

1144 Answers

Tony

Level 3 Expert

2600 Answers

Are you a Yamaha Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...