Question about 1986 kawasaki ZL 900 A2 Eliminator

1 Answer

Zl 400 running problems

Intermittent vault losing power, have been told it could be coil or CDI, have replaced coil but problem still present. When working great bike loads of fun, but when fault appears seems like half power and drops revs from 8000. Should I buy the CDI part number fitted to bike is FUJI IGNITOR TYPE 21119-1207

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    President:

    An expert whose answer got voted for 500 times.

  • Master
  • 392 Answers

Yes thats better , generally if the coil is replaced the problem should be solved.. it seems that problem is with CDI . So better i suggest u go forward and have it replaced..
hope this helps. Please rate my answer, i will get paid for the service.

Posted on Jun 30, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I keep losing spark and my 400 artic cat will not start. I have checked the ignition coil, magnets, and the cdi. What should I check next?


Sometimes when bad parts heat up they fail. I have seen this with the cdi. Be very aggressive when checking your connections. Do you lose spark after it has been run for a while or at certain temps?

Apr 02, 2017 | Arctic Cat 2004 400 DVX

1 Answer

No spark on 1 2 3and 4 sillinder coils test ok RF 400 R year 96


test for battery voltage at the coils on the orange/white wire. Also check for battery voltage at the CDI module on the orange/white wire. If voltage is present the most common failure is the signal generator (aka pulser coil)

Jan 16, 2013 | 1998 Suzuki RF 400 R

2 Answers

My gs 400 is not getin spark to the points or plugs is ther something els outher than points and battery that can be a coz


yes buddy the cdi ,coil,magneto use a electrical metre to check these out the magneto on the side off engine inside the casing the magneto will be a box with out fins and the coil will be coming from your sparkplug also replace plug this could be the cause if not check power to the coil if not check power to the coil if not the magneto is you problem

Aug 31, 2009 | 1978 Suzuki GS 400 E

1 Answer

88 ninja 600r losing power to coil and tach


Hi and welcome to FixYa,

Initially, check:
  • black wire from the ignition coil that goes to the CDI;
  • check the terminal/pin of the black wire at the connector before the CDI;
  • check the 4 wires from the pickup coil, their connectors and their connections to the CDI.
Good luck and thank you for asking FixYa.

Aug 03, 2009 | 1997 kawasaki ZX-6R Ninja

1 Answer

I have a 1985 xv700 virago. one of my plugs are misfiring. I had issues with my original one. yamaha dealer told me i needed a new cdi box. He sold me a used cdi igniter box from a non running 1985 Yamaha...


follow the plug wire back to the coil and see if there are any breaks, if not might switch coil with the other one and see if the other plug now misfires, if so replace the coil, most cdi problems are not intermittent, typically they either work, or they dont.

Jul 05, 2009 | 1988 Yamaha XV 535 Virago DX

1 Answer

Bench start kv 550


Assuming it's a KZ550, first off, your gonna need the battery, ign module, rectifier/regulator, and ign. coils. There should be a wiring harness (5 wires or so) coming from the alt housing (on left crank end) with 2 yellows one pink(to rectifier),red/blk(ign power to cdi) & (light green is neutral light- not needed). Next, assuming there's no points, there should be a 2 or 3 wire harness (usually blue/brown) from ign triggers (on right crank end) these need to go to CDI module. Then make wires from CDI module to coils. Don't forget to ground everything to motor case. Also if it's electric start only, your gonna need the start solonoid ,too. If you want a detailed wiring diagram, let me know what color wires & how many there is on the rectifier/regulator and CDI and the motor and I can email you a diagram.

Jun 03, 2009 | 1986 kawasaki ZL 900 A2 Eliminator

3 Answers

1986 gsxr 400.not sparking r starting


Hi and welcome to FixYa,

If somehow, the CDI could be opened up, then component level repair maybe tried. There would be 2 final transistors that actually do the switching; 1 for each coil. Offhand, it would appear that 1 of those 2 is faulty. Otherwise, replacement is the only option.

Incidentally, in some versions, a fault in the tachometer could also cause one of the CDI's output to fail.

Postback results of tests.

Good luck and thank you for using FixYa.

May 27, 2009 | 1996 Honda CBR 400 RR

Not finding what you are looking for?
1986 kawasaki ZL 900 A2 Eliminator Logo

Related Topics:

171 people viewed this question

Ask a Question

Usually answered in minutes!

Top kawasaki Experts

Arnie Burke
Arnie Burke

Level 3 Expert

4514 Answers

yadayada
yadayada

Level 3 Expert

75817 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Are you a kawasaki Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...