Question about 2003 Harley Davidson FLHTC Electra Glide Classic

1 Answer

2003 Ultra shuts off while riding

While riding my 2003 Ultra it shuts off very intermittantly . Loses battery voltage like the key was shut off or battery disconnect ! Wait 20 seconds and the circuit breaker closes again and it may be fine for 100 miles or it may do it again.

The voltage doesn't stay off long enough to clear radio memory but the speedo will stay at the speed the bike was traveling even tho it is stopped. Watching the volt meter it does not fluctuate. It does not appear to be heat related and has happened in cool , hot, rain, Etc !. Seems to happen more 2 up ?

I tightened everything I could find but have a feeling there is a crushed wire causing high resistance and opening the circuit breaker. But where ? The bike did have a recall on the breaker which was done and I replaced it again ( just because)

If anybody has had this complaint or knows the ancwer Thank You... I will keep digging and if I find it I will let you know !

Thanks,
Mike

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

How many lights are you running? try disconnecting the battery and hooking up a shunt with a volt meter or a current meter inline. then check the current with different accessories or everything running. If you have a big load and stereo amp you may need to upgrade the charging system and the Circuit Breaker or try a aftermarket CB.
It happened once to me, riding slow, new pavement, very hot day, spot lights and stereo amp on.
Have a new CB on order but, put on another 4000 miles without another problem????

Posted on Aug 17, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Start no electrical, bike died like the key was shut off. No electrical what so ever


battery flat if voltage regulater faulty it wont charge the battery

Jul 20, 2013 | 2000 Yamaha YZF-R1

1 Answer

2003 ford explorer shut-off while driving and it won't turn over, no sound when key is turn.


If the headlights work, I would check for voltage at the key switch and the major fuses.
If nothing works, I would start at the battery and work toward the fuse boxes. Could be a bad ground connection too.

Sep 19, 2012 | 2003 Ford Explorer

2 Answers

As i'm riding the engine will shut off sometimes and I have to restart at the start button. Any Ideas?


I also have a 2003 Ultra that would shut down for no reason while I was driving, started happening 3 months after I had the bike, very dangeous, happened in a curve once, took it to the dealer and they were having problems a module for the ignition I thought. They replaced it twice, then told me that because I had a trailer wiring harness hooked up that was causing interferance, they took that off and havent had the problem since. Didnt use the trailer hitch much anyways, but dont know at this point if it was the module or the harness. Hope this helps.

Oct 16, 2010 | 2003 Harley Davidson FLHTCUI Electra Glide...

1 Answer

No start...2000 Wrangler 4.0liter, automatic.


To me it sounds like you have weak battery. Hook up a meter and check voltage. should be over 12v, then turn key on. should maintain 12v. then crank. If the voltage goes below 11v cranking the battery is bad. Be sure to test the battery. Not the cables. Then tst the cables. You may have good voltage just touching the battery and you may have low voltage touching the terminals which would indicate a dirty connections.

Jul 27, 2010 | 2000 Jeep Wrangler

1 Answer

Bike loses power and shuts off in the middle of riding


Hi Shepfluke, and the usual suspects are:
1. Severely discharged or damaged battery.
2. Loose, corroded or broken battery cable.
3. Alternator not charging or below normal rates.
4. Failed ignition coil, ignition/electronic module.
5. Failed CKP, CPS, CMP, MAP, TPS, or BAS sensor.
6. Faulty ignition switch.
7. Water or dirt in fuel system, carburetor or filter.
8. Fuel tank vent system plugged or gas cap not venting.
9. Fuel tank empty.
10. Fuel valve vacuum line broken or carburator vent line closed off.
11. Restricted, blocked or kinked fuel line.
12. Failed fuel pump, pressure regulator and or fuel injectors.
For a prime suspect please visit website below. Good luck and have nice day.Big Twin Carb EFI DTC Intructions codes Harley Davidson Forums Harley...

Jul 04, 2010 | 2003 Harley Davidson FLHTCUI Electra Glide...

2 Answers

2003 Ultra Classic shuts down


Could be the regulator/rectifier unit at the front of the engine. I replaced one recently with a new ,non genuine Harley part and that was faulty too. When I replaced that the problem was fixed. Don't waste your money on cheap parts.

Jun 05, 2010 | 2000 Harley Davidson FLHTCUI Electra Glide...

3 Answers

Please help me? was rideing my bike shut if off now wont start gave it a boost started but when i take the cables off it dies out


check the battery voltage, and measure the voltage to the battery when it starts, should be 14 volts, are the lights ok??? it may have blown the regulator, little box below the engine near thefront

May 27, 2010 | 2003 Harley Davidson FLHRCI Road King...

1 Answer

2003 HD Ultra Glide - Electrical Problem. Can't get it to start


thats basicly average lifespan for a battery-in the south anyway-bring it to a tester like auto zone to confirm itz old-12 volts is needed at all times because the ignition does not feed off alternator once started

Aug 06, 2009 | 2003 Harley Davidson FLHTCUI Electra Glide...

3 Answers

TOTAL SHUT DOWN


This has to be a blown fuse. If it happened slowley you lost your altenator or battery connection.

Jan 07, 2009 | 2003 Harley Davidson FLHTCUI Electra Glide...

1 Answer

Zooming causes shutdown


I think your battery is weak, not holding current or not enough.

Before buying a new camera's battery, try to discharge the battery because most batteries have memory problems.

Find a small light that is rated up to the battery voltage.
Connects two wires to battery and then to light.
When the light goes out, battery is fully discharged.
Now, charge up the battery with the camera's charger
Try it on the camera.

Alexander
atdlee@netzero.com

Dec 17, 2007 | Olympus Camedia C-755 Ultra Zoom Digital...

Not finding what you are looking for?
2003 Harley Davidson FLHTC Electra Glide Classic Logo

264 people viewed this question

Ask a Question

Usually answered in minutes!

Top Harley Davidson Experts

Arnie Burke
Arnie Burke

Level 3 Expert

4514 Answers

Gills Lango

Level 2 Expert

195 Answers

Mike

Level 3 Expert

4336 Answers

Are you a Harley Davidson Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...