Question about 2000 Harley Davidson FLSTC Heritage Softail Classic

1 Answer

Speedo not working


This is an electronic pick up located on top of the transmission.

Posted by on

  • lil_os Jul 01, 2009

    I have changed the pick up twice in 14 days? no shavings on the pickup. This is the 6th pick-up I have replaced in 100K miles. I was just wondering if there was reason the pickups were going out so quickly and if anyone else has had this problem.

×

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Sergeant:

    An expert that has over 500 points.

  • Harley Davidson Expert
  • 284 Answers

Try to clean the metal off of the pick up. It may work. If it has metal shavings on it and occasionally works or still doesn't work replace the pick up.it's shot. The speedo still could be bad. but the pick ups go out rather easily. and even if the speedo is bad more than likely the pick up will have to be changed as well. So i would replace the pick up ( if it's got alot of metal shavings on it.

I’m happy to assist further over the phone at https://www.6ya.com/expert/robert_5bac37c3cb991fdb

Posted on Jun 27, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My speedo has stopped working i had the speed sensor replaced it worked for just 1/2 mile n stopped, local garage said new gearbox does this sound right to u guys


If they mean the speedo gearbox, maybe. I think this works like older cars in which you have a gear on the transmission shaft which drives a gear on the speed sensor, and sometimes the gear on the transmission shaft can break the clip which locates it and it slips out of position. Many transmissions allow removal of back section to gain access to repair this. However, some newer cars have a speed sensor which uses an electromagnet to pick up signal from a internal magnet. Removing the speed sensor from the transmission (easy!) should help determine the cause of your problem.

Dec 15, 2014 | 2005 Nissan Almera 1.6

1 Answer

I washed the motor and the speedo stoped working


'Can't really say why, si nce most if not all cars no longer use speedo cables but an electronic sensor which is usually located either in the transmission, looks like a cooling sensor, or picks up the rotation on the driveshaft. Could be the wire going to the transmission somehow got detached, or the sensor damaged by the water. Check your fuse box and the box under the hood and see if a fuse blew.

Oct 15, 2013 | 2003 Ford ZX2

1 Answer

How to replace speedo cable 97 hertiage softail


Hi Lujan4263, 1997 FLSTC do not have speedometer cables they the speedometers are electronic and have a speed sensor located on top right hand side of the transmission between the top cover and the chrome starter end cap. Good luck

Btw, I’m available to help over the phone in case u need at https://www.6ya.com/expert/gregg_c0ec1df182c7330e

Apr 12, 2013 | 2007 Harley Davidson FLSTC Heritage...

1 Answer

My transmission is stuck in first gear but picks up once in a while, also my speedometer went dead shortly after the first sign of transmission gear shift problem, I read that if i fix the speedometer...


no i dont think so if this is a newer model with electronic speedo then if the gear change doesnt work it could be the speedo drive as the computer reads the vehicle speed to control the shifting ,take the sensor out and check the nylon gears as this is the most likely cause of your problem

Mar 10, 2011 | Ford Escort Cars & Trucks

1 Answer

I have a sonata 1997, and the speedometer doesnt work , cant seem to find the speedometer cable, can yu assit please. Regards Hendrik


SOME CARS DON'T HAVE A SPEEDO CABLE! IT MAY BE ELECTRONIC THRU A SPEED SENSOR LOCATED ON TOP OF THE TRANSMISSION! IF YOU HAVE AN OBD-II CODE READER, THERE SHOULD BE A PLUG LOCATED UNDER THE DASH, THE CODE WILL PROBABLY BE A P0500!

Mar 01, 2011 | 1997 Hyundai Sonata

1 Answer

2007 harley davidson xl sportster 883 speedometer is not working. How do I troubleshoot this problem?


If you're lucky it might be the speed sensor located in the gearbox casing. This is a hall effect device and is magnetic and so can pick up metal fragments from the inside of the gearbox. I have a 2001 Sportster and the Sensor is located on the top of the gearbox casing, just below the starter. I'd expect it to be in a similar position on a later bike such as yours, but I can't be sure. Once you've located it, take it out (can be a bit fiddly) and make sure that its clear of any debris. If not the sensor, you're probably going to need to substitute in a working speedo. Be careful because a pre-2004 speedo is electronic, but is not compatible with 2007 bike. Best of luck!

May 02, 2010 | 2007 Harley Davidson XL 883 Sportster

2 Answers

I have a 1997 harley sportster 1200S XL and the speedometer doesn't work. It illuminates, but when I drive it it doesn't seem to move. I just got the bike at an auction so I am actually un-aware of it's...


It depends on which speedo you have, the electronic or the mechanical one. The lights in the speedo are simple illumination lights that are connected to the headlight. They have nothing to so with the operation of the speedo itself.

On the mechanical speedo, it is driven by a speedo drive unit on the front wheel with a cable running from the drive unit up to the backside of the speed. Look on the backside of the speedo and disconnect the cable. Raise the front wheel off the ground or tie the cable to the handlebars temporarily and ride the bike. The cable should turn. Use your fingers to put a little resistance on the cable, pinch it between your fingers and see if it slips and stops turning. If it does, you cable and possibly the drive unit is bad. If it continues to turn even against the resistance, likely you speedo is bad and must be replaced.

If your speed it an electronic unit, there is a sensor on the engine case back near the transmission part of the engine. You can remove this sensor and wipe it off in the event it might have a piece of metal on it or something. If that doesn't fix the problem, it could be either the sensor or the speedo. I do not know of a test of the sensor. Wished I could help more.

Apr 03, 2010 | 2006 Harley Davidson XL 1200 C Sportster...

1 Answer

2003 fxstd speedo not working


This depends on whether the speedo is a mechanical or an electronic unit.

If it's a mechanical unit, it probably gets it's drive from a cable that runs to a cable drive unit on the axle that is driven by the front wheel. If this is the case, the problem could be in the speedo unit itself, the cable could be broken, or the drive unit could be broken. To find out which, you're going to have to gain access to the cable by either taking the front wheel off or the dash to get the cable loose from the speedo. Pull the cable out of it's housing and inspect it. Look at both ends, they should be "squared off". If not, the cable is broken and you'll need a new one. If the cable does not look broken, lubricate it some wheel bearing grease and reinstall it into the housing. Twist it a bit while pushing it into the housing to make sure it seats in the drive unit. Raise the front end of the bike and spin the wheel. Watch for the cable to turn. If it turns, your drive unit is probably alright and the speedo is where the problem is. Time for a new speedo in most cases.

If the speedo is electronic, this kind of simplifies things but not much. The speedo gets a pulse from a sensor in the transmission. The sensor is located on the transmission on the right side of the bike just behind the chrome shifting mechanism cover on top of the transmission. It is held in by one small bolt or screw. Remove the screw and work the sensor out of it's hole. There should be an o-ring on the sensor, don't lose or break it. Wipe the face of the sensor off with a rag. Sometimes they get a small bit of metal on them and they quit working. Reinstall the sensor. Take the bike for a ride and see if the speedo works now.

If the speedo is electronic and it does not "light up", then you need to trace the circuit that it gets it's power from. To do that, you need a schematic. I'll like to help with that but I do not have a schematic for this particular bike.

I hope this helps. Good Luck and Ride Carefully.

Nov 21, 2009 | 2000 Harley Davidson FXSTD Softail Duece

1 Answer

Speedo and odo dont work


speed sensor that is located in your transmission well in the back partby differential either sensor or wireing coming from it.

Sep 01, 2009 | 2001 Audi A4

Not finding what you are looking for?
2000 Harley Davidson FLSTC Heritage Softail Classic Logo

Related Topics:

283 people viewed this question

Ask a Question

Usually answered in minutes!

Top Harley Davidson Experts

Arnie Burke
Arnie Burke

Level 3 Expert

4982 Answers

Mike

Level 3 Expert

4350 Answers

yadayada
yadayada

Level 3 Expert

80339 Answers

Are you a Harley Davidson Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...