Question about 2005 Suzuki Boulevard S50

3 Answers

I have a s50 I put my key in tonight and the light came on as usual, but when I pushed start everything went dead no power any ideas

Posted by on

Ad

3 Answers

  • Level 1:

    An expert who has achieved level 1.

    Governor:

    An expert whose answer got voted for 20 times.

    Corporal:

    An expert that has over 10 points.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Contributor
  • 16 Answers

Dead battery most likely. When you get it going the bike is supposed to charge 13/8v and a little higher.
If it is then the battery went out.

Posted on Sep 23, 2009

Ad
  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

You need to be in N.

Posted on Sep 13, 2009

Ad
  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that has over 10 points.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 6 Answers

Dead battery, your lights could still work but not enough power to turn the engine also check fuse or maybe a sticky starter selinoid ?

Posted on Jul 10, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

So then i thought the battery on my key was about dead so I started to use the key instead of the button which has been fine for months but tonight I went to unlock it with the key and the alarm went off!...


If mine, I would get a new key fob from dealer or possibly a locksmith. I think the key and or the security reciever need to be reprogrammed.

Mar 27, 2015 | Cars & Trucks

2 Answers

My key is stuck in the ignition of my 2006 cadillac cts


2005 CTS 3.6 Dead battery, key stuck, service anti theft and nothing happens when you turn key, Ttried everything, ECM reset, key memory reset, charged battery to 12.7 volts, locked door w remote and opened w key, anyway you get the idea. After 3 days of online reading and trying, THIS IS WHAT WORKED, 1. put key into on position 2. removed sarter relay from front fuse panel 3. jumped 1st pin closest to fender and passenger seat with pin that is closest to motor and front fender. I used a paper clip and just made contact long enough for car to start. ran car for five minutes and took key out and everything went back to normal. then I took car to advance auto parts to have engine light reset. if car does not go back to normal you have ECM (car computer) failure. video on YouTube under "no crank, no start"

Jul 09, 2011 | 2004 Cadillac CTS

1 Answer

Very intermittent starting problem.


it sounds more like a bad neutral safety switch then anything else.

Apr 24, 2010 | 2001 Saab 9-3

1 Answer

Have a Crate V50-112.Have had it for 1 year. Replaced tubes 2 weeks ago, turned amp on tonight, started to play, amp went dead. Checked fuses, they're good. Any ideas?


Check for bad tube... it HAPPENS that brand new ones fail... USUALLY if they last 50 hours, they will last for the expected life. The bad tube would likely NOT be the main power tubes, as the amp would still run on one cylinder...

Feb 02, 2010 | Crate Music

1 Answer

Electrical Issue


Had the same problem. I had to remove battery, take apart the battery terminals, sand them a little, then put it all back together. Make sure the screw on the front of the terminal holding the inner bar in place if very tight. Have had no problem ever sense. Good luck.

Nov 10, 2008 | 2005 Suzuki Boulevard S50

3 Answers

Car won"t start..acts like the battery is dead .


possibly the alternator. or even a bad connection on one of the wires

Jul 19, 2008 | 2000 Kia Sephia

Not finding what you are looking for?
2005 Suzuki Boulevard S50 Logo

Related Topics:

277 people viewed this question

Ask a Question

Usually answered in minutes!

Top Suzuki Experts

yadayada
yadayada

Level 3 Expert

76164 Answers

Arnie Burke
Arnie Burke

Level 3 Expert

4521 Answers

Richard
Richard

Level 2 Expert

83 Answers

Are you a Suzuki Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...