Question about 2010 Triumph Street Triple R

1 Answer

Why dose my bike Triumph Street Tripple R 2010 has issue with the white wire heating up connecting from ignition to connector?Resulting in no power nor display on the pannel. But when I play with the

Plus another issue is at times headlight doesn't turn on and I need to start directly on relay to be started.

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

  • Contributor
  • 38 Answers

Check owner manule for the correct fuse size that must be installed in the fuse box for your power relay for your head light if this is correct one it must be a earth leak near head light check all earth points on your bike tighten or replace where needed

Posted on May 14, 2014

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Benimur
  • 6966 Answers

SOURCE: Daytona 675 won't start

Hi,

Two possibilities:

  • starting relay. This could actually be bypassed/jumped to determine if the starter motor will turn:
  • starter motor. most likely carbon brush.
Just a start, do postback how things turned up or should you need additional information. Good luck and Thank you for using FixYa.

Posted on Nov 22, 2008

fastboyz
  • 674 Answers

SOURCE: tiger triumph 2008 brand new wont start... help

ok
you have a problem with the starter not turning the engine. so we probily not sending a signal to the starter.
you realy confused me when you started talking about gas and choke?
if the engine doesnt turn over none of this even matters.

these new bikes have many safety features .
you have a sensor for netural and you have a sensor for your kickstand and a sensor for your clutch
and all of these have to be workinf right for your engine to turn over.
so with your kickstand up and the bike in netural and the clutch lever pulled in
it should turn over and start.
when it doesnt you need to check your wiring to the switches one might have come loose.
or could be a bad switch.
let us know what you find

paul

Posted on Nov 23, 2008

rockitman187
  • 2559 Answers

SOURCE: "homeless" 2 wire connection plug on a 2002 Triumph TT600

Try this,If you can't see the details good enough,The plug you are talking about is for the exhaust air injection solenoid.

db58f0b.jpg
6e5ed72.jpg

Posted on Feb 10, 2009

  • 2 Answers

SOURCE: Non Starting of Triumph Trophy 3

Try wiggling the ignition key or perhaps turn off & on whilst holding the starter button in. Might be a dodgy ignition switch.

Posted on May 15, 2009

  • 447 Answers

SOURCE: Starting problems triumph sprint st 1050 2007 model

Did they check the plug wirers? How about the gas? Drian the tank to remove any sediment, OR, Put in an additive that has dry gas in it to remove any condensation. Change the fuel filter,

Posted on Apr 11, 2010

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Triumph st 1050 2010 Started bike and left running too long. Came back later to find bike had powered off and was very hot. Unable to start. No power with ignit ion on and red start switch on.


Try disconnecting the battery, wait a few minutes, reconnect it, and try again. If that doesn't work, then you will need to take it to a Triumph repaired for diagnosis.

Jul 08, 2017 | Triumph Cars & Trucks

1 Answer

Triumph Bonneville 2004. No lights indicators or horn. Bike runs starting from ignition . relay. Something burnt out? Sorted, new ignition switch and everything 's cushty.


Hi, Porl and the usual suspects are:
1. Ignition Switch not in the "ON" position.
2. Engine Run Switch in the "OFF" position.
3. Discharged battery, needs to be 12.5 volts or better and be able to pass a "LOAD" test if necessary.
4. Check the battery terminals for damage or corrosion check the battery cables at "BOTH" ends for loose, corroded, or broken connectors, "INSIDE" and outside the cable harness, perform connector wiggle test and check cables with an ohmmeter if necessary.
5. Tip over sensor needs a reset.
6. Faulty ignition switch.
7. Faulty starter button.
8. Faulty kickstand or clutch pull in switch/sensor.
9. Starter control circuit, relay, or solenoid faulty.
10. Main fuse or circuit breaker may be blown or faulty.
11. Check for engine trouble codes.
For more information about your issue and valuable "FREE" downloads that you will need please click on the blue links below. Good luck and have a wonderful day.
My 2010 Bonneville will not start
What to do When Your Motorcycle Won Start
Triumph Bonneville T100 2001 2007 Service Repair Manual Download Manuals... $10 cheap
Welcome to CalMoto Triumph Parts We are your source for original Triumph...
Triumph America Handbook

Mar 16, 2017 | 2004 Triumph Triumph Bonneville

1 Answer

I had a gas leak coming from the female or male fuel line connector I repaired the plastic connector but the bike still won't start.


Hi, Denim and the usual suspects are:
1. Fuel tank empty.
2. Fuel supply valve/petcock turned off.
3. Fouled spark plugs.
4. Engine flooded as a result of overuse of the enricher.
5. Vacuum hose to the fuel supply valve/petcock disconnected, broken, cracked, or pinched.
6. Fuel valve/petcock or filter clogged.
7. Severely discharged or damaged battery, you need 12.5 volts or better and be able to pass a load test if necessary.
8. Check battery terminals for damage or corrosion, check the battery cables at "BOTH" ends for loose, corroded, or broken connectors, "INSIDE" and outside the cable harness, perform connector wiggle test and check cables with an ohmmeter if necessary.
9. Loose or corroded wire connection at the coil, battery or plug between ignition sensor and module.
10.. Spark plug cables in bad condition and shorting, cable connections loose, or connected to the wrong cylinders.
11. Ignition timing incorrect due to a faulty ignition coil, ignition module or sensors (MAP, CMP, CKP, O2, TPS, ETP, IAC,or BAS).
12. Faulty neutral, clutch lever, or kickstand safety switch.
13. Faulty fuel pump or fuse or relay.
14. Tilt sensor needs a reset.
15. Security system not disarming alarm needs a reset.
For more information about your issue and valuable "FREE" downloads that you will need please click on the links below. Good luck and have a nice day.
955i won start Problem Solving Tech Forums Messageboard Triumph Torque
Sprint RS Starting problem
Topic 2005 Triumph Daytona 955I Will not Start Read 8797 times
Triumph Sprint RS 1999 2004 Factory Service Repair Manual Download Manuals...

Jun 08, 2016 | 2001 Triumph Sprint RS

1 Answer

My Triumph Street Triple displayed the ECU malfunction light after a flat battery which has since been satisfactorily charged. How can I reset the ECU so my bike doesn't remain in limp home mo


You could try the 12 minute tune which I think is appl;icable to this model.This resets most issues.
Start the bike from cold...do not touch throttle then wait til fan comes on then time 12 minutes exactly then turn bike off.If this dont work go to a dealer so they can plug into the ECU and find out the cause..

Sep 17, 2014 | 2013 Triumph Street Triple

1 Answer

Ignition wiring luck


if its running leave it alone its probably a connection for a different model. companies use standard wiring harnesses for most of there bikes and just omit some wires for different bikes.

Jul 11, 2013 | 1998 Triumph Triumph Thunderbird

2 Answers

2000 Triumph Legend TT no spark


Buy a wiring diagram and figure it out.

Jul 14, 2017 | 2000 Triumph Legend TT

1 Answer

Backfiring


Hi, Les I feel your pain your issue deserves 2 answers if you take your bike to a dealer for a specific issue that costs outrageous amounts of money only to have the same problem 2 days later your situation is not unique unfortunately and it is a double edged sword. First, you suffer the emotional stress and frustration of spending all your hard earned "Drachma" and your bike does not get fixed. Second, comes the realization that not only are the technicians incompetent but also the service manager for not doing anything about it, this isn't rocket science, it's a glorified lawn mower engine with extra cylinders and carburetors sometimes. You need to put an end to all the double talk, dancing around the issue, and a "we don't care" attitude, but how you ask, very simple you exercise the "nuclear option" go back to the dealer and ask to speak to the owner or general manager if the owner is not there, then with a straight face and polite voice you ask him/her if they can provide you with the name and contact phone number of the person at your brand motorcycle headquarters in your country that can recommend a repair facility that will fix your bike because your local dealer either can not or will not. I guarantee you that is all the grease you need to get someone to light a fire under the proper persons rear end to resolve your issue "toot sweet"
2nd answer and the usual suspects are:
1. Severely discharged or a damaged battery, should have 12.5 volts or better and be able to pass a load test if necessary.
2. Check battery terminals for damage or corrosion, check the battery cables at "BOTH" ends for loose, corroded, or broken connectors, "INSIDE" and outside the cable harness, perform connector wiggle test and check cables with an ohmmeter if necessary.
3. Faulty main circuit breaker and or connections.
4. Faulty ignition coil and or connections.
5. Faulty spark plug, oil or gas fouled, wrong heat range or service type, wrong gap, loose in the cylinder head, broken electrode or insulator.
6. Faulty spark plug cables, leaking or broken, internal damage check for spark leakage in the dark.
7. Faulty ignition module, switch, CKP, MAP, CMP, sensor and or any connector in the ignition circuit could have corroded, loose, or broken pins/sockets
8. Burnt exhaust valve or air leak in the exhaust system.
For more information about your issue and valuable "FREE" downloads that you will need please click on the blue links below. Good luck and have a wonderful day.
Curiosity on burbling and backfiring
back fires Problem Solving Tech Forums Messageboard Triumph Torque
http://www.bandofriders.net/forums/archive/index.php/t-73320.html
Triumph Daytona 955i 2002 Service Manual
http://www.worldoftriumph.com/triumph-motorcycle-parts.html
Triumph Daytona 955i Handbook

Mar 16, 2017 | 2002 Triumph Speed triple

1 Answer

2010 street glide throtle by wire, where does the 2plug black and white plug in?


Hi Ike, for more information about your question please visit the website below. Good luck and have nice day.
Throttle by wire installation video

Dec 06, 2011 | 2010 Harley Davidson FLHX Street Glide

1 Answer

No spark at plugs


Removed the sheathing on the seven-wire harness coming out from under the tank,may have been a poor connection in black-wire connecting link in the alarm system wiring harness between the light-gray-with-blue-stripe wire and the black-with-orange/red stripe wires, which in turn was intermittently shutting off the igniter box and resulting in no spark and the bike not starting. Re fix this

Apr 11, 2011 | 1999 Triumph Trophy 900

1 Answer

2004 Triumph daytona 955i. 4000 miles. Was riding and all of a sudden bike dies, no power to lights speedo or any gauges, starter button wouldnt work. Pushed home and turned key on all lights worked and...


Hi, The_redneckc and the usual suspects are:
1. Severely discharged or a damaged battery should have 12.5 volts or better and be able to pass a proper "LOAD" test if necessary your battery may show 12.5 volts or more but have little or zero amps and must be replaced.
2. Failed alternator/generator and or voltage regulator.
3. Loose or corroded battery terminals and or cables especially the "NEGATIVE" cable, look for loose, corroded, or broken connectors inside the cable harness at "BOTH" ends.
4. Failed main circuit breaker or ignition switch, check for loose connections and continuity.
5. Failed system and or ignition relay, check for continuity.
6. Failed ignition coil, ignition/electronic module.
7. Failed CKP, CPS, CMP, MAP, TPS, or BAS sensor, corroded, loose or broken wire connector pins/sockets.
8. Throttle cables and or idle speed improperly adjusted hot idle speed should be 950 RPM to 1000 RPM.
9. Fuel tank empty.
10. Fuel tank contaminated with ethanol sludge.
11. Water or dirt in the fuel system, or clogged filter.
12. Restricted, blocked or kinked fuel line.
13. Faulty fuel pump.
14. Faulty pressure regulator.
15. Faulty or clogged fuel injectors.
For more information about your issue and valuable "FREE" downloads that you need please click on the blue links below. Good luck and have a wonderful day.
2002 955i Daytona Quits while running and then will not start
Topic Starting Issue on 2005 Triumph Daytona 955I RUNNING AGAIN Read 8197...
Triumph Daytona 955i 2002 Service Manual
Hermys Triumph Motorcycle Parts 2004 Triumph Genuine Body and frame...
Triumph Daytona 955i Handbook

Apr 17, 2017 | 2004 Triumph Daytona 955i

Not finding what you are looking for?
2010 Triumph Street Triple R Logo

185 people viewed this question

Ask a Question

Usually answered in minutes!

Top Triumph Experts

Arnie Burke
Arnie Burke

Level 3 Expert

4514 Answers

yadayada
yadayada

Level 3 Expert

75077 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

Are you a Triumph Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...