Question about 2000 Harley Davidson FLHTCUI Electra Glide Ultra Classic

1 Answer

Popping 15amp fuse for speedo & blinkers constantly

Front light bar was removed but harness is still hooked up. Could this be what is causing the 15amp accessory fuse which also runs the blinkers and speedo to trip.

Posted by Anonymous on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Harley Davidson Master
  • 3,506 Answers

You could have created a short circuit when the light bar was removed. You will have to trace it down to find out where the problem is.

Posted on Oct 18, 2014

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

goalie39
  • 469 Answers

SOURCE: 2006 Screamin Eagle Fat Boy- tach, speedo, blinkers not working

You've blown a fuse, check the fuse block. it should be an accessory fuse.

Posted on Apr 13, 2009

wd4ity
  • 4565 Answers

SOURCE: I keep blowing the accessory fuse on my electra glide

I'd say that you have an intermittant short somewhere. These are very difficult to find. I'd start at the tail light assembly as most of the time, I've found the shorts in that area, from the seat back to the tail light assembly.

Good Luck
Steve

Posted on Jun 04, 2010

dcramer531
  • 1654 Answers

SOURCE: bike 2002 dyna wideglide speeo

First of all electrical problems on these bikes are hard to diagnose, especially on the computer. I assume you checked all your fuses and wires for any obvious shorts or blown fuses. Sounds like a wire might have melted in the heat and shorted out.Check the wiring from your ECM to the speedo under the gas tank and around the motor to make sure nothing shorted out.
Then if nothing found there is the Speed sensor located on top of the transmission. Remove, clean all debris off of it and reinstall. If that doesn't correct the issue, the sensor may need to be replaced.

Posted on Jan 26, 2011

Skrewloose1
  • 98 Answers

SOURCE: 2010 haritage softail clasic -

that panel you are talking about is held on by a 1/2 inch nut right in the middle. and if you remove the seat, you should see a small torx screw around where the **** area is. Once you remove the panel, you will see where the fuel pump is and there will be a connector and a blled off, you can disconnect these. Although the are only power to the pump, you have to disconnect it to remove the tank. Make sure you disconnect the fuel level gauge. and the fuel interconnect. Did you say that when you unplugged the rear connector, you stopped blowing fuses?? This would mean your short is somewhere in that harness. Look under the rear fender for exposed wires, is your tail light after market?? if so look for grounding on the unit, make sure all connectors are connected and no loose wires. If your looking for short on the ignition, remember the ampres given by the ignition system is so great, it will blow your Maxi fuse, so I would pull out a wiring diagram and trace all wires to and from that connector in the rear to the fuse block. Hope this helps, electrical issues are always difficult to diag, over the internet lol Doc

Posted on May 03, 2011

SOURCE: Riding into work on a

Underneath the center dash or seat there is the control module for the lights / speedo ensure that it did not come unplugged. Same problem happened to me on my 2004 Big Dog Pitbull which uses a very similiar module as your road king.

Posted on Sep 23, 2011

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

Right turn signal possible short


the wire is shorted.

trailer hitch hack job.

collision damage to rear.? wrecked the harness.



why would the flasher be bad, if left side front and rear works perfectly

we use a 15amp circuit breaker to replace the flasher fuse.

then find the short, (beaker keeps popping) when right turns are selected.

is this car under warranty?

did some one put in an illegal larger fuse in this circuit? dont

its a simple shorted line

we have a thing (real edison like) called an ammeter

we can measure the actual short, all look here its 15amps

just as the breaker trips, bingo city

then all we do is start pulling all inline connectors to find the section that is shorted, front or rear.



does that help?:

Jan 07, 2015 | 2011 Kia Sedona

1 Answer

I have a 2000 night train where the previous owner disconnected blinkers. fronts are gone but would like to hook up rear. will rear blinkers work if the fronts are not installed. Also speedo has been...


Yes, the rears should work but, if the front wires haven't been capped properly you might blow a fuse. Not sure about the speedo but, you'll have to determine how it was installed originally and where your electrical hookups are.

Jan 16, 2014 | 2000 Harley Davidson FXSTB Night Train

1 Answer

Brake light works but my tail lights and blinkers arent working on my 5150 kikker


1. Are all your blinkers out (front and back)?
2. did you replace the old ones with LED?
3. 5150 kicker im assuming is probably a build bike, with maybe an S&S Evo engine?
4. Is you speedo/dash still operating correctly?

Heres what im thinkin,

Check for blown fuses.
Check the wiring between you blinkers and taillight, usually it runs on the same harness with the connector somewhere under your seat.
If it is a build bike, im assuming its carburated and does not have an ECM, which then it would run on a flasher relay.
If it is hooked up to say a TSM, then you may need a load equilizer.
I would also check the wiring from your switches, and check the switches as well.

Apr 22, 2011 | Harley Davidson XL 883 R Sportster...

1 Answer

Hello and thanks for your time, I have a 92 0lds cutlass with over 170,000 miles at speeds of above 60 I start blowing fuses it started with turn right turn signal, I changed fuse it did it again, I...


what i think is happening is when you travel fast the wind and bumps are causing a wire to short and blow the fuses. a bad ground will cause this also. If you do not exceed 60 the fuses dont blow ? At times like these i do alot of hands on and visual checks of connections and grounds by wiggling them and having a helper listen for a fuse to pop and by touching that wire then you know that was the problem. If i don't have a helper i wait till dark and turn on car lights or blinker what ever seems to go out and i will wiggle wires in the dark looking for small sparks indicating a short.

Apr 03, 2011 | 1992 Oldsmobile Cutlass Ciera

1 Answer

Speedo, tach, blinkers, and brake lights quit working.


The blinkers and brake lights work off the lights fuse. Not sure if the speedo and tach do but I'd check the fuses to see if you have a blown fuse.

Good luck
Steve

Aug 14, 2010 | Harley Davidson FLHTC Electra Glide...

1 Answer

TURN SIGNAL, BRAKE & HAZARD LIGHTS


No Turn Signal Operation (blinker)The turn signal lights in your car are a basic electrical system that controls the front and rear blinker lights to alert the intended direction of the vehicle. We have listed some of the most common problems and repair troubleshooting tips below:
Troubleshooting Procedure
To start troubleshooting this problem:
  • Turn the key to the on position (do not start engine)
  • Inspect the system fuse located in the fuse panel and replace if needed. If you cannot find the location of the blinker fuse consult your owner's manual or an online repair manual
  • When a blinker flasher fails it can cause blinker lights to say on, not blink, or not go on at all. To test the blinker system flasher, remove the flasher unit and insert a jumper wire between the two terminals. If blinker stays on in both directions without blinking, replace the flasher. If you cannot find the location of the blinker flasher consult your owners manual or an online repair manual.
  • 1b7f814.jpg

Jul 09, 2009 | 1999 GMC Denali

3 Answers

Trailer light hook up problem


It sounds like your have may have your brake light and running lights crossed on your wiring harness to the trailer. Good luck and hope this help's

Apr 08, 2009 | 2004 GMC Envoy

2 Answers

Pressing brake causing blinker issue


The trailer harness that was installed probably has a short inside the box that distributes power to the trailer pig-tail. Remove the trailer harness. You problem will be cured.

Jan 27, 2009 | 1999 Toyota 4Runner

Not finding what you are looking for?
2000 Harley Davidson FLHTCUI Electra Glide Ultra Classic Logo

110 people viewed this question

Ask a Question

Usually answered in minutes!

Top Harley Davidson Experts

Arnie Burke
Arnie Burke

Level 3 Expert

4514 Answers

Gills Lango

Level 2 Expert

195 Answers

Mike

Level 3 Expert

4336 Answers

Are you a Harley Davidson Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...