Question about 2008 Yamaha C3

1 Answer

No electricity at all

I took my scooter out of storage from winter 2 weeks ago and it started right up with the electric start. I drove it around and then it started to putter and die. I had to kick start it and drive it slow to get it back home. Now today I went to go start it and when I turn the key I get nothing. No dash lights or sound. Kick start wont work either. I charged the battery and still nothing. The kill switch is not on, the battery was tested and works, I even checked the volts on the wire right by the ends of the battery clamps. Everything seems fine, yet I get no dash lights or anything. I checked the fuse right by the battery and it was fine also. Not really sure what else to do. Is there another fuse spot? Maybe a wire broke somewhere from the battery? I'm not really sure what else could cause a complete loss of power... Any help would be great. Thanks

Posted by on

  • greg Mar 31, 2014

    have you checked all the wires around the whole scooter the same thing happened to me and i found out that i just had a split wire

×

1 Answer

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

I would check the wires around the whole scooter any wire that is split will cause this problem

Posted on Mar 31, 2014

5 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

  • 1810 Answers

SOURCE: DT125 no electrics! non starter

how about replacing the fuse by the battery it is a master fuse and thats what it sounds like
since all lights and bike runs after a bump it sounds like a master fuse problem
if not check your batterie ground it might be cut or loose

Posted on Aug 04, 2009

  • 15 Answers

SOURCE: My 2003 WR 450F was easy to kick start/push button

Did you check the carb? The float might be stuck traping liquid in it, causing it to act like its flooded. Or the Jet could be plugged up?

Posted on Nov 06, 2009

mwoodring1
  • 496 Answers

SOURCE: i have a 2004 pw80 with no fire

volt ac or dc?? why did you put the top end on?? i have seen pick ups go bad and the mag. let my know about the top end. on the coil i can check the specs so you can check it. you can give me a call at the shop or i can send it to you hear.
C.C. Motorsports (361) 885-7787
242 westchester dr.
Corpus Christi TX 78408
Mark

Posted on Mar 26, 2010

emissionwiz
  • 74945 Answers

SOURCE: will be riding for about

Hello
Have the battery load tested, a fully charged battery is about 14.2 volts, and then have the Alternator output tested, it sound like the battery is not being charged, it should have about 14.0 volts at 1500RPM, if not then the Alternator is defective. If nothing shows you will need the bikes electronic engine control system tested by the dealer for system fault codes.

Posted on May 22, 2011

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have an error code of 7 Flashes = drive lever not central, but it is.


hi, the lever maybe but is the actual throttle pot stem ? look a the screw slot located a the end of the pot stem ? bet you it's slightly to the left or right ...

Regards
Rob

www.gewizrepairs.co.uk

Mar 10, 2015 | Electric Strider Midi 4 Wheel Mobility...

1 Answer

2008 Highlander will not start. Makes a ticking noise when pressing keyless start


Immobiliser ?
Try this thread it may help - http://www.helpowl.com/a/Toyota/2008-Highlander/Research/5115?search=2008%20toyota%20highlander%20vsc%20check%20engine%20light

Mar 19, 2014 | 2005 Toyota Highlander

1 Answer

My 2005 malibu has been a great dependable whip untill this past year. Living in utah winters r extremely cold. Last winter was below freezing and killed my battery. I kept a portable battery pack for two...


Your fuel injectors don't like water and this can damage them, you need to get your injectors tested to see if they are supplying the correct volume of fuel and have a correct spray pattern, Damaged injectors would explain your symptoms.

Mar 03, 2012 | 2008 Chevrolet Malibu Classic

1 Answer

I have a 2008 Hyundai Accent. About 2 weeks ago my car wouldn't start after driving perfectly fine and parked for only 10 minutes. Took it to O'Reilly's and Autozone and all locations said that the...


after u had it jumped u drove it to the zone so the alternator was workin--it seems like the regulator is not functionin to charge batt--theres somethin goin on in the electrics thats frying ur reg these new cars r very complex--do a scan to see any bad codes and a harness wire chec may be helpful

Aug 15, 2010 | 2008 Hyundai Accent

1 Answer

When i plug up my charger to my electric scooter it says that it is fully charged but when i unplug it it doesnt move at all


I had a similar problem. When scooter purchased, gave it the full 8 hr charge. Was great. Husband did not bring batteries n that winter from unheated building. If left in cold a trickle charger needs to be on it. Easier to take out and bring in.

Same thing happened. Would charge and said fully charged but one battery(has 2) had a dead cell from being out in the cold. Took to batteries plus(very reasonable) had it checked and purchased.new one. Put in and gave it a full charge. Wonderful ever since. Use it at horse shows to run from trailer to stalls to arena and all over. Constantly forget to turn switch off and still comes through for me. It appears to go into a sleep mode when you forget to switch off. When back to trailer to sleep plug it in. The first 2 days of a 7 day circuit didn't plug in but then started to whenever I took it back to trailer as the strip sign says on platform. Duh!! Love it, love it love it!!!

Jun 11, 2009 | Electric Currie EZIP 500 Scooter

1 Answer

97 Chevy Blazer - good battery, good alternator...still dies???


check battery voltage when you turn off car. it should be 12.5 volts.if drops 11.0 volts the battery is got a weak cell in it.i bought a sears die hard battery it last 2 years the battery had a defect .it had a bad cell it short out the battery.check alternator wires for defects.

May 29, 2009 | 1997 Chevrolet Blazer

1 Answer

97 Chevy Blazer - good battery, good alternator...still dies???


if you removed the dome lightbulb then there is no longer a draw from the battery there but if the ashtray light light does not go out then over a period the battery will go dead or drained to the point to not the vehicle

Mar 05, 2009 | 1997 Chevrolet Blazer

1 Answer

89 Honda Prelude SI- Wont start


sounds like your on the rite track . clean the contacts at the batt and at the starter and get back to me

Feb 19, 2009 | 1990 Honda Prelude

Not finding what you are looking for?
2008 Yamaha C3 Logo

176 people viewed this question

Ask a Question

Usually answered in minutes!

Top Yamaha Experts

dhnguyen

Level 2 Expert

281 Answers

Steve Sweetleaf
Steve Sweetleaf

Level 3 Expert

1144 Answers

Tony

Level 3 Expert

2600 Answers

Are you a Yamaha Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...