Question about 2010 Piaggio MP3 125ie

1 Answer

Press starter button and nothing happens

All other electrics appear ok . All lights on dash, brake light and horn OK

Posted by Anonymous on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Habit-Forming:

    Visited the website for 3 consecutive days.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

  • Expert
  • 44 Answers

How familiar are you with the Piaggio MP3 ?

For the electric starter to operate, not only does the ignition key have to be turned to the on position AND the ENGINE STOP SWITCH
Press starter button and nothing happens - 4c5a26a4-8f3e-4f2a-92bc-1dd0107fdb36.jpg

be in the RUN position .....

BUT you must also APPLY REASONABLE PRESSURE to either of the BRAKE LEVERS.

On another note, the MP3 has an IMMOBILISER
There is a TRANSPONDER CHIP in the IGNITION KEY that is detected by the bike's "security system" and the CODE in it is read and compared to the one stored on-board.

I've never tried to start a MP3 with a key that has the wrong code or the transponder chip missing, BUT, if it is the same as my car (Ford Mondeo) the STARTER MOTOR DOES NOT TURN - NOT EVEN A CLICK

Posted on Apr 03, 2014

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Ignition problem on my gs750l 1981gs75x engine


1st Thing Iam Back *245

make sure you dont have the solenoid wires hook backward

Apr 03, 2015 | 1981 Suzuki GS 750 L

2 Answers

How to fix Cruise Control


The most common problem on this vehicle is the sensor right on the master brake cylinder the seal goes out and brake fluid gets right in the sensor ruining it that is the most common problem lete no if it helps

Sep 22, 2014 | 2001 Ford Windstar

1 Answer

2001 aurora won't start at all. Hook batery up horn horn sounds and doesn't stop head lights stay on but nothing happens when the key is inthe ingition. No clicking or anything at all. alarm on...


The security system does not disable the starter, it only disables fuel to the engine. In the fuse block under the hood, locate the STARTER relay. Place your hand on this relay and see if it clicks while someone else turns the key to start...if the relay is ok then the starter itself is faulty. Good luck, i hope this helps.

Jul 11, 2011 | 2001 Oldsmobile Aurora

1 Answer

Key inseeted and turned to on position. Green neutral light appears as per normal. No noise of fuel pump filling carbs. Absolutely nothing when start button pressed. Headlight and horn work ok. Any...


Could be your starter solenoid has gone.
You will need to check if power is getting too it when you press the starter.
Also check the kill switch, side stand switches etc.

---


Please dont forget to vote this answer was helpful.

Many thanks

------

Mar 01, 2011 | 2000 Yamaha V-Max

2 Answers

My brake lights wont work,i checked all the fuses,bought new bulbs,and bought a brake switch,and still nothing.my regular lights come on,just my brake lights dont work.dont no if this is part of the...


Just had a similar problem. Brake (stop) lights and horn didn't work. Couldn't find mention of stop lights in fuse chart. Found horn fuse to be slot 21 in the engine fuse block (not the fuse block in car interior). Replaced 15A fuse and all now ok.

Aug 21, 2009 | 2005 Mazda 3

1 Answer

1996 isuzu rodeo problem


TO TROUBLE SHOOT ELECTRICAL YOU MIGHT NEED TO TRY A GOOD BULB OF CORRECT TYPE INTO SOCKET IN BRAKE FIXTURE THEN ALSO MAKE CERTAIN THE REGULAR TAIL LIGHT ELEMENT IS GOOD REPLACE FUSE WITHOUT PRESSING BRAKE LIGHTS ON IF FUSE IS OK THEN TURN ON THE RUNNING LIGHTS SEE IF THE ONE IN QUESTION IS COMING ON IF IT IS AND THE FUSE IS OK THEN PRESS BRAKE PEDAL AND SEE IF THE BULB LIGHTS WITH THE BRAKE ON ALSO THE FOUR WAY FLAHER IF FUSE IF STILL GOOD IT MIGHT ALLOW DASH LIGHTS TO COME ON MANY VEHICLES HAVE A SAFETY WAY OF LETTING YOU KNOW YOU HAVE NO TAIL LIGHTS BY ALSO TURNING OFF THE DASH LIGHTS.

Nov 09, 2008 | 1995 Isuzu Rodeo

Not finding what you are looking for?
2010 Piaggio MP3 125ie Logo

227 people viewed this question

Ask a Question

Usually answered in minutes!

Top Piaggio Experts

Arnie Burke
Arnie Burke

Level 3 Expert

4514 Answers

Joseph Hoffmann

Level 3 Expert

1702 Answers

Andrew Taylor
Andrew Taylor

Level 3 Expert

14584 Answers

Are you a Piaggio Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...