Question about 2008 Gilera Stalker

Open Question

Accelerating but no power

Looses power

Posted by Anonymous on

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Trac light on loose power when accelerate ?


hook up scanner to retrieve codes this will indicate your problem

Oct 22, 2015 | 1994 Lexus LS 400

1 Answer

Engine started loosing power during acceleration.


Sounds like one of your Catalytic convertor's are plugged up.

Jun 05, 2013 | 1999 Kia Sportage

2 Answers

2002 isuzu trooper looses power on climbing, not responding to acceleration


Is the transmission dropping down to lower gear when climbing ? (automatic only ) Will it accelerate good to pass on level road?
Proper fuel pressure, and possible exhaust restriction, such as partially plugged/plugged catalytic converter, are 2 things I would check as well. All provided engine is also in good shape to begin with.

Apr 09, 2012 | 2002 Isuzu Trooper

1 Answer

Very poor acceleration through all gears


diesel pump might not be working right. Try and check fuel pressure. I dont know if its turbo but if the turbo is failing then you will loose power

Feb 05, 2010 | 2006 BMW 5 Series

1 Answer

Momentarily Sluggish Acceleration


Are you loosing power to the ecu when the car is shut down? most cars with an ECU that controls timing, fuel, or boost can be forced to relearn the car if the ECU looses power (called a "limp" mode). I'd look into this. Also are you getting any check engine lights? considering the description of the problem, this would help to diagnose. Try getting the car started and running normally, then turn the car off but do not kill the power to the car, just stop the motor from running...Fire the engine back up and try to give the car a good stomp on the gas and see if you get the same sluggish problems...my 2 cents... Good luck future auto DIY's

Apr 16, 2009 | 2003 Volkswagen Jetta TDI

2 Answers

Loss of power when accelerating


the problem was caused by a loose ignition wire
Carl

Jan 10, 2009 | 2005 Subaru Impreza

Not finding what you are looking for?
2008 Gilera Stalker Logo

Related Topics:

14 people viewed this question

Ask a Question

Usually answered in minutes!

Top Gilera Experts

Arnie Burke
Arnie Burke

Level 3 Expert

4521 Answers

yadayada
yadayada

Level 3 Expert

76118 Answers

Fabrice Wolters

Level 2 Expert

265 Answers

Are you a Gilera Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...