Question about 1999 kawasaki ZX-7R

1 Answer

Wont fire up after its been running a whlie

Bike seems not to be getting any fire after its been running awhile

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Sergeant:

    An expert that hasĀ over 500 points.

    Champion:

    An expert who has answered 200 questions.

  • kawasaki Expert
  • 391 Answers

May have a vapor lock in the fuel line. Rerouting the line may help. If you are in a jam, try putting ice on the fuel lines, I know, it's gonna be tough but it will solve a vapor lock.

Posted on Apr 13, 2014

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Engine Vibration and noise after riding awhile


Maybe it is not firing properly on one cylinder. Have you changed plugs? It may also be that the coil is breaking down when hot. You might be able to check this with a coils tester if anyone has one anymore. Suzuki used to have a very good one. Very expensive Suzuki tool though. Cheaper to try a new coil. Also you might check HT wires when hot if the foregoing does not fix it. Next place I would go is try to isolate which cylinder it is and check/replace the fuel injector. This is assuming no mechanical faults. However you have POWER VISION and so it could also be something errant there.

Feb 10, 2014 | 2013 Harley Davidson Road King Base

1 Answer

Wont start at all


If you have no light you can't even hot wire it sounds like the ignition switch is bad in the start and run positions.

Jan 30, 2014 | 2005 Yamaha YZF-R6

1 Answer

Faulty charging system


ck. the voltage at the batt. with it running should be 13 volts

Jun 15, 2012 | kawasaki VN 1500 Vulcan Classic...

1 Answer

My yamaha 1998 royal star xvz 1300 wont stay runin runs on choke then wen u take it off will shut off ...?


If the bike sat through winter...carbs may be gummed up on idle circuit....could try a product like Seafoam ...add to tank.....run for awhile to get the treated gas in carbs....then let it sit a day and retry.
You're certain its actually firing on all 4 plug wires?

Apr 05, 2011 | 1998 Yamaha Royal Star XVZ 1300 A

1 Answer

My bike runs real good and starts easy but just


Sound like the magneto is not charging the battery properly, and your bike is then running off the battery while running, sending it flat.

To test this, start the bike, then remove the battery from the bike, it should be able to run without the battery connected. Make sure the positive lead does not touch metal on the bike.

Using a multimeter, check that you have 13.8 volts at the battery while the bike is running, anything less than this and your bike is not charging the battery properly.

Jul 26, 2009 | 1982 Suzuki GS 650 GT

1 Answer

Im looking for some help finding some carb rebuild kits and maybe some bigger jets as i'm going to run open element air filters. The filter manufacture said to run 25% bigger jets. The bike gets spark and...


if it has been sitting for awhile you might need to clean the carbs -clean the stock carbs and get it running before making changes -check comp. as well-bike bandit seems to have a good selection of older bike parts

Jun 26, 2009 | 1980 Yamaha XS 650 G

1 Answer

LEAKING FUEL


You need to get some new float needles, and have the carbs cleaned and the float heights set correctly.

May 30, 2009 | 2000 Suzuki GSX-R 600

2 Answers

It wont stay running in stalls out from time to time


Change the fuel filter,clean the carb jets again,and replace the air filter.This should take care of it but sometimes when they sit for awhile,you will need to clean the carbs numerous time as the gunk in the tank continues to wash down into the carbs.

May 03, 2009 | 1996 Suzuki GSX 750 F (Katana)

2 Answers

STALLING AND LOSING POWER WHILE RIDING


If battery is running down. The engine may not be charging the battery. Check charging system. If running on battery, the bike will run fine for awhile then die as the battery can no longer provide spark to the engine. If charging system is less than 13.0 volts could be a ad stator or regulator. Make sure the battery posts are clean, a bad ground can cause problems too.

Apr 30, 2009 | 2000 Yamaha YZF-R6

2 Answers

Missfire on my xv535


THIS IS A FUEL PROBLEM IF IT RUNS OK WHEN COLD IF THE BIKE DOES THIS AT START UP IT WILL BE THE TIMING IS OUT

Feb 15, 2009 | 1998 Yamaha XV 535 Virago DX

Not finding what you are looking for?
1999 kawasaki ZX-7R Logo

59 people viewed this question

Ask a Question

Usually answered in minutes!

Top kawasaki Experts

Arnie Burke
Arnie Burke

Level 3 Expert

4514 Answers

yadayada
yadayada

Level 3 Expert

75051 Answers

Gino Cussen
Gino Cussen

Level 2 Expert

216 Answers

Are you a kawasaki Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...